在线检测未来函数

主图叠加MACD KDJ RSI(飞狐)

来源:Internet,编辑:股旁网,2010-05-24

主图叠加后,保持了原指标的波动趋势,总体效果尚可,但有些个股效果不是很好。
叠加到主图上,方法也有好多种,并非创新,但有人喜欢这样使用,故发上来。
叠加MACD
前收:=DYNAINFO(3);
DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))+前收;
DEA:EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
STICKLINE(MACD>0,前收,前收+MACD,0,1),COLORf00ff0;
STICKLINE(MACD<0,前收,前收+MACD,0,1),COLOR00ff00;

叠加KDJ
前收:=DYNAINFO(3);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*2+前收;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
J:3*K-2*D;

叠加RSI
前收:=DYNAINFO(3);
LC:= REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*5+前收-2;
RSI2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*5+前收-2;
RSI3:SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*5+前收-2;

 

相关文章