在线检测未来函数

通达信超强KDJ公式

来源:Internet,编辑:股旁网,2010-05-29

为克服KDJ指标在高位钝化的不足,网友试将参数重新调整,经试用效果还可以

{INPUT:N(25,1,999),M1(5,1,999),M2(5,1,999);}
N:=25;
M1:=5;
M2:=5;
RSV:=(CLOSE-LLV(LOW,N))*(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,3,1),COLORWHITE,LINETHICK2;
D:SMA(K,3,1),COLORYELLOW,LINETHICK2;
J:3*K-2*D,COLORYELLOW,LINETHICK2;
IF(K<REF(K,1),K,DRAWNULL),COLORGREEN,LINETHICK2;
IF(D<REF(D,1),D,DRAWNULL),COLORGREEN,LINETHICK2;
IF(J<REF(J,1),J,DRAWNULL),COLORFFFF00,LINETHICK2;
IF(K>REF(K,1),K,DRAWNULL),COLORRED,LINETHICK2;
IF(D>REF(D,1),D,DRAWNULL),COLORRED,LINETHICK2;
IF(J>REF(J,1),J,DRAWNULL),COLORFF00FF,LINETHICK2;

通达信超强KDJ公式

 

相关文章