在线检测未来函数

通达信买卖盘公式

来源:Internet,编辑:股旁网,2010-05-30

成交量:=VOL;
VAR1:=成交量/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:(CLOSE>OPEN,VAR1*(HIGH-LOW),(CLOSE<OPEN,VAR1*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
卖盘:(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),(CLOSE<OPEN,VAR1* (HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
STICKLINE(买盘>卖盘,0,VAR1+买盘,3,0),COLOR000088;
STICKLINE(买盘>卖盘,0,VAR1+买盘,1.5,0),COLOR0000AA;
STICKLINE(买盘>卖盘,0,VAR1+买盘,1,0),COLOR0000CC;
STICKLINE(买盘>卖盘,0,VAR1+买盘,0.5,0),COLOR0000EE;
STICKLINE(卖盘>买盘,0,VAR1+买盘,3,0),COLOR008800;
STICKLINE(卖盘>买盘,0,VAR1+买盘,1.5,0),COLOR00AA00;
STICKLINE(卖盘>买盘,0,VAR1+买盘,1,0),COLOR00CC00;
STICKLINE(卖盘>买盘,0,VAR1+买盘,0.5,0),COLOR00EE00;
累积能量:MA(买盘-卖盘,5)*10,COLORCYAN,LINETHICK2;
累积能量2:MA(买盘-卖盘,10)*10,COLORYELLOW,LINETHICK1;
A0:=(L+H+C*2)/4;
A1:=EMA(A0,14);
A2:=EMA(A0,25);
A1X:=(A1-REF(A1,1))/REF(A1,1)*100;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100;
看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),CIRCLEDOT,COLORBLUE,LINETHICK0;
进:CROSS(累积能量,0);
DRAWICON(进,-1000*150,23)COLORMAGENTA;
BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2));
主买:=主动买/10000;
主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0- BB*(HIGH-LOW),0-VOL/2));
主卖:=(-主动卖/10000);
放量:主买/主卖>5;
STICKLINE(放量,买盘,买盘*2,4,0),COLORBROWN;
B:=ZIG(3,10);
G:=MA(B,2);
D:=CROSS(B,G);
STICKLINE(D,成交量,累积能量,1,0),COLORYELLOW;
DRAWTEXT(D=1,累积能量,'底');

通达信买卖盘公式

 

相关文章