在线检测未来函数

通达信KDJ中短线公式

来源:Internet,编辑:股旁网,2010-05-30

A2:=(HIGH+LOW+CLOSE*2)/4;
A3:=EMA(A2,17);
A4:=STD(A2,17);
A5:=((A2-A3)/A4*100+200)/4;
A6:=(EMA(A5,5)-25)*1.56;
T2:=(HHV(HIGH,3)+LLV(LOW,3)+CLOSE*2)/4;
T3:=EMA(T2,25);
T4:=STD(T2,25);
T5:=((T2-T3)/T4*100+200)/4;
T6:=(EMA(T5,20)-25)*1.56;
K1:=EMA(CLOSE,12)-EMA(CLOSE,26);
ST1:=EMA(K1,9);
ET1:=(K1-ST1)*2,COLORSTICK;
AK: EMA(A6,2)*1.22,LINETHICK2;
AD: EMA(AK,2),LINETHICK2;
AJ: 3*AK-2*AD,LINETHICK2;
BK: EMA(T6,3)*1.22,COLORWHITE,LINETHICK2;
BD: EMA(BK,3),COLORLIBLUE,LINETHICK2;
BJ: 3*BK-2*BD,COLORRED,LINETHICK2;
MA1:=MA(((3*C+L+O+H)/6),3),LINETHICK1,COLORGRAY;
IF(CLOSE>=SAR(4,2,20)*0.98,BD,DRAWNULL),LINETHICK1,COLORLIRED;
IF(CLOSE<=SAR(4,2,20)*0.98,BD,DRAWNULL),LINETHICK1,COLORBLUE;
DRAWICON(CROSS(MA1,SAR(4,2,20))=1,BD-10,7);
DRAWICON(CROSS(SAR(4,2,20),MA1)=1,BD+10,8);
DRAWICON(CROSS(AD,AK),AD+10,2);
DRAWICON(CROSS(AK,AD) AND UPNDAY((O+C)/2,1),AD-10,1);
DRAWICON(CROSS(AD,AK) AND AK<BK AND DOWNNDAY(MA(C,18),1),AD+15,12);
DRAWICON(CROSS(AK,AD) AND AK>BK AND UPNDAY(MA(C,18),1),AD-15,11);
LA:100;
LB:0;
LC:80;
LD:20;
IF(BD>=REF(BD,1) && ET1>=0,BD,DRAWNULL),STICK,COLORRED;
IF(BD<=REF(BD,1) && ET1<=0,BD,DRAWNULL),STICK,COLORBLUE;

通达信KDJ中短线公式

 

相关文章