在线检测未来函数

通达信精进MACD公式

来源:Internet,编辑:股旁网,2010-06-02

收距:=(INDEXC-EMA(INDEXC,12))/EMA(INDEXC,12)*100;
九收:=EMA(收距,9);
DIF2:(EMA(C,12)-EMA(C,26))/EMA(C,26)*100;
DEA2:EMA(DIF2,9);
DRAWBAND(DIF2,RGB(205,92,92),DEA2,RGB(28,134,238));
MACD2:(DIF2-DEA2)*2,NODRAW;
STICKLINE(MACD2>=0 AND MACD2>REF(MACD2,1),0,MACD2,2.5,0),COLORRED;
STICKLINE(MACD2<0 AND MACD2<REF(MACD2,1),0,MACD2,2.5,0),COLORMAGENTA;
D升:IF(DIF2>=REF(DIF2,1),DIF2,DRAWNULL)COLORRED,LINETHICK2;
M升:STICKLINE(MACD2<0 AND MACD2>=REF(MACD2,1),0,MACD2,2.5,0)COLORWHITE;
M降:STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,2.5,0)COLORYELLOW;
M位:(MACD2- LLV(MACD2,20))/(HHV(MACD2,20)-LLV(MACD2,20))*10,COLORRED,LINETHICK2;
上:IF(M位>REF(M位,1),M位,DRAWNULL),COLORRED;
下:IF(M位<REF(M位,1),M位,DRAWNULL),COLORGREEN,LINETHICK2;
D位:(DIF2-LLV(DIF2,20))/(HHV(DIF2,20)-LLV(DIF2,20))*10,COLORYELLOW;
E位:(DEA2-LLV(DEA2,20))/(HHV(DEA2,20)-LLV(DEA2,20))*10,COLORLICYAN;
DRAWICON(CROSS(E位,0.001),-9,13);
筑底:IF(M位=0 AND D位=0,-7,-10);
短底:IF(M位=0 AND D位=0 AND E位=0,-5,-10),LINETHICK2,COLORGREEN;
潜:IF(LAST(MACD2<0,5,0)AND MACD2>=REF(MACD2,1),-12,-10),COLORYELLOW;
DRAWICON(M位<10 AND REF(M位,1)=10,M位*0.985,2);
大盘超跌:IF(九收<=-5 AND DEA2<=-5,5,0);
有同学要的主图源码:
N:=21;
P:=13;
波段线:ZIG(3,P),COLORWHITE;
波段涨天:BARSLASTCOUNT(波段线>REF(波段线,1)),NODRAW;
VARO:=(C-REF(C,波段涨天))/REF(C,波段涨天)*100;
涨幅%:IF(波段涨天>0,VARO, DRAWNULL),NODRAW;
波段跌天:BARSLASTCOUNT(波段线<REF(波段线,1)),NODRAW;
VARV:=(C-REF(C,波段跌天))/REF(C,波段跌天)*100;
跌幅%:IF(波段跌天>0,VARV, DRAWNULL),NODRAW;
突破:REF(EMA(C,14),1)COLORMAGENTA,LINETHICK2;
A1X:=(EMA(C,14)-突破)/突破*100,NODRAW;
出击:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
休假:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK2;
STICKLINE(A1X>=0,出击,突破,0,-1)COLORRED;
STICKLINE(A1X<0,休假,突破,0,-1)COLORGREEN;
STICKLINE(CROSS(A1X,0),C,O,3,0)COLORYELLOW;
STICKLINE(CROSS(0,A1X),C,O,2,0)COLORGREEN;
压力:MA(REF(HHV(C,60),1),2),COLORRED,LINETHICK2;
支撑:MA(REF(LLV(C,60),1),2),COLORGREEN,LINETHICK2;
高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
P1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0);
P2:=今小前;
爱琴海:P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,COLORCYAN,NODRAW;
STICKLINE(爱琴海,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(爱琴海 ,OPEN,CLOSE,3.1,0 ),COLOR990000;
STICKLINE(爱琴海 ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(爱琴海 ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(爱琴海,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(爱琴海 ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(爱琴海 ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
DRAWICON(VAR19,L*0.975,1);
M1:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)),COLORGREEN;
M2:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),COLORGREEN,LINETHICK1;
M3:=IF(MA(CLOSE,17)<M2,M2,MA(CLOSE,17)),COLORGREEN,LINETHICK1;
支撑线:=M3-(EMA(C,3)-M3),COLORFF8080,LINETHICK1;
DRAWICON(CROSS(M3,支撑线),L*0.99,9);
{奥斯卡}
SC:=100*(CLOSE-MA(CLOSE,26)),COLORRED;
MAO:=EMA(SC,9),COLORYELLOW;
XG:=CROSS(SC,MAO);
STICKLINE(XG,支撑*0.965,支撑,3,0),COLORRED;

通达信精进MACD公式

 

相关文章