在线检测未来函数

同花顺大资金活动指标公式

来源:Internet,编辑:股旁网,2010-06-04

N:=27;N2:=9;N3:=3;N4:=16;
Var1:=IF(DATE>=1030131,1,1);
Var2:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
获利盘:WINNER(CLOSE)*100*Var1;
Var3:=SMA(Var2,3,1)*Var1;
Var4:=SMA(Var3,N2,1)*Var1;
Var5:=3*Var3-2*Var4*Var1;
Var6:=VOL*Var1;
角度:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100*Var1;
换手: VOL/CAPITAL*100*Var1;
Var7:=SUM(换手,30)*Var1;
Var8:=LLV(INDEXL,5)*Var1;
Var9:=HHV(INDEXH,5)*Var1;
VarA:=EMA((INDEXC-Var8)/(Var9-Var8)*100,4);
VarB:=MA(EMA(0.667*REF(VarA,1)+0.333*VarA,2),9);
VarC:=MA(VarB,30);
VarD:=EMA(获利盘,4)*Var1;
本盘亿股: CAPITAL/1000000;
V5: MA(VOL,5)*2*Var1;
V13: MA(VOL,13)*2*Var1;
CROSS(VarB,VarC) AND VarC<29*Var1;
STICKLINE(VOL AND Var5>Var4,0,VOL,9,0),color000055;
STICKLINE(VOL AND Var5>Var4,0,VOL,8,0),color000066;
STICKLINE(VOL AND Var5>Var4,0,VOL,7,0),color000077;
STICKLINE(VOL AND Var5>Var4,0,VOL,6,0),color000088;
STICKLINE(VOL AND Var5>Var4,0,VOL,5,0),color000099;
STICKLINE(VOL AND Var5>Var4,0,VOL,4,0),color0000aa;
STICKLINE(VOL AND Var5>Var4,0,VOL,3,0),color0000bb;
STICKLINE(VOL AND Var5>Var4,0,VOL,2,0),color0000cc;
STICKLINE(VOL AND Var5>Var4,0,VOL,1,0),color0000dd;
STICKLINE(VOL AND Var5<Var4,0,VOL,9,0),colorFF1100;
STICKLINE(VOL AND Var5<Var4,0,VOL,8,0),colorFF2200;
STICKLINE(VOL AND Var5<Var4,0,VOL,7,0),colorFF3300;
STICKLINE(VOL AND Var5<Var4,0,VOL,6,0),colorFF4400;
STICKLINE(VOL AND Var5<Var4,0,VOL,5,0),colorFF5500;
STICKLINE(VOL AND Var5<Var4,0,VOL,4,0),colorFF6600;
STICKLINE(VOL AND Var5<Var4,0,VOL,3,0),colorFF7700;
STICKLINE(VOL AND Var5<Var4,0,VOL,2,0),colorFF8800;
STICKLINE(VOL AND Var5<Var4,0,VOL,1,0),colorFF9900;
STICKLINE(VOL AND Var4<N4,0,VOL,9,0),color333333;
STICKLINE(VOL AND Var4<N4,0,VOL,8,0),color444444;
STICKLINE(VOL AND Var4<N4,0,VOL,7,0),color555555;
STICKLINE(VOL AND Var4<N4,0,VOL,6,0),color666666;
STICKLINE(VOL AND Var4<N4,0,VOL,7,0),color777777;
STICKLINE(VOL AND Var4<N4,0,VOL,6,0),color888888;
STICKLINE(VOL AND Var4<N4,0,VOL,5,0),color999999;
STICKLINE(VOL AND Var4<N4,0,VOL,4,0),coloraaaaaa;
STICKLINE(VOL AND Var4<N4,0,VOL,3,0),colorbbbbbb;
STICKLINE(VOL AND Var4<N4,0,VOL,2,0),colorcccccc;
STICKLINE(VOL AND Var4<N4,0,VOL,1,0),colordddddd;
RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
抛压:STICKLINE(CROSS(84,RSI),0 ,VOL,9,0),COLORFF0033;
STICKLINE(CROSS(84,RSI),0 ,VOL,8,0),COLORFF0044;
STICKLINE(CROSS(84,RSI),0 ,VOL,7,0),COLORff0055;
STICKLINE(CROSS(84,RSI),0 ,VOL,6,0),COLORff0066;
STICKLINE(CROSS(84,RSI),0 ,VOL,5,0),COLORff0077;
STICKLINE(CROSS(84,RSI),0 ,VOL,4,0),COLORFF0088;
STICKLINE(CROSS(84,RSI),0 ,VOL,3,0),COLORff0099;
STICKLINE(CROSS(84,RSI),0 ,VOL,2,0),COLORff00aa;
STICKLINE(CROSS(84,RSI),0 ,VOL,1,0),COLORff00bb;
VAR13:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR14:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR15:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR16:=(VAR13+VAR14+VAR15)/3;
VAR18:=IF(VAR16<=-20,10,0);
VAR19:=HHV(VAR18,10);
VAR20:=IF(VAR19 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
底部:STICKLINE(VAR20=20,0 ,VOL,9,0),COLOR005555;
STICKLINE(VAR20=20,0 ,VOL,8,0),COLOR006666;
STICKLINE(VAR20=20,0 ,VOL,7,0),COLOR007777;
STICKLINE(VAR20=20,0 ,VOL,6,0),COLOR008888;
STICKLINE(VAR20=20,0 ,VOL,5,0),COLOR009999;
STICKLINE(VAR20=20,0 ,VOL,4,0),COLOR00aaaa;
STICKLINE(VAR20=20,0 ,VOL,3,0),COLOR00bbbb;
STICKLINE(VAR20=20,0 ,VOL,2,0),COLOR00CCCC;
STICKLINE(VAR20=20,0 ,VOL,2,0),COLOR00dddd;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1);
VAR100:=100-3*SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1);
VAR111:=VARF<REF(VAR100,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
资金活动:STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,9,0),COLOR006600;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,8,0),COLOR007700;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,7,0),COLOR008800;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,6,0),COLOR009900;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,5,0),COLOR00aa00;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,4,0),COLOR00BB00;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,3,0),COLOR00CC00;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,2,0),COLOR00DD00;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,1,0),COLOR00EE00;
A8:=(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4;
B8:=A8*(1+ ((C+O+H+L)/4-SMA(C,10,1))/SMA(C,21,1));
D8:=A8+3*STD(A8,10);
DRAWICON(CROSS(B8,A8) AND A8>REF(A8,1) AND D8>REF(D8,1),0,1);

同花顺大资金活动指标公式

 

相关文章