在线检测未来函数

大智慧6均线资金主图指标公式

来源:Internet,编辑:股旁网,2010-06-04

帐户总数:extradata('散户线'),linethick0,PRECIS0;
户均持股:=(FINANCE2(37)/帐户总数)*10000;
ZH3:=ref(帐户总数,3);
HJ3:=ref(户均持股,3);
主动率:="卫东.主动率#day";
单数比:="卫东.单数比#day";
通吃率:="卫东.通吃率#day";
DRAWTEXTREL(5,13,'帐户总数(户):'+NUMTOSTRN(帐户总数,0)),Color0000FF;
DRAWTEXTREL(139,13,'户均持股(股):'+NUMTOSTRN(户均持股,0)),Color0000FF;
DRAWTEXTREL(290,13,'上涨家数:'+"卫东.上涨家数#day"+'家'),COLOR0000FF;
DRAWTEXTREL(390,13,'平盘家数:'+"卫东.平盘家数#day"+'家'),COLORFFFFFF;
DRAWTEXTREL(490,13,'下跌家数:'+"卫东.下跌家数#day"+'家'),COLOR00FF00;
DRAWTEXTREL(590,13,'主动率:'+NUMTOSTRN(主动率,2)+'%'),COLOR0033FF;
DRAWTEXTREL(690,13,'单数比:'+NUMTOSTRN(单数比,2)+'%'),COLOR00FF00;
DRAWTEXTREL(790,13,'通吃率:'+NUMTOSTRN(通吃率,2)+'%'),COLOR00FFff;
连红:LAST(CLOSE>OPEN),PRECIS0,color0000FF,linethick0;
连绿:LAST(CLOSE<OPEN),PRECIS0,color00FF00,linethick0;
M1:=5;M2:=10;M3:=20;M4:=30;M5:=60;M6:=120;
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);
MA6:MA(CLOSE,M6);
MA5:=EMA(C,5);
MA10:=EMA(C,10);
MA30:=EMA(C,30);
MA60:=EMA(C,60);
YCX:=MA5>=REF(MA5,1);
H1:=MAX(MAX(MA5,MA10),MA30);
L1:=MIN(MIN(MA5,MA10),MA30);
DRAWTEXT(H1<C AND O<L1 AND YCX AND MA30>REF(MA30,1) ,H*1.018,'【串串】'),COLORYELLOW;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000);
DD:=REF(LLV(CLOSE,120),1);
J:="KDJ.J";
DDZ:=DD*17;
DDY:=((QJ2+QJ4)-(QJ1+QJ3))/SUM(VOL,10)*100;
弄点钱玩:=CROSS(J,0) AND ((DDX>0 AND DDY>0) OR DDZ>400);
A2:="MACD.MACD"(26,12,9);
A1:=C/REF(C,1)<1.099 AND A2>REF(A2,1) ;
A3:=COUNT(DDX>0.045,10)>2;
弄点钱玩2:=弄点钱玩 AND DDX >0.055 AND DDY>0.07 AND A1 AND A3;
DRAWTEXT(弄点钱玩2>0,L*0.97,'【弄点钱玩玩】'),COLORYELLOW;
DRAWTEXT(FILTER(REF(L,1)<MA4 AND C>MA4,7),L*0.96,'短'),COLORMAGENTA;
{资金}
TODAY:=DYNAINFO(7)=CLOSE and (ORDER(1)=0 and ORDER(2)=0);{判断是否有理想数据}
{TODAY:="ddx.ddx"=0;}{判断是否有正版数据}
Ddmr:=IF(TODAY,("DDEDATA@BIGORDER"(1,2)-"DDEDATA@BIGORDER"(2,2)),(bigorder(1,2)-bigorder(2,2)))*vol/capital*100;
Ddmrs:=sum(Ddmr,0);
Chb:=IF(TODAY,"DDEDATA@BIGORDER"(1,3),bigorder(1,3))*AMOUNT;
Dhb:=IF(TODAY,("DDEDATA@BIGORDER"(1,2)-"DDEDATA@BIGORDER"(1,3)),(bigorder(1,2)-bigorder(1,3)))*AMOUNT;
Zhb:=IF(TODAY,("DDEDATA@BIGORDER"(1,1)-"DDEDATA@BIGORDER"(1,2)),(bigorder(1,1)-bigorder(1,2)))*AMOUNT;
Xhb:=IF(TODAY,(1-"DDEDATA@BIGORDER"(1,1)),(1-bigorder(1,1)))*AMOUNT;
Chs:=IF(TODAY,"DDEDATA@BIGORDER"(2,3),bigorder(2,3))*AMOUNT;
Dhs:=IF(TODAY,("DDEDATA@BIGORDER"(2,2)-"DDEDATA@BIGORDER"(2,3)),(bigorder(2,2)-bigorder(2,3)))*AMOUNT;
Zhs:=IF(TODAY,("DDEDATA@BIGORDER"(2,1)-"DDEDATA@BIGORDER"(2,2)),(bigorder(2,1)-bigorder(2,2)))*AMOUNT;
Xhs:=IF(TODAY,(1-"DDEDATA@BIGORDER"(2,1)),(1-bigorder(2,1)))*AMOUNT;
散资:=(xhb-xhs)/10000;
中资:=(zhb-zhs)/10000;
大资:=(dhb-dhs)/10000;
超资:=(chb-chs)/10000;
超资增仓:=超资;
大资增仓:=大资;
中资增仓:=中资;
散资增仓:=散资;
BBD净额:=(超资+大资);
DRAWTEXTREL(5,85,'BBD (万):'+NUMTOSTRN(BBD净额,0)),LINETHICK1,Color0080FF;
DRAWTEXTREL(5,155,'超资(万):'+NUMTOSTRN(超资增仓,0)),LINETHICK1,COLORYELLOW;
DRAWTEXTREL(5,225,'大资(万):'+NUMTOSTRN(大资增仓,0)),LINETHICK1,Color62FFFF;
DRAWTEXTREL(5,295,'中资(万):'+NUMTOSTRN(中资增仓,0)),LINETHICK1,ColorACFFFF;
DRAWTEXTREL(5,365,'散资(万):'+NUMTOSTRN(散资增仓,0)),LINETHICK1,ColorFFFFFF;
DRAWRECTABS(0,118,270,0,1),COLOR00FF00;
zln:=REF(IF(TODAY,IF(TODAY,"DDEDATA@BIGORDER"(1,2),SELFDATA('特大买入 ')+SELFDATA('大单买入')),bigorder(1,2)),0);
zlm:=REF(IF(TODAY,IF(TODAY,"DDEDATA@BIGORDER"(2,2),SELFDATA('特大卖出 ')+SELFDATA('大单卖出')),bigorder(2,2)),0);
tdn:=REF(IF(TODAY,IF(TODAY,"DDEDATA@BIGORDER"(1,3),SELFDATA('特大买入 ')),bigorder(1,3)),0);
tdm:=REF(IF(TODAY,IF(TODAY,"DDEDATA@BIGORDER"(2,3),SELFDATA('特大卖出 ')),bigorder(2,3)),0);
ddn:=REF(IF(TODAY,IF(TODAY,("DDEDATA@BIGORDER"(1,2)-"DDEDATA@BIGORDER" (1,3)),SELFDATA('大单买入')),(bigorder(1,2)-bigorder(1,3))),0);
ddm:=REF(IF(TODAY,IF(TODAY,("DDEDATA@BIGORDER"(2,2)-"DDEDATA@BIGORDER" (2,3)),SELFDATA('大单卖出')),(bigorder(2,2)-bigorder(2,3))),0);
zdn:=REF(IF(TODAY,IF(TODAY,("DDEDATA@BIGORDER"(1,1)-"DDEDATA@BIGORDER" (1,2)),SELFDATA('中单买入')),(bigorder(1,1)-bigorder(1,2))),0);
zdm:=REF(IF(TODAY,IF(TODAY,("DDEDATA@BIGORDER"(2,1)-"DDEDATA@BIGORDER" (2,2)),SELFDATA('中单卖出')),(bigorder(2,1)-bigorder(2,2))),0);
sdn:=REF(IF(TODAY,IF(TODAY,1-("DDEDATA@BIGORDER"(1,1)),1-(SELFDATA('特大买入 ')+SELFDATA('大单买入')+SELFDATA('中单买入'))),1-(bigorder(1,1))),0);
sdm:=REF(IF(TODAY,IF(TODAY,1-("DDEDATA@BIGORDER"(2,1)),1-(SELFDATA('特大卖出 ')+SELFDATA('大单卖出')+SELFDATA('中单卖出'))),1-(bigorder(2,1))),0);
tdj:=tdn-tdm;
ddj:=ddn-ddm;
zdj:=zdn-zdm;
sdj:=sdn-sdm;
zlj:=zln-zlm;
DRAWTEXTREL(140,85,'占'+numtostrn(((zlj))*100,1)+'%'),Color0080FF;
DRAWTEXTREL(140,155,'占'+numtostrn((tdj)*100,1)+'%'),COLORYELLOW;
DRAWTEXTREL(140,225,'占'+numtostrn((ddj)*100,1)+'%'),Color62FFFF;
DRAWTEXTREL(140,295,'占'+numtostrn((zdj)*100,1)+'%'),ColorACFFFF;
DRAWTEXTREL(140,365,'占'+numtostrn((sdj)*100,1)+'%'),ColorFFFFFF;
DRAWTEXTREL(200,85,numtostrn(((zlj))*V,0)+'手'),Color0080FF;
DRAWTEXTREL(200,155,numtostrn((tdj)*V,0)+'手'),COLORYELLOW;
DRAWTEXTREL(200,225,numtostrn((ddj)*V,0)+'手'),Color62FFFF;
DRAWTEXTREL(200,295,numtostrn((zdj)*V,0)+'手'),ColorACFFFF;
DRAWTEXTREL(200,365,numtostrn((sdj)*V,0)+'手'),ColorFFFFFF;
DRAWTEXTREL(280,85,'仓 '+NUMTOSTRN(50+Sum((VOL/CAPITAL)*100*((zlj)),0),1)+'%'),Color0080FF;
DRAWTEXTREL(280,155,'仓 '+NUMTOSTRN(25+Sum((VOL/CAPITAL)*100*(tdj),0),1)+'%'),COLORYELLOW;
DRAWTEXTREL(280,225,'仓 '+NUMTOSTRN(25+Sum((VOL/CAPITAL)*100*(ddj),0),1)+'%'),Color62FFFF;
DRAWTEXTREL(280,295,'仓 '+NUMTOSTRN(25+Sum((VOL/CAPITAL)*100*(zdj),0),1)+'%'),ColorACFFFF;
DRAWTEXTREL(280,365,'仓 '+NUMTOSTRN(25+Sum((VOL/CAPITAL)*100*(sdj),0),1)+'%'),ColorFFFFFF;

大智慧6均线资金主图指标公式

 

相关文章