在线检测未来函数

通达信风度DDX指标公式

来源:Internet,编辑:股旁网,2010-06-09

ZF:=H-L;
CB:=IF(CAPITAL>0,AMOUNT/V/100,(H+L+O+C*3)/6);
DV1:=IF(ZF>0 AND C>CB,((H-C)/(H-CB))*((H-CB)/ZF*V),0);
UV1:=IF(ZF>0 AND C>CB,V-DV1 ,0);
UV2:=IF(ZF>0 AND C<CB,((C-L)/(CB-L))*((CB-L)/ZF*V),0);
DV2:=IF(ZF>0 AND C<CB,V-UV2 ,0);
UV3:=IF(ZF=0 AND C>REF(C,1),V,0);
DV3:=IF(ZF=0 AND C<REF(C,1),V,0);
UV:=UV1+UV2+UV3;
DV:=DV1+DV2+DV3;
DDX:(UV-DV),NODRAW,COLORRED;
五日红:COUNT(DDX>=0,5),NODRAW,COLORYELLOW;
十日红:COUNT(DDX>=0,10),NODRAW,COLORLIMAGENTA;
STICKLINE(DDX<0,0,V,3,1),COLORFF6600;
STICKLINE(DDX>0,0,V,3,1),COLOR000099;
STICKLINE(DDX<0,0,-DDX,3,0),COLORFF6600;
STICKLINE(DDX<0,0,-DDX,2,0),COLORFF9900;
STICKLINE(DDX<0,0,-DDX,1.5,0),COLORFFCC00;
STICKLINE(DDX<0,0,-DDX,0.5,0),COLORCYAN;
STICKLINE(DDX>0,0,DDX,3,0),COLOR000099;
STICKLINE(DDX>0,0,DDX,2,0),COLOR0000CC;
STICKLINE(DDX>0,0,DDX,1.5,0),COLOR0000FF;
STICKLINE(DDX>0,0,DDX,0.5,0),COLORCC66FF;
换手:V/CAPITAL*100,NODRAW;
DRAWTEXT(V/REF(MA(V,5),1)>=2,V*1.2,'★'),COLORYELLOW;
DDX1:EMA(SUM(DDX,13),2),COLORWHITE;
DDX2:EMA(DDX1,3),COLORYELLOW;
DDX3:EMA(DDX1,5}),COLORRED;

通达信风度DDX指标公式

 

相关文章