在线检测未来函数

同花顺猎庄主图指标公式

来源:Internet,编辑:股旁网,2010-06-07

大盘指数:INDEXC,NODRAW,ColorFFFF00;
止盈线:=EMA(C,7),LINETHICK1,colorwhite;;
PARTLINE(止盈线,止盈线>REF(止盈线,1),RGB(250,0,250),止盈线<=REF(止盈线,1),RGB(250,250,250)),LINETHICK2;
工作线:EMA(C,14),LINETHICK1,coloryellow;
生命线:EMA(C,25),colorred,LINETHICK1;
压力:HHV(C,20),Color00FF00;
支撑:LLV(L,20),ColorFFFF35;
MA3:=MA(C,3);
X1:=REF(EMA(C,3),1);
X2:=(EMA(C,3)-X1)/X1*100;
N1:=BARSLAST(CROSS(X2,0));
N2:=BARSLAST(CROSS(0,X2));
X3:=CROSS(X2,0) OR CROSS(0,X2);
STICKLINE(N1<N2,REF(MA3,N1),REF(MA3,N1),9,3),Color1EFFFF,LINETHICK2;
STICKLINE(N2<N1,REF(MA3,N2),REF(MA3,N2),9,3),ColorFFFFFF,LINETHICK2;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),ColorFFFF1E;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),ColorFFFF1E;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,10,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORffFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,10,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;
var9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
STICKLINE(var9Q,C,(O+C)/2,10,0),color000055;
STICKLINE(var9Q,C,(O+C)/2,8,0),color000066;
STICKLINE(var9Q,C,(O+C)/2,5,0),color000077;
STICKLINE(var9Q,C,(O+C)/2,4,0),color000099;
STICKLINE(var9Q,C,(O+C)/2,3,0),color0000bb;
STICKLINE(var9Q,C,(O+C)/2,2,0),color0000dd;
STICKLINE(var9Q,C,(O+C)/2,1,0),color0000ff;
varaQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
STICKLINE(varaQ,C,(O+C)/2,10,0),colorff11ff;
STICKLINE(varaQ,C,(O+C)/2,8,0),colorff33ff;
STICKLINE(varaQ,C,(O+C)/2,5,0),colorff55ff;
STICKLINE(varaQ,C,(O+C)/2,4,0),colorff77ff;
STICKLINE(varaQ,C,(O+C)/2,3,0),colorff99ff;
STICKLINE(varaQ,C,(O+C)/2,2,0),colorffbbff;
STICKLINE(varaQ,C,(O+C)/2,1,0),colorffddff;
varbQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
STICKLINE(varbQ,C,(O+C)/2,10,0),color333333;
STICKLINE(varbQ,C,(O+C)/2,8,0),color555555;
STICKLINE(varbQ,C,(O+C)/2,5,0),color777777;
STICKLINE(varbQ,C,(O+C)/2,4,0),color999999;
STICKLINE(varbQ,C,(O+C)/2,3,0),colorbbbbbb;
STICKLINE(varbQ,C,(O+C)/2,2,0),colordddddd;
STICKLINE(varbQ,C,(O+C)/2,1,0),colorffffff;
varcQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
STICKLINE(varcQ,O,(O+C)/2,10,0),Color00A8A8;
STICKLINE(varcQ,O,(O+C)/2,8,0),Color00BDBD;
STICKLINE(varcQ,O,(O+C)/2,5,0),Color00D2D2;
STICKLINE(varcQ,O,(O+C)/2,4,0),Color00ECEC;
STICKLINE(varcQ,O,(O+C)/2,3,0),Color00FFFF;
STICKLINE(varcQ,O,(O+C)/2,2,0),Color15FFFF;
STICKLINE(varcQ,O,(O+C)/2,1,0),Color33FFFF;
vardQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
STICKLINE(vardQ,O,(O+C)/2,10,0),colorff1100;
STICKLINE(vardQ,O,(O+C)/2,8,0),colorff3300;
STICKLINE(vardQ,O,(O+C)/2,5,0),colorff5500;
STICKLINE(vardQ,O,(O+C)/2,4,0),colorff7700;
STICKLINE(vardQ,O,(O+C)/2,3,0),colorff9900;
STICKLINE(vardQ,O,(O+C)/2,2,0),colorffbb00;
STICKLINE(vardQ,O,(O+C)/2,1,0),colorffdd00;
C3:=REF(C,1);
涨停:IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),Color2DFFFF;
STICKLINE(涨停,OPEN,CLOSE,10,0),Color008C8C;
STICKLINE(涨停,OPEN,CLOSE,8,0),Color00AAAA;
STICKLINE(涨停,OPEN,CLOSE,6,0),Color00CACA;
STICKLINE(涨停,OPEN,CLOSE,5,0),Color00E3E3;
STICKLINE(涨停,OPEN,CLOSE,4,0),Color02FFFF;
STICKLINE(涨停,OPEN,CLOSE,3,0),Color02FFFF;
STICKLINE(涨停,OPEN,CLOSE,2,0),Color2DFFFF;
STICKLINE(涨停,OPEN,CLOSE,1,0),Color2DFFFF;
跌停:IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),Color33FF33;
STICKLINE(跌停,OPEN,CLOSE,10,0),Color009B00;
STICKLINE(跌停,OPEN,CLOSE,8,0),Color00B700;
STICKLINE(跌停,OPEN,CLOSE,6,0),Color00D200;
STICKLINE(跌停,OPEN,CLOSE,5,0),Color00EA00;
STICKLINE(跌停,OPEN,CLOSE,4,0),Color0FFF0F;
STICKLINE(跌停,OPEN,CLOSE,3,0),Color0FFF0F;
STICKLINE(跌停,OPEN,CLOSE,2,0),Color33FF33;
STICKLINE(跌停,OPEN,CLOSE,1,0),Color33FF33;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
低吸:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(低吸=1,5),LOW-0.19,'▲'),ColorFF26FF;

同花顺猎庄主图指标公式

 

相关文章