在线检测未来函数

通达信中短KDJ指标公式

来源:Internet,编辑:股旁网,2010-06-08

T2:=(HHV(HIGH,3)+LLV(LOW,3)+CLOSE*2)/4;
T3:=EMA(T2,13);
T4:=STD(T2,13);
T5:=((T2-T3)/T4*100+200)/4;
T6:=(EMA(T5,13)-21)*1.56;
K1:=EMA(CLOSE,8)-EMA(CLOSE,26);
ST1:=EMA(K1,3);
ET1:=(K1-ST1)*2,COLORSTICK;
BK: EMA(T6,3)*1.22,COLORWHITE,LINETHICK2;
BD: EMA(BK,3),COLORLIBLUE,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORYELLOW;
IF(K<REF(K,1),K,DRAWNULL),COLORGREEN,LINETHICK1;
IF(D<REF(D,1),D,DRAWNULL),COLORGREEN,LINETHICK1;
IF(J<REF(J,1),J,DRAWNULL),COLORFFFF00,LINETHICK1;
IF(K>REF(K,1),K,DRAWNULL),COLORRED,LINETHICK1;
IF(D>REF(D,1),D,DRAWNULL),COLORRED,LINETHICK1;
IF(J>REF(J,1),J,DRAWNULL),COLORFF00FF,LINETHICK1;
STICKLINE((J<=0 AND K<=30),0,J,1,1),COLORYELLOW;
金叉:IF(SUM(CROSS(K,D)AND D<23,15)>=2 AND CROSS(K,D)AND C>O,10,0),COLORFFFF00;
A1:=BARSLAST(REF(CROSS(J,K),1));
底背:=REF(CLOSE,A1+1)>CLOSE AND J>REF(J,A1+1) AND CROSS(J,K);
底:DRAWLINE(A1=0,D,底背,D,0),COLORRED,POINTDOT;
DRAWTEXT(底背,D,'底B'),COLORRED;
A2:=BARSLAST(REF(CROSS(K,J),1));
顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(J,A2+1)>J AND CROSS(K,J);
顶:DRAWLINE(A2=0,D,顶背,D,0),COLORBLUE,POINTDOT;
DRAWTEXT(顶背,D,'顶B'),COLORYELLOW;

通达信中短KDJ指标公式

 

相关文章