在线检测未来函数

飞狐超赢主力散户指标公式

来源:Internet,编辑:股旁网,2010-06-11

{参数: M 缺省0.7 最小0.3 最大 0.9 ; N 缺省3.3 最小3.1 最大3.6}

VOL=AMOUNT;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
VAR2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
{IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR3),COLORGREEN;}
主买:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主卖:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN- LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
主买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH- OPEN)+(CLOSE-LOW)),VOL/2));
主卖盘:=IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE< OPEN,VAR1*(HIGH-LOW),VOL/2));
STICKLINE(主买盘>0,0,主买盘,1,0),COLORRED;
STICKLINE(主卖盘<0,VOL,主买盘,1,0),COLOR00FF00;
额:=AMOUNT/10000000;
资金进:MA(主买盘/10000,4),COLORRED;
资金出:MA((主卖盘/10000),4),COLOR00FF00;
bb:=(主买盘+主卖盘);
STICKLINE(资金进>资金出,资金进,资金出,6,0),colorred;
STICKLINE(资金进<资金出,资金出,资金进,6,0),colorgreen;
STICKLINE(资金进>资金出,资金进,资金出,6,0),colorred;
STICKLINE(资金进<资金出,资金出,资金进,6,0),colorgreen;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
换手率:=VOL/CAPITAL*100;
主力吸筹:换手率>3 AND 换手率<=5,COLORMAGENTA;
加快吸筹:换手率>5 AND 换手率<=7,COLOR99ff;
STICKLINE(主力吸筹,0,VOL,9,0),COLORMAGENTA;
STICKLINE(加快吸筹,0,VOL,9,0),COLOR99ff;
Var1:=DYNAINFO(17)*REF(MA(VOL,5),1);
Var2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
预测V1:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,Var1,Var2);
预测V:IF(VOL>=预测V1,VOL,预测V1),LINETHICK0;
比:=预测V/VOL;
WJ:=(HIGH+LOW+CLOSE)/3;
V1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
V2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-WJ);
V3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
V4:=IF(HIGH=LOW,1,WJ-MIN(CLOSE,OPEN));
V5:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=(V9+V8)*比;
卖盘2:=(V6+V7)*比;
买盘:=IF(STKTYPE<>0 AND BARSTATUS=2 AND DATATYPE=6,买盘1,买盘2);
卖盘:=IF(STKTYPE<>0 AND BARSTATUS=2 AND DATATYPE=6,卖盘1,卖盘2);
{股旁网-股票公式网站 http://www.gupang.com}
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:VOL,POINTDOT,COLORE4C1EE;
主买:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主卖:=IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE< OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
VOLUME:=VOL;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
VOLUME:=VOL;
VAR2:=MA(VOLUME,5);
VAR3:=MA(VOLUME,10);
VAR4:=MA(VOLUME,20);
VAR5:=MA(VOLUME,60);
量比:=VOL/REF(VOL,1); 五量比:=VOL/VAR2; 六量比:=VOL/VAR5;
PARTLINE(MA(VOL,5)>=REF(MA(VOL,5),1),MA(VOL,5)),COLORRED,LINETHICK3;
PARTLINE(MA(VOL,5)<=REF(MA(VOL,5),1),MA(VOL,5)),COLOR00C700,LINETHICK3;
variable:wday[7]='星期六';wday[1]:='星期日';wday[2]:='星期一';
wday[3]:='星期二';wday[4]:='星期三';wday[5]:='星期四';wday[6]:='星期五';
fy:=YEAR;fm:=MONTH;fd:=DAY;wd:=WEEKDAY;p:=SYSPARAM(1);BB:=BARPOS;
str1:=''+NUMTOSTR(fy[p],0)+'年'+NUMTOSTR(fm[p],0)+'月'+NUMTOSTR(fd[p],0)+' 日 '+wday[wd[p]+1];
SJ:=OPENMINUTES(CURRENTTIME)>1 and OPENMINUTES(CURRENTTIME)<239;
lj0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);jj:=(HIGH+LOW+CLOSE)/3;
特大:IF(CAPITAL=0,lj0*(jj-MIN(CLOSE,OPEN)),lj0*IF(HIGH=LOW,1, (MIN(OPEN,CLOSE)-LOW))),PRECISION0,COLOR0000FF,LINETHICK;
大户:IF(CAPITAL=0,lj0*(MIN(OPEN,CLOSE)-LOW),lj0*IF(HIGH=LOW,1,(jj- MIN(CLOSE,OPEN)))),PRECISION0,COLORFF00FF,LINETHICK;
中户:IF(CAPITAL=0,lj0*(HIGH-MAX(OPEN,CLOSE)),lj0*IF(HIGH=LOW,1,(HIGH- MAX(OPEN,CLOSE)))),PRECISION0,COLOR00FF00,LINETHICK;
散户:IF(CAPITAL=0,lj0*(MAX(CLOSE,OPEN)-jj),lj0*IF(HIGH=LOW,1, (MAX(CLOSE,OPEN)-jj))),PRECISION0,COLORFF6600,LINETHICK;
总1:=(特大+大户)-(中户+散户);总:=VOL;
ww:=SYSPARAM(2);n1:=SYSPARAM(3);nn:=n1-ww+1;hh:=HHV(总,nn);ll:=LLV(总,nn);
ZG:=hh[n1];ZD:=ll[n1];中0:=ZD+(ZG-ZD)*0.5;中:=中0*0.05;CM:=SUM(总1,25);
ZJ:=REF(总1,1);ZSB:=(总1-REF(总1,1))/总*100;
ZSA:=cm/IF(STKTYPE=0,SUM(VOL,25),IF(STKTYPE=13,SUM(VOL,10),CAPITAL));
cc:=REF(CLOSE,BARSLAST(fm>REF(fm,1)));主力成本:=(cc*(特大+大户)*100)/(特大+大户) /100;
DF1:=EMA(CLOSE,12)-EMA(CLOSE,26);DA1:=EMA(DF1,9);
lj6:=df1>da1 and da1<0;lj7:="kdj.k">"kdj.d" and "kdj.d"<30;
lj8:=df1<da1;lj9:="kdj.k"<"kdj.d" and "kdj.k">80;
w1:=SUM(大户,5)+SUM(特大,5);w2:=SUM(散户,5)+SUM(中户,5);
量振1:=特大>大户 and 大户>散户;量振2:=特大<散户 and 大户<散户;
标振1:=lj6 and lj7;标振2:=lj8 and lj9;
a:=w1-w2;a0:=IF(a>0,a,0);b0:=IF(a<0,a,0);
STICKLINE(BB=ww,中*0.2,中*9.2,(散户[P]/总*200)*1.02,1),COLORWHITE,LINETHICK2;
STICKLINE(BB=ww,中*0.8,中*8.6,散户[P]/总*200,0),COLORFF8800;
STICKLINE(BB=ww,中*10.2,中*19.2,(中户[P]/ 总*200)*1.02,1),COLORWHITE,LINETHICK2;
STICKLINE(BB=ww,中*10.8,中*18.6,中户[P]/总*200,0),COLORFF00FF;
STICKLINE(BB=ww,中*20.2,中*29.2,(大户[P]/ 总*200)*1.02,1),COLORWHITE,LINETHICK2;
STICKLINE(BB=ww,中*20.8,中*28.6,大户[P]/总*200,0),COLOR0088FF;
STICKLINE(BB=ww,中*30.2,中*39.2,(特大[P]/ 总*200)*1.02,1),COLORWHITE,LINETHICK2;
STICKLINE(BB=ww,中*30.8,中*38.6,特大[P]/总*200,0),COLOR0000FF;
DRAWTEXTEX(CLOSE,1,420,0,str1),ColorffFF00;
DRAWTEXTEX(CLOSE,1,200,0,STKLABEL+' '+STKNAME+''),ColorffFF00;
DRAWTEXT(BB=ww,中*36,'特大:'+NUMTOSTR(特大[P]/总*100,2)+' %'),Color00EEFF;
DRAWTEXT(BB=ww,中*26,'大户:'+NUMTOSTR(大户[P]/总*100,2)+' %'),Color00EEFF;
DRAWTEXT(BB=ww,中*16,'中户:'+NUMTOSTR(中户[P]/总*100,2)+' %'),Color00EEFF;
DRAWTEXT(BB=ww,中*6,'散户:'+NUMTOSTR(散户[P]/总*100,2)+' %'),Color00EEFF;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD1:=2*(DIFF-DEA);
CS1:=100;
CS2:=HHV(ABS(MACD1),CS1);
CS3:=ABS(100/CS2);
MACD:(MACD1*CS3+100)/2,LINETHICK5,color00FF00;
CS:=MACD;
日红:=CS>=REF(CS,1);
日转红:=日红 AND REF(日红,1)=0;
AA:=0;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
价位线:=EMA((CLOSE-V1)/(V2-V1)*4,4);
DRAWTEXTEX(CLOSE,1,200,130,'主力成本:'+NUMTOSTR(主力成本[p],2)),COLOR00FF00;
DRAWTEXTEX(CLOSE,1,350,130,'主力筹码占流通:'+NUMTOSTR(IF(ZSA>0,ZSA[P]*100,0),2)+' %'),COLOR00FF00;
DRAWTEXTEX(CLOSE,1,560,130,'较昨日增减:'+NUMTOSTR(ZSB[P],2)+' %'),COLOR00FF00;
DRAWTEXTEX(CLOSE and 总1[P]<0,1,720,0,'散户主买 主力主卖'),COLORffee00;
DRAWTEXTEX(CLOSE and 总1[P]>0,1,720,0,'主力主买 散户主卖'),COLOR0000ff;

 

VOL=AMOUNT;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
VAR2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
{IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR3),COLORGREEN;}

主买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH- OPEN)+(CLOSE-LOW)),VOL/2));
主卖盘:=IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE< OPEN,VAR1*(HIGH-LOW),VOL/2));
STICKLINE(主买盘>0,0,主买盘,1,0),COLORRED;
STICKLINE(主卖盘<0,VOL,主买盘,1,0),COLOR00FF00;
换手:=VOL/CAPITAL*100;
STICKLINE(换手>0 ,0, 主买盘,0,0),COLORYELLOW;
STICKLINE(换手>0,VOL, 主买盘, 0,0) ,COLORRED;
bb:=(主买盘+主卖盘);
STICKLINE(资金进>资金出,资金进,资金出,6,0),colorred;
STICKLINE(资金进<资金出,资金出,资金进,6,0),colorgreen;
STICKLINE(资金进>资金出,资金进,资金出,6,0),colorred;
STICKLINE(资金进<资金出,资金出,资金进,6,0),colorgreen;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
STICKLINE(主买>0,0,主买,6,0 ),Color6666cc;
STICKLINE(主买>0,0,主买,5,0 ),COLOR7777dd;
STICKLINE(主买>0,0,主买,6.4 ,0 ),COLOR8888ee;
STICKLINE(主买>0,0,主买,4.1 ,0 ),COLOR9999ff;
STICKLINE( 主卖>0,0 ,主卖,6,0 ),COLORaaaaaa;
STICKLINE(主卖>0 ,0 ,主卖,5,0 ),Colorbbbbbb;
STICKLINE(主卖>0 ,0 ,主卖,6.4,0 ),Colorcccccc;
STICKLINE(主卖>0 ,0 ,主卖,6.1,0 ),ColorFF8800;

 

WJ:=(HIGH+LOW+CLOSE)/3;
VD1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
VD2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-WJ);
VD3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
VD4:=IF(HIGH=LOW,1,WJ-MIN(CLOSE,OPEN));
VD5:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
VD6:=(VD1*VD5);
VD7:=(VD2*VD5);
VD8:=(VD3*VD5);
VD9:=(VD4*VD5);
买入量:=(VD9+VD8);
卖出量:=(VD6+VD7);
买入资金:=买入量*CLOSE/100;
卖出资金:=卖出量*CLOSE/100;
资金进出:=买入资金-卖出资金;
买卖资金比:=买入资金/卖出资金;
DRAWTEXTEX(CLOSE,1,250,100,' ┃买入资金累计万元: '+NUMTOSTR(买入资金,2))Colorred,LINETHICK1;
DRAWTEXTEX(CLOSE,1,250,200,' ┃卖出资金累计万元: '+NUMTOSTR(卖出资金,2))Color00ff00,LINETHICK1;
DRAWTEXTEX(CLOSE,1,250,300,' ┃资金进出万元: '+NUMTOSTR(资金进出,2))Coloryellow,LINETHICK1;

飞狐超赢主力散户指标公式

 

相关文章