在线检测未来函数

同花顺DMI优化指标公式

来源:Internet,编辑:股旁网,2010-06-12

TR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EMA(IF(HD>0 OR HD>LD,HD,0),14);
DMM:=EMA(IF(LD>0 OR LD>HD,LD,0),14);
PDI: DMP*100/TR,colorwhite;
MDI: DMM*100/TR,coloryellow;
趋势线:MA(EMA(PDI,2),10),colorred,LINETHICK2;
STICKLINE(PDI>趋势线,趋势线,PDI,0.05,0),colormagenta;
STICKLINE(PDI>MDI,PDI,趋势线,0.1,0),colorred;
STICKLINE(PDI>MDI,MDI,趋势线,0.1,0),COLORLIRED;
STICKLINE(PDI<趋势线,趋势线,PDI,0.05,0),COLORFF8000;
STICKLINE(PDI<MDI,PDI,MDI,0.1,0),colorblue;
ADX: EMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),colorgreen;
ADXR:EMA(ADX,6),colormagenta;

同花顺DMI优化指标公式

 

相关文章