在线检测未来函数

通达信解盘顶底指标公式

来源:Internet,编辑:股旁网,2010-06-14

VAR1:=MA(LOW,1);
VAR2:=MA(HIGH,2);
VAR3:=MA(CLOSE,2);
VAR4:=(VAR3-LLV(VAR1,9))/(HHV(VAR2,9)-LLV(VAR1,9))*100;
VAR5:=SMA(VAR4,3,1);
【阳】: SMA(VAR5,3,1),COLORRED,LINETHICK2;
Y1:=SMA(【阳】,3,1);
VAR6:=(HHV(VAR2,9)-VAR3)/(HHV(VAR2,9)-LLV(VAR1,9))*100;
【阴】: SMA(VAR6,3,1),COLORYELLOW,LINETHICK2;
Y2:=SMA(【阴】,3,1);
VAR7:=REF(VAR3,1);
VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;
VARB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100;
VARC:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;
VARD:=CLOSE*100/MA(CLOSE,10)-100;
VARE:=IF(VARB>10,10,VARB);
VARF:=IF(VARE<-10,-10,VARE);
VAR10:=IF(VARC>10,10,VARC);
VAR11:=IF(VAR10<-10,-10,VAR10);
VAR12:=REF(VARB,1);
VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);
VAR14:=INDEXC;
VAR15:=REF(VAR14,1);
VAR16:=100*(VAR14-VAR15)/VAR14;
VAR17:=MA(VAR13,3);
VAR18:=MA(VAR16,3);
VAR19:=(3*CLOSE+VAR1+OPEN+HIGH)/6;
VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;
VAR1B:=MA(VAR1A,12);
VAR1C:=EMA(VAR1A,5);
VAR1D:=ABS(VAR1A-VAR1B);
VAR1E:=REF(VAR3,1)*0.015;
VAR1F:=REF(INDEXC,1);
VAR24:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
VAR25:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);
VAR26:=MA(CLOSE,26);
VAR27:=VAR26+2*STD(VAR3,26);
VAR28:=VAR26-2*STD(VAR3,26);
VAR29:=VAR26+2*STD(REF(VAR3,1),26);
VAR2A:=VAR26-2*STD(REF(VAR3,1),26);
VAR2B:=IF(VAR24 AND VAR1<VAR28,1,0);
VAR2C:=IF(VAR25*VAR1 AND VAR2>VAR27,2,VAR2B);
VAR2D:=IF(VAR2C=1,80,45);
VAR2E:=IF(VAR2C=2,0,VAR2D);
VAR2F:=VAR2E;
D1:=EMA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),5);
D2:=REF(D1,1);
STICKLINE(D1>=REF(D1,1),D1,D2,5,0),COLOR0055AA;
STICKLINE(D1<REF(D1,1),D1,D2,5,0),COLOR006600;
{股旁网-股票公式网站 WWW.GUPANG.COM}
{STICKLINE(D1>=REF(D1,1),D1,D2,2,0),COLOR0077CC;}
STICKLINE(D1>=REF(D1,1),D1,D2,1,0),COLOR0099DD;
{STICKLINE(D1<REF(D1,1),D1,D2,2,0),COLOR009900;}
STICKLINE(D1<REF(D1,1),D1,D2,1,0),COLOR00BB00;
【强弱】:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100;
DRAWTEXT(ISLASTBAR=1 AND (CROSS(【强弱】,Y2) OR VAR2E>45),80,' 短期吃货!'),COLORRED;
{股旁网-股票公式网站 www.gupang.com}
DRAWTEXT(ISLASTBAR=1 AND (CROSS(Y1,【强弱】) OR VAR2E<45),80,' 短期出货!'),COLORGREEN;
DRAWTEXT(ISLASTBAR=1 AND VAR17>VAR18,60,' 个股强于大盘!'),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1 AND VAR12>VARF,50,' 大盘处在下降通道'),COLORCCFF99;
DRAWTEXT(ISLASTBAR=1 AND VAR18>=VAR17,60,' 个股弱于大盘!'),COLOR00FFFF;
DRAWTEXT(ISLASTBAR=1 AND VAR1A>VAR1B AND VAR1D>VAR1E AND NOT(CROSS(75,VAR8)),40,' 持股待涨!'),COLOR0099FF;
DRAWTEXT(ISLASTBAR=1 AND VAR1A<VAR1B AND VAR1D>VAR1E AND NOT(CROSS(【强弱】,20)),40,' 下调减持!'),COLORFF9900;
DRAWTEXT(ISLASTBAR=1 AND VAR1D<=VAR1E,40,' 盘整阶段!'),COLORFF9900;
DRAWTEXT(ISLASTBAR=1 AND (INDEXC-VAR1F)/VAR1F>0.035,40,'出现井喷行情!'),COLORRED;

通达信解盘顶底指标公式

 

相关文章