在线检测未来函数

通达信优量DDX指标公式

来源:Internet,编辑:股旁网,2010-06-16

{使用说明:1.5日均量线上穿35日均量线,135日均量线,收阳线出笑脸提示。2.DDX同时走红,择机介入。}
VOL,VOLSTICK;
V05:MA(VOL,5),LINETHICK1;
V35:MA(VOL,35),LINETHICK1,COLORYELLOW ;
VL135:MA(VOL,135),LINETHICK1,COLORBLUE;
ML:=CROSS(V05,VL135) OR CROSS(V05,V35);
DRAWICON(ML AND CLOSE>OPEN,LOW,5);
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2)),LINETHICK0,COLORRED;
卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0- AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORCYAN;
进出量:=买量+卖量,COLOR00FFFF;
N:=5;
M:=13;
N日内净流入:SUM(进出量,N),LINETHICK2,COLORGREEN;
流入:IF(N日内净流入>REF(N日内净流入,1),N日内净流入,DRAWNULL),COLORRED,LINETHICK2;
连红天:BARSLASTCOUNT(进出量>0);
M日内翻红天:COUNT(进出量>0,M),COLORRED;
{股旁网-股票公式网站 www.gupang.com}
走熊天:BARSLASTCOUNT(N日内净流入<0),COLORCYAN;
走牛天:BARSLASTCOUNT(N日内净流入>0),COLORRED;
强势天:BARSLASTCOUNT((N日内净流入>REF(N日内净流入,1))>0 AND N日内净流入>0);
弱势天:BARSLASTCOUNT((N日内净流入<REF(N日内净流入,1))>0 AND N日内净流入<0);

通达信优量DDX指标公式

 

相关文章