在线检测未来函数

飞狐macd叠加主图指标公式

来源:Internet,编辑:股旁网,2010-06-16

DRAWGBK(c>0 , COLORRgb(0,0,0), COLORRGB(0,0,0),1);
DIFF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*3;
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),COLORSTICK;
N1:=sysparam(3);
N:=N1-sysparam(2)+1;
HH:=HHV(H,N);
LL:=LLV(L,N);
最高:HH[N1],COLORRED,LINEDOT;
最低:LL[N1],COLORRED,LINEDOT;
STICKLINE(DIFF>DEA,最低+(最高-最低)*0.5,最低+(最高-最低)*0.5+MACD,5,0),,,Color0000B7;
STICKLINE(DIFF<DEA,最低+(最高-最低)*0.5,最低+(最高-最低)*0.5+MACD,5,0),,Color008C8C;
STICKLINE(c>o,c,o,6,1),,Color86C2FF;
STICKLINE(c<o,c,o,6,0),COLORCYAN;
{股旁网-股票公式网站 www.gupang.com}
STICKLINE(c=o and c>ref(c,1),c,o,6,1),,Color86C2FF;
STICKLINE(c=o and c<ref(c,1),c,o,6,0),COLORffcc00;
STICKLINE(c=o and c=ref(c,1),c,o,6,0),COLORYELLOW;
STICKLINE(c>o,c,h,0.5,1),,Color86C2FF;
STICKLINE(c>o,o,l,0.5,1),,Color86C2FF;
STICKLINE(c<o,o,h,0.5,0),COLORffcc00;
STICKLINE(c<o,c,l,0.5,0),COLORffcc00;
STICKLINE(c=o and c>ref(c,1),c,h,0.5,0),,Color86C2FF;
STICKLINE(c=o and c>ref(c,1),c,l,0.5,0),,Color86C2FF;
STICKLINE(c=o and c=ref(c,1),c,h,0.5,0),COLORYELLOW;
STICKLINE(c=o and c=ref(c,1),c,l,0.5,0),COLORYELLOW;
STICKLINE(c=o and c<ref(c,1),c,h,0.5,0),COLORffcc00;
STICKLINE(c=o and c<ref(c,1),c,l,0.5,0),COLORffcc00;
最低+(最高-最低)*0.5+DIFF,COLORGREEN;
最低+(最高-最低)*0.5+DEA,COLORMAGENTA;
DRAWTEXT(BARSCOUNT(C)=SYSPARAM(3),最低+(最高-最低)*0.5,'0 轴'),SHIFT2,COLORBBBBBB;

飞狐macd叠加主图指标公式

 

相关文章