在线检测未来函数

通达信湖北卫视猛吹的战略家的操盘优化组合指标公式

来源:Internet,编辑:股旁网,2010-06-17

这段时间湖北卫视猛吹的战略家,
其操盘原理和曹氏八线的持股线或凯恩斯的黄金线其实是一样的,不同的是,曹氏八线的持股线是15天均线,凯恩斯的黄金线是18天均线,而战略家的短线操盘线是10天均线,中线操盘线是45天均线而已。
而将其短线操盘和中线操盘组合在一起,再加上几条常用的均线,则要比战略家原版操盘公式实用得多。
下面是组合后的主图公式源码:
N:=IF(BARSCOUNT(C)>=10,10,BARSCOUNT(C));
STICKLINE(C>=MA(C,N),MA(C,N),REF(MA(C,N),1),5,0),COLORYELLOW;
STICKLINE(C<MA(C,N),MA(C,N),REF(MA(C,N),1),5,0),COLORBLUE;
DRAWTEXT(C>=MA(C,N) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,N),' 黄色持股 (短线)'),COLORYELLOW;
DRAWTEXT(C<MA(C,N) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,N),' 蓝色持币 (短线)'),COLORFF9933;
M:=IF(BARSCOUNT(C)>=45,45,BARSCOUNT(C));
STICKLINE(C>=MA(C,M),MA(C,M),REF(MA(C,M),1),5,0),COLORYELLOW;
STICKLINE(C<MA(C,M),MA(C,M),REF(MA(C,M),1),5,0),COLORBLUE;
{股旁网-股票公式网站 WWW.GUPANG.COM}
DRAWTEXT(C>=MA(C,M) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,M),' 黄色持股 (中线)'),COLORYELLOW;
{股旁网-股票公式网站 www.gupang.com}
DRAWTEXT(C<MA(C,M) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,M),' 蓝色持币 (中线)'),COLORFF9933;
DRAWKLINE(H,O,L,C);
MA5:MA(C,5),COLORMAGENTA;
MA10:MA(C,N),COLORLIRED;
MA25:MA(C,25),LINETHICK2,COLORRED;
MA45:MA(C,M),COLORGREEN;
MA120:MA(C,120),COLORBROWN;

另外,它的副图公式只偏重于短线操盘,我把慢速KD也组合进去后,也就兼顾了中线操盘。(慢速KD和MACD其实差不多,都是中线指标),
下面是组合后的副图公式,个人觉得比原版好用:
Z:=MA(C,120);
VAR3:=(MA(C,5)-Z)/Z;
VAR4:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
波段进场:IF(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2),80,50);
反弹进场:IF(REF(VAR4,1)<5 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) AND VAR3<-0.3,80,50);
超跌进场:IF(CROSS(VAR4,5) AND VAR3<-0.4,80,50); STICKLINE(C>=MA(C,10),VAR4,REF(VAR4,1),4,0),COLORRED; STICKLINE(C<MA(C,10),VAR4,REF(VAR4,1),4,0),COLORGREEN;
RSV:= (CLOSE-LLV(LOW,50))/(HHV(HIGH,50)-LLV(LOW,50))*100;
FASTK:=SMA(RSV,3,1);
SK:SMA(FASTK,3,1),LINETHICK2,COLORYELLOW;
SD:SMA(SK,5,1),LINETHICK2,COLORMAGENTA;
MAKD:=(SK-SD)*2;
STICKLINE(MAKD>0 AND REF(MAKD,1)<MAKD,50,MAKD+50,0,0),COLORRED;
STICKLINE(MAKD>0 AND REF(MAKD,1)>MAKD,50,MAKD+50,0,0),COLORLIRED;
STICKLINE(MAKD<0 AND REF(MAKD,1)>MAKD,50,MAKD+50,0,0),COLORLICYAN;
STICKLINE(MAKD<0 AND REF(MAKD,1)<MAKD,50,MAKD+50,0,0),COLORLIGREEN;

通达信湖北卫视猛吹的战略家的操盘优化组合指标公式

 

相关文章