在线检测未来函数

通达信主力扫描仪指标公式

来源:Internet,编辑:股旁网,2010-06-20

AVPRICE:=(2*OPEN+2*CLOSE+2*HIGH+2*LOW)/8;
INDEXAVP:=(2*INDEXH+2*INDEXL+2*INDEXO+2*INDEXC)/8;
F:=(AVPRICE - REF(AVPRICE,1))/REF(AVPRICE,1);
F1:=(INDEXAVP - REF(INDEXAVP,1))/REF(INDEXAVP,1);
类比参数3:=(SUM(F,10) + SUM(F1,10))/10*1000;
类比大盘参数:=IF(类比参数3 > 0,类比参数3,0);
类比参数2:=IF(类比参数3 < 0,-类比参数3,0);
STICKLINE(类比参数2 AND (150 - 类比参数2)>0,150,150 - 类比参数2,2,0),COLOR008000;
STICKLINE(类比大盘参数 AND (150 - 类比大盘参数)>0,150,150 - 类比大盘参数,2,0),COLORFF00FF;
AA:=AVPRICE;
BB:=((VOL)*((AA)*(2) - HIGH - LOW))/(HIGH - LOW);
CC:=IF((HIGH = LOW) AND (AA < REF(AA,1)),((-1))*(VOL),VOL);
A:=IF((HIGH = LOW),CC,BB);
B:=SUM(A,11);
BBD:=(((B)/((CAPITAL)*(11)))*(10000));
BB1:=IF((BBD < 150) AND (BBD > (-150)),BBD,150);
买方能量指标:=IF((BB1 > 0),BB1,0);
STICKLINE((BB1 > 0),0,买方能量指标,2,0),COLORYELLOW;
STICKLINE((BB1 < 0),0,(-BB1),2,0),COLOR00FF00;
主动买量:IF((BB1 > 0),BB1,0),COLORYELLOW,NODRAW;
主动卖量:IF((BB1<0),BB1,0),COLOR00FF00,NODRAW;
A16:=(SUM((AVPRICE)*(VOL),16))/(SUM(VOL,16));
A11:=(SUM((AVPRICE)*(VOL),11))/(SUM(VOL,11));
A6:=(SUM((AVPRICE)*(VOL),6))/(SUM(VOL,6));
A7:=(SUM((AVPRICE)*(VOL),7) - (AVPRICE)*(VOL))/(SUM(VOL,7) - VOL);
A0:=((A11 - A16)/(AVPRICE))*(1000);
A00:=IF((A0 > 50),50,IF((A0 < (-50)),(-50),A0));
A1:=((A6 - A11)/(AVPRICE))*(1000);
AA11:=IF((A1 > 50),50,IF((A1 < (-50)),(-50),A1));
A2:=((((A6 - A7)/(A7))*(5))/(4))*(1000);
A22:=IF((A2 > 50),50,IF((A2 < (-50)),(-50),A2));
{股旁网-股票公式网站 www.gupang.com}
刻度线3:=(A00 + AA11 + A22);
趋势线:=IF((刻度线3 > 0),刻度线3,0);
兰刻度线:=IF((刻度线3 < 0),刻度线3,0);
做多趋势:趋势线,COLOR0000FF;
做空趋势:(-兰刻度线),COLORFF0000;
STICKLINE(趋势线,0,趋势线,1,0),COLORRED;
STICKLINE(兰刻度线,0,(-兰刻度线),1,0),COLORFF0000;
强弱界:50,COLORFFFFFF;
触顶线:145,COLOR0000FF,LINETHICK3;
大盘顶线:90,COLOR00FFFF,LINETHICK2;
STICKLINE(趋势线>触顶线,140,150,3,0),COLORFFFF00;
STICKLINE(-兰刻度线>触顶线,140,150,3,0),COLOR0000FF;
STICKLINE(趋势线>大盘顶线 AND HHV(趋势线,3)<102,0,-6,5,0),COLORFFFF00;

通达信主力扫描仪指标公式

 

相关文章