在线检测未来函数

通达信监控大盘周线主图指标公式

来源:Internet,编辑:股旁网,2010-06-20

MA30:MA(CLOSE,30),LINETHICK1,COLORRED;
MA60:MA(CLOSE,60),LINETHICK1,COLORYELLOW;
MA120:MA(CLOSE,120),LINETHICK1,COLORFF00FF;
A:=(3*C+L+O+H)/6;
X:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210,COLORRED,LINETHICK2;
Y:MA(X,15),COLORFFFF00,LINETHICK1;
LY:=10;
BL:=40;
CJQS:=XMA(CLOSE,LY);
JBQS:=XMA(CLOSE,BL);
N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT);
M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT);
{股旁网-股票公式网站 www.gupang.com}
轨迹:IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1- CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*0.95),COLORWHITE;
DRAWTEXT(CROSS(轨迹,X),轨迹,'进场'),COLORFFBB99;
DRAWTEXT(CROSS(X,Y),X,'←大盘买'),COLORYELLOW;
DRAWTEXT(CROSS(Y,X),Y,'←大盘2顶'),COLORYELLOW;
DRAWTEXT(CROSS(X,轨迹),X,'←大盘顶'),COLORYELLOW;
DRAWTEXT(CROSS(X,MA60),X,'←大盘买'),COLORYELLOW;
DRAWTEXT(CROSS(MA60,Y),MA60,'大盘逃命'),COLORGREEN;
DRAWTEXT(CROSS(MA120,MA60) AND MA30<=MA120,MA120,'变盘'),COLORFFBB99;

通达信监控大盘周线主图指标公式

 

相关文章