在线检测未来函数

通达信BIAS角度计算指标公式

来源:Internet,编辑:股旁网,2010-06-21

N1:=5;N2:=10;N3:=20;
BIAS1:=(CLOSE-MA(CLOSE,N1))/MA(CLOSE,N1)*100,LINETHICK1;
BIAS2:=(CLOSE-MA(CLOSE,N2))/MA(CLOSE,N2)*100,LINETHICK2;
BIAS3:=(CLOSE-MA(CLOSE,N3))/MA(CLOSE,N3)*100,LINETHICK4;
MAXBIAS1:=IF(BIAS1>REF(BIAS1,1),BIAS1,0);
角度计算1:IF(BIAS1>REF(BIAS1,1),(MAXBIAS1-MIN(BIAS1,REF(BIAS1,1)))/
(ABS(BIAS1)+ABS(REF(BIAS1,1))),0),LINETHICK1;
MAXBIAS2:=IF(BIAS2>REF(BIAS2,1),BIAS2,0);
角度计算2:IF(BIAS2>REF(BIAS2,1),(MAXBIAS2-MIN(BIAS2,REF(BIAS2,1)))/
(ABS(BIAS2)+ABS(REF(BIAS2,1))),0),LINETHICK1;
MAXBIAS3:=IF(BIAS3>REF(BIAS3,1),BIAS3,0);
角度计算3:IF(BIAS3>REF(BIAS3,1),(MAXBIAS3-MIN(BIAS3,REF(BIAS3,1)))/
(ABS(BIAS3)+ABS(REF(BIAS3,1))),0),LINETHICK1;
三强:=角度计算1>=1 AND 角度计算2>=1 AND 角度计算3>=1;
STICKLINE(三强,0.5,1,0.5,0),COLORRED;
{股旁网-股票公式网站 WWW.GUPANG.COM}
大盘6日:=(INDEXC-MA(INDEXC,6))/MA(INDEXC,6)*100;
大盘12日:=(INDEXC-MA(INDEXC,12))/MA(INDEXC,12)*100;
大盘24日:=(INDEXC-MA(INDEXC,24))/MA(INDEXC,24)*100;
大盘:=(大盘6日 + 大盘12日 + 大盘24日)/3;
个股6日:=(C-MA(C,6))/MA(C,6)*100;
个股12日:=(C-MA(C,12))/MA(C,12)*100;
个股24日:=(C-MA(C,24))/MA(C,24)*100;
个股:=(个股6日 + 个股12日 + 个股24日)/3;
强势出击:=(大盘>REF(大盘,1) AND CROSS(个股,大盘));
STICKLINE(强势出击,0,1,0,0),COLORRED;
转折1:=REF(角度计算1,2)>REF(角度计算1,1) AND REF(角度计算1,1)<角度计算1
AND REF(角度计算1,2)<角度计算1;
转折2:=REF(角度计算2,2)>REF(角度计算2,1) AND REF(角度计算2,1)<角度计算2
AND REF(角度计算2,2)<角度计算2;
转折3:=REF(角度计算3,2)>REF(角度计算3,1) AND REF(角度计算3,1)<角度计算3
AND REF(角度计算3,2)<角度计算3;
同时转折买点:=转折1 AND 转折2 AND 转折3;
DRAWICON(同时转折买点 AND C>MA(C,5)
AND MA(C,5)>REF(MA(C,5),1)
AND REF(MA(C,5),1)>REF(MA(C,5),2),
MIN(MIN(角度计算1,角度计算2),角度计算3),1);
DRAWICON(同时转折买点,角度计算1,1);
DRAWICON(同时转折买点,角度计算2,1);
DRAWICON(同时转折买点,角度计算3,1);
金屋顶:1,CIRCLEDOT,LINETHICK3,COLORRED;

通达信BIAS角度计算指标公式

 

相关文章