在线检测未来函数

通达信超赢主图指标公式

来源:Internet,编辑:股旁网,2010-06-26

JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
M3:=EMA(CLOSE,3);
M8:=EMA(CLOSE,8);
DRAWBAND(M3,RGB(140,70,30),M8,RGB(140,70,30));
STICKLINE(A>B,A,B,5,0),COLORBLUE;
STICKLINE(A<B,A,B,5,0),COLORGREEN;
M13:EMA(M8,13),LINETHICK2,COLORWHITE;
M55:EMA(M8,55),LINETHICK2,COLORYELLOW;
VAR1:=EMA(M13,55),LINETHICK4;
M81:EMA(M55,81), COLORRED,LINETHICK4;
VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,21)+2*STD(CLOSE,21);
VAR4:=REF(CLOSE,1);
VAR5:=SMA(MAX(CLOSE-VAR4,0),7,1)/SMA(ABS(CLOSE-VAR4),7,1)*100;
VAR6:=CROSS(79,VAR5);
VAR7:=FILTER(VAR6,4);
A7:=(2*C+H+L)/4;
VAR10:=LLV(LOW,34);
VAR11:=HHV(HIGH,34);
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1Q:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2Q:=(REF(VAR1Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3Q:=(REF(VAR2Q,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4Q:=(REF(VAR3Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5Q:=(REF(VAR4Q,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6Q:=(REF(VAR5Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7Q:=(REF(VAR6Q,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8Q:=(REF(VAR7Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9Q:=(REF(VAR8Q,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARAQ:=(REF(VAR9Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARBQ:=(REF(VARAQ,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARCQ:=(REF(VARBQ,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARDQ:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VAREQ:=(REF(VARDQ,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARFQ:=(REF(VAREQ,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10Q:=(REF(VARFQ,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11Q:=(REF(VAR10Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12Q:=(REF(VAR11Q,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13Q:=(REF(VAR12Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14Q:=(REF(VAR13Q,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15Q:=(REF(VAR14Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16Q:=(REF(VAR15Q,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17Q:=(REF(VAR16Q,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18Q:=(REF(VAR17Q,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19Q:=((REF(VARDQ OR VAREQ OR VARFQ OR VAR10Q OR VAR11Q OR VAR12Q OR VAR13Q OR VAR14Q OR VAR15Q OR VAR16Q OR VAR17Q OR VAR18Q,1)) AND VAR1Q);
VAR1AQ:=((REF(VAR1Q OR VAR2Q OR VAR3Q OR VAR4Q OR VAR5Q OR VAR6Q OR VAR7Q OR VAR8Q OR VAR9Q OR VARAQ OR VARBQ OR VARCQ,1)) AND VARDQ);
红色持股:=VAR1Q OR VAR2Q OR VAR3Q OR VAR4Q OR VAR5Q OR VAR6Q OR VAR7Q OR VAR8Q OR VAR9Q OR VARAQ OR VARBQ OR VARCQ,COLOR0000FF,NODRAW;
离场:=IF(红色持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
今离场价:=REF(离场,1)COLOR0000FF,NODRAW;
青色观望:=VARDQ OR VAREQ OR VARFQ OR VAR10Q OR VAR11Q OR VAR12Q OR VAR13Q OR VAR14Q OR VAR15Q OR VAR16Q OR VAR17Q OR VAR18Q,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:=REF(明进场价,1),COLORFF0000,NODRAW;
黄色低买:=VAR19Q,COLOR33AACC,NODRAW;
洋红离场:=VAR1AQ,COLORMAGENTA,NODRAW;
{股旁网-股票公式网站 www.gupang.com}
急跌关注:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORWHITE,NODRAW;
上市日期年:=REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF;
月:=REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF;
日:=REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF;
STICKLINE(C>=O,L,H,0.3,0),COLOR0000CC;
STICKLINE(C<O,L,H,0.3,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR454500;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,1.5,0),COLOR656500;
STICKLINE(青色观望,CLOSE,O,1,0),COLOR757500;
STICKLINE(青色观望,CLOSE,O,0.5,0),COLOR858500;
CO:=(C-O);
STICKLINE(急跌关注,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急跌关注,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急跌关注,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急跌关注,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急跌关注,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(黄色低买,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(黄色低买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(黄色低买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(黄色低买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(黄色低买,O,O+CO/3,0,0),COLOR33EEEE;
STICKLINE(洋红离场,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(洋红离场,O,O+CO/3,2,0),COLOR880088;
STICKLINE(洋红离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(洋红离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(洋红离场,O,O+CO/3,0.5,0),COLOREE00EE;
DRAWICON( CROSS(M55,M81),M81*0.95,1),COLORYELLOW;{抄底};

通达信超赢主图指标公式

 

相关文章