在线检测未来函数

通达信macd超强指标公式

来源:Internet,编辑:股旁网,2010-07-02

DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,3.2,0),COLOR000055;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2.7,0),COLOR000077;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2.1,0),COLOR000099;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1.5,0),COLOR0000BB;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,0.9,0),COLOR0000DD;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,0.3,0),COLOR0000FF;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,3.2,0),COLOR555555;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2.7,0),COLOR777777;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2.1,0),COLOR999999;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1.5,0),COLORBBBBBB;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,0.9,0),COLORDDDDDD;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,0.3,0),COLORFFFFFF;
STICKLINE(MACD1<MACD2,0,MACD1,3.2,0),COLORB20000;
{股旁网-股票公式网站 www.gupang.com}
STICKLINE(MACD1<MACD2,0,MACD1,2.7,0),COLOREC0000;
STICKLINE(MACD1<MACD2,0,MACD1,2.1,0),COLORFF4600;
STICKLINE(MACD1<MACD2,0,MACD1,1.5,0),COLORFF6300;
STICKLINE(MACD1<MACD2,0,MACD1,0.9,0),COLORFF8B00;
STICKLINE(MACD1<MACD2,0,MACD1,0.3,0),COLORFFAB00;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIF:DIF1,COLOR33FF33;
DEA:DEA1,COLORYELLOW;
MACD:MACD1,NODRAW,COLORMAGENTA;
强度:IF(DIF1>=DEA1,DIF1,DRAWNULL),COLORRED,LINETHICK1;
抄底:IF((TROUGHBARS(3,15,1)=0) AND (HIGH>LOW+0.01),0.2,(-0)),COLORGREEN,LINETHICK2;

通达信macd超强指标公式

 

相关文章