在线检测未来函数

飞狐macd顶底背离组合指标公式

来源:Internet,编辑:股旁网,2010-07-03

DRAWGBK(CLOSE>0, COLORRGB(1,0,0), COLORRGB(1,0,0),2);
DIFF:EMA(CLOSE,12) - EMA(CLOSE,26),LINETHICK;
DEA:EMA(DIFF,9),Color39FD96,LINETHICK1;
FILLRGN(DIFF>DEA,DIFF,DEA),Color39FD96;
MACD:=2*(DIFF-DEA), COLORSTICK,LINETHICK1;
s:=MACD;
s1:=s<ref(s,1) and s>0;
s2:=s<ref(s,1) and s<0;
STICKLINE(s>=0,0,s,2,1),COLORRED,LINETHICK1;
STICKLINE(s1,0,s,2,1),Color677937,LINETHICK1;
STICKLINE(s2,0,s,2,1),Color964E27,LINETHICK1;
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TR;
MDI:= MDM*100/TR;
A1:=BARSLAST(ref(cross("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=ref(c,A1+1)>c and ref("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) and cross("macd.diff"(12,26,9),"macd.dea"(12,26,9));
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) and cross("kdj.k"(9,3,3),"kdj.d"(9,3,3));
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) and cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(ref(cross("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=ref(c,C1+1)<c and ref("macd.diff"(12,26,9),C1+1)>"macd.diff"(12,26,9) and cross("macd.dea"(12,26,9),"macd.diff"(12,26,9));
C2:=BARSLAST(ref(cross("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=ref(c,C2+1)<c and ref("kdj.k"(9,3,3),C2+1)>"kdj.k"(9,3,3) and cross("kdj.d"(9,3,3),"kdj.k"(9,3,3));
C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=ref(c,C3+1)<c and ref("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) and cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(ref(cross(mdi,pdi),1));
D4:=ref(c,C4+1)<c and ref(mdi,C4+1)>mdi and cross(mdi,pdi);
A4:=BARSLAST(ref(cross(PDI,MDI),1));
B4:=ref(c,A4+1)>c and ref(pdi,A4+1)<pdi and cross(pdi,mdi);
DMI底背:IF(B4>0,-0.1,0),COLOR0099FF,POINTDOT;
DMI顶背:IF(D4>0,0.1,0),COLORBLUE,POINTDOT;
MACD底背:if(B1>0,-0.1,0),colorred,pointdot;
KDJ底背:if(B2>0,-0.1,0),colorff00ff,pointdot;
RSI底背:if(B3>0,-0.1,0),coloryellow,pointdot;
MACD顶背:if(D1>0,0.1,0),color00ff00,pointdot;
KDJ顶背:if(D2>0,0.1,0),colorffcc66,pointdot;
RSI顶背:if(D3>0,0.1,0),colorwhite,pointdot;
STICKLINE(B1>0,-0.1,0,4,0),colorred;
STICKLINE(B2>0,-0.1,0,4,0),colorff00ff;
STICKLINE(B3>0,-0.1,0,4,0),coloryellow;
{股旁网-股票公式网站 www.gupang.com}
STICKLINE(d1>0,0.1,0,4,0),color00ff00;
STICKLINE(d2>0,0.1,0,4,0),colorffcc66;
STICKLINE(d3>0,0.1,0,4,0),colorwhite;
STICKLINE(B4>0,-0.1,0,4,0),color0099ff;
STICKLINE(D4>0,0.1,0,4,0),colorblue;
VVA:=((AMOUNT)/(VOL))/(100);
VVB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VVC:=((SUM(AMOUNT,7))/(VVA))/(100);
VVD:=DMA(VVB,(VOL)/(VVC));
VVE:=((CLOSE-VVD)/(VVD))*(100);
VVF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VVJ:=MA(VVE,20)+STD(VVE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
KV:=SMA(VVF,3,1);
STICKLINE((REF(BIAS18,1)>=5) AND CROSS(VVJ,VVE) AND (KV>79),macd,macd+0.03,4,0),color00ff00;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
stickline(cross(84,RSI),macd,macd+0.03,4,0),COLOR00FF00;
多方趋势:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-sma(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
天线:=78.89;
stickline(cross(天线,多方趋势),macd,macd+0.03,4,0),Color00FF00;
A1:=EMA(CLOSE,8)-EMA(CLOSE,14);
B1:=EMA(0.668*REF(A1,1)+0.333*A1,1);
做多:IF(A1>=B1,A1,B1),ColorFF00FF,LINETHICK1;
做空:=IF(B1-A1,B1,A1),LINETHICK;
FILLRGN(做多>做空,做多,做空),ColorFF00FF;

飞狐macd顶底背离组合指标公式

 

相关文章