在线检测未来函数

通达信波段K线解盘主图指标公式

来源:Internet,编辑:股旁网,2010-07-05

{中短波}
短波:EMA(EMA(CLOSE,13),1),COLOR00DD00;
中波:EMA(EMA(CLOSE,13),26),COLORRED;
HZ2:EMA(EMA(CLOSE,13),8),COLORGREEN,LINETHICK2;
HZ4:EMA(EMA(CLOSE,13),39),COLORFF00FF,LINETHICK2;
STICKLINE(HZ2<HZ4,短波,HZ4,1,0),COLORBLUE ;
STICKLINE(短波>HZ2,短波,HZ2,1,0),COLORGREEN;
STICKLINE(中波>HZ4,中波,HZ4,1,0),COLORFF00FF;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
{红}
STICKLINE(MACD>0,C,O,2.8,0),COLOR000080;
STICKLINE(MACD>0,H,L,0,0),COLOR0000E5;
{淡蓝}
STICKLINE(MACD<0 AND MACD<REF(MACD,1),C,O,2.8,0),COLORFF9900;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),H,L,0,0),COLORFFFF00;
{黄}
STICKLINE(MACD<0 AND MACD>REF(MACD,1),C,O,2.8,0),COLOR0099FF;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),H,L,0,0),COLOR00FFFF;
T1{早晨之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1)
< REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T2{黄昏之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1)
> REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02
AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2)),1,0));
T3{长十字}:=CONST(IF((CLOSE=OPEN AND HIGH/LOW >1.03),1,0));
T4{垂死十字}:=CONST(IF((CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH),1,0));
T5{早晨十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1)
< REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T6{黄昏十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1)
> REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2)),1,0));
T7{射击之星}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >
3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5)),1,0));
{股旁网-股票公式网站 www.gupang.com}
T8{倒转锤头}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >
3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5)),1,0));
T9{锤头}:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW >
3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5)),1,0));
T10{吊颈}:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW >
3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5)),1,0));
T11{穿头破脚}:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96
AND CLOSE<REF(OPEN,1)
AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04
AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))),1,0));
T12{乌云盖顶}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97
AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1)),1,0));
T13{曙光初现}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03
AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1)),1,0));
T14{身怀六甲}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04
AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)
> MIN(REF(CLOSE,1),REF(OPEN,1))),1,0));
T15{十字胎}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04
AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1)
,REF(OPEN,1))),1,0));
T16{平顶}:=CONST(IF((ABS(HIGH-REF(HIGH,1))/HIGH<0.001),1,0));
T17{平底}:=CONST(IF(((ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)
-REF(LOW,2))/REF(LOW,1)<=0.001)),1,0));
T18{大阳烛}:=CONST(IF((CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018),1,0));
T19{三个白武士}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)
>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1)),1,0));
T20{双飞乌鸦}:=CONST(IF((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN
AND CLOSE/OPEN<0.98),1,0));
T21{孕育线}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)
-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1)
AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)
<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN
AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1)
AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))
<=1/100),1,0));
T22{多方炮}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1)
AND CLOSE>OPEN),1,0));
T23{出水芙蓉}:=CONST(IF(((OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<
EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)
>1.2 AND C/REF(C,1)>1.049)),1,0));
T24{上升三部曲}:=CONST(IF((REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)
<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1)
AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)
<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2)
AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4)),1,0));
T25{下跌三部曲}:=CONST(IF(( REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)
>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1)
AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)
<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4)),1,0));
T26{跳空缺口}:=CONST(IF(HIGH<REF(LOW,1) OR LOW>REF(HIGH,1),1,0));
T27{三只乌鸦}:=CONST(IF((REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)
<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2)
AND CLOSE<REF(CLOSE,1)),1,0));
T28{光脚阴线}:=CONST(IF((LOW=CLOSE AND HIGH!=LOW),1,0));
T29{光头阳线}:=CONST(IF((HIGH=CLOSE AND HIGH!=LOW),1,0));
T30{分离}:=CONST(IF((OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)
-REF(OPEN,1))<0),1,0));
T31{长下影}:=CONST(IF(((MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667),1,0));
T32{长上影}:=CONST(IF(((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667),1,0));
T33{十字星}:=CONST(IF((CLOSE=OPEN AND HIGH!=LOW),1,0));
T34{大阴烛}:=CONST(IF((OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018),1,0));
T35{好友反攻}:=CONST(IF(((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN
AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1)
AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))
/CLOSE<0.002)),1,0));
T36{倾盆大雨}:=CONST(IF((REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O
>REF(O,1) AND C<REF(O,1)),1,0));
N:=0.04;
TS1:=IF(T1=1,0+N,0);
TS2:=IF(T2=1,TS1+N,TS1);
TS3:=IF(T3=1,TS2+N,TS2);
TS4:=IF(T4=1,TS3+N,TS3);
TS5:=IF(T5=1,TS4+N,TS4);
TS6:=IF(T6=1,TS5+N,TS5);
TS7:=IF(T7=1,TS6+N,TS6);
TS8:=IF(T8=1,TS7+N,TS7);
TS9:=IF(T9=1,TS8+N,TS8);
TS10:=IF(T10=1,TS9+N,TS9);
TS11:=IF(T11=1,TS10+N,TS10);
TS12:=IF(T12=1,TS11+N,TS11);
TS13:=IF(T13=1,TS12+N,TS12);
TS14:=IF(T14=1,TS13+N,TS13);
TS15:=IF(T15=1,TS14+N,TS14);
TS16:=IF(T16=1,TS15+N,TS15);
TS17:=IF(T17=1,TS16+N,TS16);
TS18:=IF(T18=1,TS17+N,TS17);
TS19:=IF(T19=1,TS18+N,TS18);
TS20:=IF(T20=1,TS19+N,TS19);
TS21:=IF(T21=1,TS20+N,TS20);
TS22:=IF(T22=1,TS21+N,TS21);
TS23:=IF(T23=1,TS22+N,TS22);
TS24:=IF(T24=1,TS23+N,TS23);
TS25:=IF(T25=1,TS24+N,TS24);
TS26:=IF(T26=1,TS25+N,TS25);
TS27:=IF(T27=1,TS26+N,TS26);
TS28:=IF(T28=1,TS27+N,TS27);
TS29:=IF(T29=1,TS28+N,TS28);
TS30:=IF(T30=1,TS29+N,TS29);
TS31:=IF(T31=1,TS30+N,TS30);
TS32:=IF(T32=1,TS31+N,TS31);
TS33:=IF(T33=1,TS32+N,TS32);
TS34:=IF(T34=1,TS33+N,TS33);
TS35:=IF(T35=1,TS34+N,TS34);
TS36:=IF(T36=1,TS35+N,TS35);
AAA:=CONST(HHV(H,90));
DRAWTEXT(T1=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS1),'早晨之星,见底回升');
DRAWTEXT(T2=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS2),'黄昏之星,见顶回落');
DRAWTEXT(T3=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS3),'长十字,重要的警告信号,原趋势停顿或反转');
DRAWTEXT(T4=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS4),'垂死十字,下跌信号');
DRAWTEXT(T5=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS5),'早晨十字星,上涨信号,见底回升');
DRAWTEXT(T6=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS6),'黄昏十字星,趋势停顿或反转,下跌或,见顶回落');
DRAWTEXT(T7=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS7),'射击之星,市场顶部就在眼前,可能见顶回落,可靠性低');
DRAWTEXT(T8=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS8),'倒转锤头构成一个看涨信号,可能见底回升');
DRAWTEXT(T9=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS9),'锤头,可能见底回升,如有量配合,信号强烈');
DRAWTEXT(T10=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS10),'吊颈,上升行情中见顶回落,顶部出现,见顶信号');
DRAWTEXT(T11=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS11),'穿头破脚,顶部出现,见顶回落信号');
DRAWTEXT(T12=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS12),'乌云盖顶,见顶回落信号');
DRAWTEXT(T13=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS13),'曙光初现,将演化为V型反转或横盘。后市见底回升');
DRAWTEXT(T14=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS14),'身怀六甲,底部,是见底回升,顶部,是见顶回落信号');
DRAWTEXT(T15=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS15),'十字胎‖');
DRAWTEXT(T16=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS16),'平顶,行情见顶,股价将反转。但下跌力度较小');
DRAWTEXT(T17=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS17),'平底,行情探低见底,股价行将反转上升,但力度较小');
DRAWTEXT(T18=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS18),'大阳烛,上升中,剧烈地向上攀升。下行中,剧烈地向上反弹 '),COLORYELLOW ;
DRAWTEXT(T19=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS19),'三个白武士,每日收盘价上移,表示可能见底回升');
DRAWTEXT(T20=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS20),'双飞乌鸦,行情开始疲软将见顶回落‖');
DRAWTEXT(T21=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS21),'孕育线,注意股价位置');
DRAWTEXT(T22=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS22),'多方炮,底部可能上涨,中间上涨中继,顶部见顶信号');
DRAWTEXT(T23=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS23),'出水芙蓉,阳线穿过20、40、60日均线,上攻势头初现');
DRAWTEXT(T24=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS24),'上升三部曲,上涨信号');
DRAWTEXT(T25=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS25),'下跌三部曲,下跌信号');
DRAWTEXT(T26=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS26),'跳空缺口,突破盘整,向上涨、向下跌开始');
DRAWTEXT(T27=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS27),'三只乌鸦站枝头,可能见顶回落');
DRAWTEXT(T28=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS28),'光脚阴线,下跌信号');
DRAWTEXT(T29=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS29),'光头阳线,多方积极上攻态势,后市看涨');
DRAWTEXT(T30=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS30),'分离,注意看涨分离和看跌分离');
DRAWTEXT(T31=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS31),'长下影,有可能止跌回升,升势末期,须小心');
DRAWTEXT(T32=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS32),'长上影,表明行情上档压力沉重,升势受阻');
DRAWTEXT(T33=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS33),'十字星,重要的警告信号,原趋势停顿或反转');
DRAWTEXT(T34=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS34),'大阴烛,后市向淡,发生逆转');
DRAWTEXT(T35=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS35),'好友反攻,跌势已尽,要展开一段反弹行情');
DRAWTEXT(T36=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS36),'倾盆大雨,见顶信号');

通达信波段K线解盘主图指标公式

 

相关文章