在线检测未来函数

飞狐黑马神秘买卖主图指标公式

来源:Internet,编辑:股旁网,2010-07-07

上:=SMA(HIGH,21,2)*1.05;
下轨道:=SMA(LOW,21,2)*0.969;
BMA:=MA(CLOSE,118);
阻挡:=SMA(HIGH,21,2)*1.05;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));
压力位:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J))));
CB:=AMOUNT/VOL/100;
CD:=CB>HIGH OR CB<LOW;
黑马趋势:=MA(CLOSE,3);
MAP:=MA(CLOSE,8);
AA5:=MA(CLOSE,21);
孤独: (CLOSE+0.618*REF(CLOSE,1)+0.382*REF(CLOSE,2)+0.236*REF(CLOSE,3)+0.146*REF(CLOSE,4))/2.382,LINETHICK2,color4080FF;
PARTLINE(孤独<REF(孤独,1),孤独),LINETHICK2,color8000;
短趋线:EMA(CLOSE,8),LINETHICK2,colorFF00FF;
PARTLINE(短趋线<REF(短趋线,1),短趋线),LINETHICK2,colorFF0000;
中趋线:EMA(CLOSE,17),LINETHICK2,colorFF;
PARTLINE(中趋线<REF(中趋线,1),中趋线),LINETHICK2,colorFF00;
DRAWICON(CROSS(短趋线,中趋线),中趋线,10);
DRAWICON(CROSS(中趋线,短趋线),中趋线,11);
不败:EMA(CLOSE,27),POINTDOT,LINETHICK1,color400080;
PARTLINE(不败<REF(不败,1),不败),POINTDOT,LINETHICK1,colorFF0000;
BB10:=(ATAN(短趋线-REF(短趋线,1)))*3.1416*10;
BB12:=(ATAN(中趋线-REF(中趋线,1)))*3.1416*10;
MA13:=MA(CLOSE,13);
DRAWTEXT(FILTER(CLOSE/OPEN>1.04 AND CLOSE-REF(CLOSE,1)>0 AND CLOSE>下轨道 AND 短趋线-REF(短趋线,1)>0 AND CLOSE<上,3),LOW-0.05,'追'),colorFF00;
DRAWICON(FILTER(CLOSE/OPEN>1.04 AND CLOSE-REF(CLOSE,1)>0 AND CLOSE>下轨道 AND 短趋线-REF(短趋线,1)>0 AND CLOSE<上,3),LOW-0.05,4),colorFF00;
VARD:=(OPEN+LOW+HIGH+CLOSE)/4;
支撑:=EMA(VARD,5);
短期底部:=LLV(OPEN,30);
X1:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X2:=EMA(X1,10);
X3:=REF(X2,1);
X4:=(REF(HIGH,1)+REF(LOW,1))/2;
X5:=MA(CLOSE,21)+2*STD(CLOSE,21);
X6:=REF(CLOSE,1);
X7:=(SMA(MAX(CLOSE-X6,0),7,1))/(SMA(ABS(CLOSE-X6),7,1))*100;
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
MAP1:=MA(CLOSE,60);
均线30:=MA(CLOSE,30);
均线89:=MA(CLOSE,89);
均线:=MA(CLOSE,16);
均线34:=MA(CLOSE,34);
均线55:=MA(CLOSE,55);
VAR1:=EMA(CLOSE,8);
VAR2:=EMA(VAR1,20);
VAR3:=CROSS(VAR1,VAR2);
VAR4:=VAR1<MA(CLOSE,60);
VAR5:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR6:=SMA(VAR5,5,1);
VAR7:=SMA(VAR6,8,1);
VAR8:=CROSS(VAR6,VAR7) AND VAR7<16;
VAR9:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR8;
VARA:=IF(CLOSE>1000,VAR8,VAR9);
黑马起步:=VAR3 AND VAR4;
逃遁:=VARA;
DRAWTEXT(VARA,HIGH+0.06,'逃遁');
DRAWICON(VARA,HIGH+0.06,5);
均线20:=MA(CLOSE,20);
均线120:=MA(CLOSE,120);
牛熊线:=MA(CLOSE,250);
VA:=CROSS(MA(CLOSE,19),MA(CLOSE,120));
{股旁网-股票公式网站 www.gupang.com}
VB:=MA(CLOSE,20)>MA(CLOSE,120);
VC:=CROSS(MA(CLOSE,120),MA(CLOSE,89));
VD:=MA(CLOSE,20)<MA(CLOSE,120);
VE:=CROSS(MA(CLOSE,20),MA(CLOSE,250));
VF:=MA(CLOSE,20)>MA(CLOSE,250);
VG:=CROSS(MA(CLOSE,250),MA(CLOSE,20));
DRAWTEXT(均线-REF(均线,1)>0 AND CROSS(均线20,均线120) AND LOW<=均线120 AND CLOSE>=均线120,LOW,'三线开花'),colorFFFFFF;
短期底部2:=LLV(HIGH,30);
上轨:=SMA(HIGH,21,2)*1.092;
中轨道:=SMA(HIGH,21,2)*1.017;
DRAWTEXT(VE>VG AND HIGH<阻挡,LOW-0.1,'短线'),colorFFFF;
DRAWICON(VE>VG AND HIGH<阻挡,LOW-0.1,4);
DRAWTEXT(FILTER(OPEN<X2 AND CLOSE>X2 AND 支撑-REF(支撑,1)>0 AND 支撑-REF(支撑,1)>0 AND CLOSE<阻挡 AND 均线-REF(均线,1)>0 AND CLOSE>=均线 AND HIGH<阻挡 AND 短趋线-REF(短趋线,1)>0 AND 阻挡-REF(阻挡,2)>0,11),LOW-0.11,'快马'),colorFFFFFF;
DRAWTEXT(FILTER(OPEN<X2 AND WINNER(CLOSE)<0.2 AND CLOSE>X2 AND X2-REF(X2,1)>0 AND HIGH<阻挡 AND CLOSE-REF(CLOSE,1)>0.35,4),LOW-0.05,'★黑马狂奔'),colorD18073;
DRAWTEXT(CROSS(支撑,均线) AND HIGH<中轨道 AND WINNER(CLOSE)<0.2 AND CLOSE<阻挡 AND CLOSE>OPEN AND LOW<=X2 AND CLOSE>=X2 AND CROSS(支撑,X2),LOW,'起步'),colorFFFF;
DRAWTEXT(黑马起步>0 AND LOW<=X2 AND 均线-REF(均线,1)>0,LOW-0.11,'起步'),colorFF00;
RDV:=SMA(LOW,8,1);
DRAWTEXT(CROSS(K,D) AND CLOSE>=OPEN AND X2-REF(X2,1)>0 AND RDV-REF(RDV,1)>0 AND K<=33,LOW-0.08,'★黑马初现'),color8500DE;
DRAWTEXT(FILTER(LOW<=短期底部 AND WINNER(CLOSE)<0.2 AND CLOSE<牛熊线 AND HIGH<阻挡 AND X2-REF(X2,1)>0 AND CLOSE>OPEN AND HIGH>=X3,5),LOW-0.03,'←黑马筑底'),color85B256;
RCK:=SMA(LOW,21,2)*0.95;
趋势线:=SMA(LOW,5,1);
DRAWTEXT(CROSS(趋势线,RCK) AND LOW<=X2 AND X2-REF(X2,1)>0,LOW,'大胆买入'),colorFFFFFF;
DRAWICON(CROSS(趋势线,RCK) AND LOW<=X2 AND X2-REF(X2,1)>0,LOW,4);
B1:=(HIGH+LOW+CLOSE)/3;
B6:=HHV(B1,4*15);
B7:=LLV(B1,4*15);
B8:=B6-B7;
飞龙顶底线:=MA((B1-B7)/B8,2)*80;
DRAWTEXT(FILTER(飞龙顶底线<=1 AND WINNER(CLOSE)<0.02 AND HIGH<趋势线 AND CLOSE>OPEN AND LOW<=短期底部 AND CLOSE>短期底部,8),LOW-0.02,'←黑马寻底'),colorE7DD1F;
DRAWTEXT(FILTER(LOW<=短期底部 AND WINNER(CLOSE)<0.015 AND OPEN/CLOSE>0.99 AND J-REF(J,1)>0 AND CLOSE>OPEN AND HIGH<支撑位 AND CLOSE>短期底部,25),LOW-0.09,'←开始建仓'),colorFFFF;
DRAWTEXT(FILTER(LOW<=均线30 AND 短趋线-REF(短趋线,1)>0 AND 均线-REF(均线20,1)>0 AND 趋势线-REF(趋势线,1)>0 AND CLOSE>=均线30 AND WINNER(CLOSE)<0.15 AND CLOSE/OPEN>1.01,3),LOW,'★天马奔月'),color76B0FC;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,13);
DWN:=BBI-3*STD(BBI,13);
LC:=REF(CLOSE,1);
RSI:=(SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1))*100;
A7:=(2*CLOSE+HIGH+LOW)/4;
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,HIGH,LOW,1,0),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,HIGH,LOW,1,0),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,HIGH,LOW,1,0),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,HIGH,LOW,1,0),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,HIGH,LOW,1,0),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,HIGH,LOW,1,0),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,OPEN,CLOSE,8,1),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,OPEN,CLOSE,8,1),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,OPEN,CLOSE,8,1),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,OPEN,CLOSE,8,1),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,OPEN,CLOSE,8,1),LINETHICK2,colorF00FF0;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,OPEN,CLOSE,8,1),LINETHICK2,colorF00FF0;
STICKLINE(FILTER(CLOSE/OPEN>1.04 AND CLOSE-REF(CLOSE,1)>0 AND CLOSE>下轨道 AND 短趋线-REF(短趋线,1)>0 AND CLOSE<上,3),HIGH,LOW,0,0),LINETHICK2,colorFFFF;
STICKLINE(FILTER(CLOSE/OPEN>1.04 AND CLOSE-REF(CLOSE,1)>0 AND CLOSE>下轨道 AND 短趋线-REF(短趋线,1)>0 AND CLOSE<上,3),OPEN,CLOSE,8,1),LINETHICK2,colorFFFF;
趋势线:=3*SMA((CLOSE- LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部:=LLV(CLOSE,30);
MA3:=MA(底部,2);
X:=MA(CLOSE,26);
压力:=HHV(HIGH,30);
DRAWTEXT(FILTER(LOW<=X AND CLOSE>=X AND MA3>=REF(MA3,1) AND CLOSE/OPEN>1.02 AND WINNER(CLOSE)<0.4,20),LOW-0.07,'看多'),colorFFFF;
DRAWICON(FILTER(LOW<=X AND CLOSE>=X AND MA3>=REF(MA3,1) AND CLOSE/OPEN>1.02 AND WINNER(CLOSE)<0.4,20),LOW-0.07,4);
DRAWTEXT(FILTER(HIGH>=压力 AND CLOSE<HIGH AND CLOSE<OPEN AND OPEN/CLOSE>1.03 AND WINNER(CLOSE)>0.6,5),HIGH+0.06,'压力'),colorFF00;
DRAWICON(FILTER(HIGH>=压力 AND CLOSE<HIGH AND CLOSE<OPEN AND OPEN/CLOSE>1.03 AND WINNER(CLOSE)>0.6,5),HIGH+0.06,5);
趋势线:=3*SMA((CLOSE- LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
短期乖离率:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
DRAWTEXT(FILTER(IF(CROSS(趋势线,10) AND CLOSE/LOW>1.04 AND 短期乖离率<0.35,1,0) AND CLOSE>OPEN,5),LOW-0.07,'底'),colorFFFF;
DRAWICON(FILTER(IF(CROSS(趋势线,10) AND CLOSE/LOW>1.04 AND 短期乖离率<0.35,1,0) AND CLOSE>OPEN,5),LOW-0.07,4);
VARA:=AMOUNT/VOL/100;
VARB:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VARC:=SUM(AMOUNT,7)/VARA/100;
VARD:=DMA(VARB,VOL/VARC);
VARE:=(CLOSE-VARD)/VARD*100;
VARF:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=(CLOSE-MA(CLOSE,18))/MA(CLOSE,18)*100;
K:=SMA(VARF,3,1);
顶:=REF(BIAS18,1)>=5 AND CROSS(VARJ,VARE) AND K>79;
DRAWICON(FILTER(REF(BIAS18,1)>=5 AND CROSS(VARJ,VARE) AND K>79,5),HIGH,12),ALIGN0,colorFFFF;
DRAWTEXT(FILTER(REFX(ISLASTBAR,20),1000),CLOSE,'☆与君共知\版权所有 ☆'),ALIGN4,colorFFFFFF;

飞狐黑马神秘买卖主图指标公式

 

相关文章