在线检测未来函数

大智慧牛马线指标公式

来源:Internet,编辑:股旁网,2010-07-08

MA20:=MA(CLOSE,20);
MA40:=MA(CLOSE,40);
MA60:=MA(CLOSE,60);
MA240:=MA(CLOSE,240);
突破线:MIN(MA60*1.1,MA240*1.3),COLOR00FFFF;
{股旁网-股票公式网站 www.gupang.com}
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线: (20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
马线:MA(牛线,5),COLORWHITE;
PARTLINE(牛线,牛线>马线,RGB(255,0,0),牛线<马线,RGB(0,255,0));
PL1:=(C - MA60) / MA60 < 0.1;
PL2:=(C - MA240) / MA240 < 0.3;
偏离率:=(PL1 = 1 AND PL2 = 1) * 0.2;
突破:=(偏离率 = 0 AND REF(COUNT(偏离率 = 0.2,10) = 10,1) = 1) * (-0.1);
DRAWTEXT(突破=-0.1,L*0.95,'★突破'),COLORYELLOW;
AA:=BARSLAST(MA60>MA40 AND (MA40=MA20 OR MA40>MA20));
BB:=REF(COUNT(C<MA60,AA)=AA,1);
CC:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
STICKLINE(BB AND CC,H,L,0,0),COLORRED;
STICKLINE(BB AND CC,O,C,6,0),COLORRED;
DRAWTEXT(BB AND CC,L*0.95,'↑芙蓉出水'),COLORRED;

大智慧牛马线指标公式

 

相关文章