在线检测未来函数

大智慧变色K柱主图指标公式

来源:Internet,编辑:股旁网,2010-07-13

DRAWTEXTREL(480{左右},65{高低},'〖操盘专用〗'),color9ACD32;
DRAWTEXTREL(340,130,'高开高走为一根红柱,高开低走收红为黄柱,高开低走收绿为上黄下绿柱,'),Color8285FF;
DRAWTEXTREL(340,165,'低开低走收绿蓝色,低开高走收绿淡蓝色柱,低开高走收红下淡蓝上红柱。'),Color8285FF;
{DRAWTEXTABS}DRAWTEXTREL(16,950,STKLABEL+' ※'+STKNAME+' '+BKNAME),LINETHICK2,COLOR00FFFF;
工作14日线:EMA(CLOSE,14),colorgreen,linethick1;
持股35日线:EMA(CLOSE,35),colorred,linethick2;
IF BARSTATUS=2 and v>ref(v,1) and ma(v,5)>ref(ma(v,5),1) THEN
DRAWTEXTREL(698,950,'※ 今日成交量大于昨日,且有继续增大趋势!'),LINETHICK2,Color8285FF;
IF BARSTATUS=2 and v<ref(v,1) and ma(v,5)>ref(ma(v,5),1) THEN
DRAWTEXTREL(698,950,'※ 今日成交量小于昨日,但有放大迹象!'),LINETHICK2,Color8285FF;
IF BARSTATUS=2 and v>ref(v,1)and ma(v,5)<ref(ma(v,5),1) THEN
DRAWTEXTREL(698,950,'※ 今日成交量大于昨日, 但有缩小迹象!'),LINETHICK2,Color8285FF;
IF BARSTATUS=2 and v<ref(v,1)and ma(v,5)<ref(ma(v,5),1) THEN
DRAWTEXTREL(698,950,'※ 今日成交量小于昨日,且有缩小迹象!'),LINETHICK2,Color8285FF;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),EMA8,'∠45上升'),COLORWHITE;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.96),'老鼠仓'),COLOR4080FF;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT(CROSS(趋势线,0) AND 黑马线<40,(LOW * 0.96),'▲大黑马'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.96),'底背离'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.04),'顶背离'),COLOR1880FF;
VAR2:=LLV(LOW,27);
VAR3:=HHV(HIGH,34);
VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;
注意买:=IF((VAR4<10),80,100);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
超跌:=IF(J<0,10,0);
BDDD:=LLV(J,2)=LLV(J,8);
买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);
DRAWTEXT(买入 AND 注意买=100 AND 超跌=0,LOW*0.96,'短线'),COLOR8000FF;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买=1,5),LOW*0.96,'拉升'),COLORFFDE00;
{高开低走收红}
STICKLINE(open>=CLOSE and close>=REF(CLOSE,1),close,open,8,0),color0033ff;
STICKLINE(open>=CLOSE and close>=REF(CLOSE,1),close,open,7,0),color0066ff;
STICKLINE(open>=CLOSE and close>=REF(CLOSE,1),close,open,5.8,0),color0099ff;
STICKLINE(open>=CLOSE and close>=REF(CLOSE,1),close,open,4.4,0),color00bbff;
STICKLINE(open>=CLOSE and close>=REF(CLOSE,1),close,open,2.8,0),color00ddff;
STICKLINE(open>=CLOSE and close>=REF(CLOSE,1),close,open,1,0),color00ffff;
{股旁网-股票公式网站 www.gupang.com}
{高开高走收红}
STICKLINE(open>=REF(CLOSE,1) and close>=REF(CLOSE,1) and open<=close,open,close,8,0),color000055;
STICKLINE(open>=REF(CLOSE,1) and close>=REF(CLOSE,1) and open<=close,open,close,7,0),color000077;
STICKLINE(open>=REF(CLOSE,1) and close>=REF(CLOSE,1) and open<=close,open,close,5.8,0),color000099;
STICKLINE(open>=REF(CLOSE,1) and close>=REF(CLOSE,1) and open<=close,open,close,4.4,0),color0000bb;
STICKLINE(open>=REF(CLOSE,1) and close>=REF(CLOSE,1) and open<=close,open,close,2.8,0),color0000dd;
STICKLINE(open>=REF(CLOSE,1) and close>=REF(CLOSE,1) and open<=close,open,close,1,0),color0000ff;
{高开低走收绿}
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),CLOSE,REF(CLOSE,1),8,0),color005500;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),CLOSE,REF(CLOSE,1),7,0),color007700;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),CLOSE,REF(CLOSE,1),5.8,0),color009900;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),CLOSE,REF(CLOSE,1),4.4,0),color00bb00;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),CLOSE,REF(CLOSE,1),2.8,0),color00dd00;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),CLOSE,REF(CLOSE,1),1,0),color00ff00;
{高开低走收绿}
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),REF(CLOSE,1),open,8,0),color0033ff;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),REF(CLOSE,1),open,7,0),color0066ff;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),REF(CLOSE,1),open,5.8,0),color0099ff;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),REF(CLOSE,1),open,4.4,0),color00bbff;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),REF(CLOSE,1),open,2.8,0),color00ddff;
STICKLINE(open>=REF(CLOSE,1) and close<REF(CLOSE,1),REF(CLOSE,1),open,1,0),color00ffff;
{低开低走收绿}
STICKLINE(open<REF(CLOSE,1) and close<=open,close,OPEN,8,0),color550000;
STICKLINE(open<REF(CLOSE,1) and close<=open,close,OPEN,7,0),color770000;
STICKLINE(open<REF(CLOSE,1) and close<=open,close,OPEN,5.8,0),color990000;
STICKLINE(open<REF(CLOSE,1) and close<=open,close,OPEN,4.4,0),colorbb0000;
STICKLINE(open<REF(CLOSE,1) and close<=open,close,OPEN,2.8,0),colordd0000;
STICKLINE(open<REF(CLOSE,1) and close<=open,close,OPEN,1,0),colorff0000;
{低开高走收绿}
STICKLINE(close>open and close<=REF(CLOSE,1),open,close,8,0),colorff5500;
STICKLINE(close>open and close<=REF(CLOSE,1),open,close,7,0),colorff7700;
STICKLINE(close>open and close<=REF(CLOSE,1),open,close,5.8,0),colorff9911;
STICKLINE(close>open and close<=REF(CLOSE,1),open,close,4.4,0),colorffbb22;
STICKLINE(close>open and close<=REF(CLOSE,1),open,close,2.8,0),colorffdd33;
STICKLINE(close>open and close<=REF(CLOSE,1),open,close,1,0),colorffff33;
{低开高走收红}
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),open,REF(CLOSE,1),8,0),colorff5500;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),open,REF(CLOSE,1),7,0),colorff7700;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),open,REF(CLOSE,1),5.8,0),colorff9911;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),open,REF(CLOSE,1),4.4,0),colorffbb22;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),open,REF(CLOSE,1),2.8,0),colorffdd33;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),open,REF(CLOSE,1),1,0),colorffff33;
{低开高走收红}
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),REF(CLOSE,1),close,8,0),color000055 ;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),REF(CLOSE,1),close,7,0),color000077;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),REF(CLOSE,1),close,5.8,0),color000099;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),REF(CLOSE,1),close,4.4,0),color0000bb;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),REF(CLOSE,1),close,2.8,0),color0000dd;
STICKLINE(close>REF(CLOSE,1) and open<REF(CLOSE,1),REF(CLOSE,1),close,1,0),color0000ff;

大智慧变色K柱主图指标公式

 

相关文章