在线检测未来函数

通达信波段逃顶指标公式

来源:Internet,编辑:股旁网,2010-07-15

VAR1:=REF(CLOSE,1);
VAR2:=(-100)*(HHV(HIGH,84)-CLOSE)/(HHV(HIGH,84)-LLV(LOW,84));
顶: CROSS(-1,VAR2)*7000,COLORGREEN;
DRAWTEXT(CROSS(0,VAR2),6500,'顶');
VAR3:=SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100;
VAR4:=SMA(MAX(CLOSE-VAR1,0),13,1)/SMA(ABS(CLOSE-VAR1),13,1)*100;
VAR5:=BARSCOUNT(CLOSE);
底: (VAR2<-98)*2000,COLORWHITE;
{股旁网-股票公式网站 www.gupang.com}
DRAWTEXT(CROSS(1000,底),4100,'底'),COLORWHITE;
VAR6:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*1000-700;
VAR7:=SMA(VAR6,3,1)+100;
VAR8:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3))*10000;
VAR9:=SMA(VAR8,3,1);
VARA:=SMA(VAR9,3,1)+100;
VARB:=VARA-VAR7;
VARC:=IF(VARB>100,VARB-100,0);
STICKLINE(REF(VARC,1)<VARC,VARC,REF(VARC,1),8,1),COLORRED;
STICKLINE(REF(VARC,1)>VARC,VARC,REF(VARC,1),8,1),COLORYELLOW;
VARD:=IF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.98,REF(CLOSE,1),LOW);
VARE:=IF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<-0.98,REF(CLOSE,1),HIGH);

通达信波段逃顶指标公式

 

相关文章