在线检测未来函数

通达信返璞归真MACD指标公式

来源:Internet,编辑:股旁网,2010-07-15

DIFF :(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORRED;
DEA : EMA(DIFF,9),COLORRED,LINETHICK2;
DIF:IF(DIFF<REF(DIFF,1),DIFF,DRAWNULL),COLORGREEN;
ADEA:IF(DEA<REF(DEA,1),DEA,DRAWNULL),COLORGREEN,LINETHICK2;
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
{股旁网-股票公式网站 WWW.GUPANG.COM}
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(背离,0,3,2,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,背离,DEA,0),COLORRED;
DRAWTEXT(背离,5.2,' 背离');
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORFF00FF;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0.5,0)COLOR00FF00;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,0.5,0),COLORYELLOW;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORRED;

通达信返璞归真MACD指标公式

 

相关文章