在线检测未来函数

通达信整合MACD指标公式

来源:Internet,编辑:股旁网,2010-07-18

DIF:EMA(CLOSE,5)-EMA(CLOSE,11);
DEA:EMA(DIF,5);
MACD:(DIF-DEA)*2,COLORSTICK;
IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK1;
IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)> C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS
("MACD.DIF","MACD.DEA");
DRAWICON(B1>0,DIF*1.21,1);{底背离}
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
{股旁网-股票公式网站 www.gupang.com}
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)> "MACD.DIF" AND CROSS
("MACD.DEA","MACD.DIF");
DRAWICON(D1>0,DEA*1.21,2);{顶背离};
DRAWICON(CROSS(MACD,0),0,1);
DRAWICON(CROSS(0,MACD),0.2,2);
DRAWICON(CROSS(DIF,DEA),DIF,1),COLORRED;
DRAWICON(CROSS(DEA,DIF),DEA,2),COLORGREEN;

通达信整合MACD指标公式

 

相关文章