在线检测未来函数

通达信整合KDJ指标公式

来源:Internet,编辑:股旁网,2010-07-18

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),POINTDOT,COLORWHITE,LINETHICK1;
D:SMA(K,3,1),POINTDOT,COLORGREEN,LINETHICK1;
J:3*K-2*D,COLORFF00FF,LINETHICK1;
IF(J<0,J,DRAWNULL),COLORGREEN,LINETHICK2;
IF(K>90,K,DRAWNULL),COLOR0000FF,LINETHICK2;
IF(D>85,D,DRAWNULL),COLORFFFF11,LINETHICK2;
DRAWICON(CROSS(J,1),-50,1);
DRAWICON(K>80 AND D>80 AND CROSS(D,K),150,2);
PP:=V>REF(V,1);
F:=C>O AND HIGH>REF(HIGH,1);
G:=C>O AND LOW>REF(LOW,1) AND C>REF(C,1);
X:=(ATAN((MA(C,1)/REF(MA(C,1),1)-1)*100)*180/3.14115926)>45;
R:=J>REF(J,2) AND J<100;
OK:=F AND G AND X AND R AND PP;
JJ:=CROSS(J,OK);
DD:=COUNT(CROSS(J,OK),6)<0;
DRAWTEXT(OK,50,'买'),COLOR00FFFF;
DRAWTEXT(J<-10,-20,'底'),COLOR00FFFF;
DRAWTEXT(JJ,90,'买'),COLORRED;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV1:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
A:=EMA(RSV1,3);
B:=MA(A,3);
VAR1:=3;
VAR2:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1))
- (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) *
100),5,1),3,1)));
买:IF(CROSS(VAR2,VAR1),60,0);
LST1:=(H+L+O+C*2)/5;
LST2:=EMA(LST1,21);
LST3:=STD(LST1,23);
LST4:=EMA(LST1,2);
LSTA:=(LST1-LST2)*100/LST3;
KG:=(EMA(LSTA,23)+100)/2-3,COLOR00FFFF,LINETHICK1;
DG:=SMA(KG,5,1),COLORFFFF00,LINETHICK1;
JG:4*KG-3*DG,COLORFF00FF,LINETHICK2;
IF(JG>REF(JG,1),JG,DRAWNULL),COLORRED,LINETHICK2;
IF(JG<REF(JG,1),JG,DRAWNULL)COLOR00BB00,LINETHICK2;
DRAWICON(FILTER(JG>REF(JG,1)AND JG<REF(JG,3) AND JG<KG AND LST4>REF(LST4,1) AND
KG>=REF(KG,1)AND JG<40 OR CROSS(JG,KG)AND CROSS(JG,DG) AND JG<40 OR JG>REF(JG,1)AND
JG<-20,7),-30,1);
DRAWICON(FILTER(JG<=REF(JG,1) AND JG>80,8),140,15);
VARA:=(2*CLOSE+HIGH+LOW)/4;
VARB:=EXPMA(EXPMA(EXPMA(VARA,4),4),4);
JY:=(VARB-REF(VARB,1))/REF(VARB,1)*120;
KY:=MA(JY,1),COLORCYAN,LINETHICK1;
DY:=MA(JY,3),COLORGREEN,LINETHICK1;
VARYGB:=EMA(EMA(CLOSE,9),9);
控盘:=(VARYGB-REF(VARYGB,1))/REF(VARYGB,1)*100;
A10:=CROSS(控盘,0);
开始控盘:IF(A10,20,0),LINETHICK1,COLORCYAN;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,90,0,0.3,0),COLORWHITE;
DRAWTEXT(A1,100,'全仓'),COLORWHITE;
MY1:=CROSS(KY,DY);
AY1:=BARSLAST(REF(CROSS(KY,DY),1));
背离:=REF(CLOSE,AY1+1)>CLOSE AND KY>REF(KY,AY1+1) AND CROSS(KY,DY);
DRAWLINE(AY1=0 AND DY<0 AND KY<0,KY,底背离,KY,0),COLORFF00FF,LINETHICK3;
DRAWICON(MY1,-40,1),COLORWHITE;
DRAWICON(CROSS(DY,KY),150,2);
{股旁网-股票公式网站 www.gupang.com}
KK:=SMA(RSV,3,1);
DDD:=SMA(K,3,1);
N:=KK+DDD,COLORMAGENTA;
准备:IF(CROSS(N,50),40,-20),COLORLIRED;
发射:IF(CROSS(N,100),50,-10),COLORYELLOW;
ZTSJ:=BARSLAST(发射=100);
价:REF(C,ZTSJ)*1.1,COLORBLUE;
涨:=(C/REF(C,ZTSJ)-1)*100,RGB(255,255,0);
低:=IF(ZTSJ>0 AND ZTSJ<10 AND (L/REF(C,ZTSJ)-1)*100<=-5,5,50),RGB(255,255,255);
达标:=ZTSJ<20 AND CROSS(H,REF(C,ZTSJ)*1.1);
GWGD:=N<REF(N,1) AND REF(N,1)>=160 AND REF(N,1)>=REF(N,2);
卖:IF(GWGD,130,160),COLORGREEN;
XX:=LLV(J,2)=LLV(J,8);
YGBLST:=CROSS(J,REF(J+0.01,1)) AND XX AND J<20;
短进:IF(YGBLST,20,0),LINETHICK1,COLORWHITE;

通达信整合KDJ指标公式

 

相关文章