在线检测未来函数

同花顺黑马出击指标公式

来源:Internet,编辑:股旁网,2010-07-23

SHORT=26;LONG=12;M=9;P1=19;P2=120;K= -40;G=-26;
DIF:=((EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)))*-1;
DEA:=EMA(DIF,M),COLORFF00FF;
MACD:=2*(DIF-DEA);
HH:=MA(CLOSE,10);
GG:=MA(CLOSE,12);
上:=EMA((MA(HIGH,3) * 1.05),30);
下:=EMA((MA(LOW,3) * 0.96),30);
决战:STICKLINE((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIF < 0)),DIF,0.4,3,0),color0000FF;
DRAWICON((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIF < 0)),0.4,0);
DRAWTEXT((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIF <= 0)),0.4,'DIFF金叉'),color0000FF;
STICKLINE(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND ((GG - REF(GG,1)) >= 0)),3),0,0.5,3,0),color00FF00;
DRAWICON(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND ((GG - REF(GG,1)) >= 0)),3),0.5,0);
DRAWTEXT(FILTER(((((MACD >= REF(MACD,5)) AND ((下 - REF(下,1)) > 0)) AND (MACD <= 0)) AND ((GG - REF(GG,1)) >= 0)),3),0.5,'绝佳买入'),color00FF00;
VCF1:=LLV(LOW,5);
VCF2:=HHV(HIGH,5);
VCF3:=EMA((((CLOSE - VCF1) / (VCF2 - VCF1)) * 100),4);
VCF4:=EMA(((0.667 * REF(VCF3,1)) + (0.333 * VCF3)),2);
VCF5:=((HIGH + LOW) / 2);
VCF6:=DMA(VCF5,(VOL / SUM(VOL,5)));
VCF7:=DMA(VCF5,(VOL / SUM(VOL,13)));
VCF8:=DMA(VCF5,(VOL / SUM(VOL,34)));
VCF9:=DMA(VCF5,(VOL / SUM(VOL,75)));
VCFA:=EMA(WINNER((0.9 * CLOSE)),5);
VCFB:=(1 - EMA(WINNER((1.2 * CLOSE)),5));
VCFC:=EMA(WINNER(CLOSE),5);
VCFD:=((100 * (CLOSE - VCF6)) / VCF6);
VCFE:=((100 * (CLOSE - VCF7)) / VCF7);
VCFF:=((100 * (MIN(CLOSE,OPEN) - VCF8)) / VCF8);
VCF10:=BARSLAST(((VCF8 > VCF9) AND (REF(VCF8,1) <= REF(VCF9,1))));
VCF11:=((((COUNT(((WINNER(CLOSE) < 0.11) AND (EMA(WINNER(CLOSE),5) < 0.15)),2) > 0) OR (((1 - WINNER((1.2 * CLOSE))) >= 0.8) AND (WINNER(CLOSE) < 0.05))) AND (COUNT((VCFE < (0 - 16)),2) > 0)) AND (COUNT((VCFF < (0 - 20)),2) > 0));
VCF12:=((((COUNT((VCFD < (0 - 10)),2) > 0) AND (COUNT((VCFE < (0 - 15)),2) > 0)) AND (COUNT((VCFF < (0 - 15)),2) > 0)) AND (COUNT((VCFA > 0.8),VCF10) = 0));
VCF13:=(((COUNT((VCF11 OR VCF12),2) > 0) AND (VCF3 > REF(VCF3,1))) AND (((1 - WINNER((1.15 * CLOSE))) * 100) > 80));
出击1:=IF((VCF13 AND (COUNT(VCF13,3) <= 1)),0.1,0);
黑马出击:IF((VCF13 AND (COUNT(VCF13,3) <= 1)),0.37,0),LINETHICK3,color0000FF;
DRAWICON((黑马出击 > 0),0.37,1);
DRAWTEXT((黑马出击 > 0),0.35,'★黑马'),colorFFFFFF;
DRAWTEXT((黑马出击 > 0),0.35,'出击'),color00FF00;
VAR26:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR27:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);
VAR28:=EMA(VAR27,9);
VAR29:=(2 * (VAR27 - VAR28));
STICKLINE(((VAR27 < (0 - 50)) AND (VAR26 > 7)),0,(0 - 0.1),5,0),color0000FF;
DRAWTEXT((((VAR27 < (0 - 50)) AND (VAR26 > 7)) AND (VAR27 < VAR28)),(0 - 0.09),'底'),colorFFFFFF;
DRAWTEXT((((VAR27 < (0 - 50)) AND (VAR26 > 7)) AND (VAR27 >= VAR28)),(0 - 0.1),'追'),colorFFFFFF;
VAR1:=1;
VAR2:=MA(CLOSE,18);
VAR3:=(((CLOSE - VAR2) / VAR2) * 100);
VAR4:=MA(VAR3,1);
升跌:=(VAR4 * VAR1);
VAR5:=BARSLAST((CROSS((0 - 10),VAR4) = 1));
VAR6:=BARSLAST((CROSS(VAR4,10) = 1));
VAR7:=((VAR4 < (0 - 10)) AND (VAR5 >= 5));
VAR8:=((VAR4 > 10) AND (VAR6 >= 5));
{C1:(0.01 * (IF(((VAR4 < (0 - 10)) AND (VAR5 >= 5)),VAR4,0) * VAR1)),LINETHICK1,color0000FF;
C2:=C1;}
C3:=(IF(((VAR4 > 10) AND (VAR6 >= 5)),VAR4,0) * VAR1);
C4:=C3;
D1:=((((升跌 > REF(升跌,1)) AND VAR7) * 0.2) * VAR1);
中期底部:=LLV(CLOSE,30);
D:(FILTER(((((((升跌 > REF(升跌,1)) AND (LOW <= 中期底部)) AND (CLOSE > 中期底部)) AND VAR7) * 0.5) * VAR1),3) * 0.5),LINETHICK2,color0000FF;
DRAWTEXT((D >= 0.25),D,'★铁底'),color00FFFF;
STICKLINE(((CROSS(MACD,DIF) AND (MACD >= (0 - 0.05))) AND (MACD <= 0.02)),MACD,0.23,0,0),LINETHICK2,color00FFFF;
DRAWTEXT(((CROSS(MACD,DIF) AND (MACD >= (0 - 0.05))) AND (MACD <= 0.02)),0.23,'^MACD'),color0000FF;
DRAWTEXT(((CROSS(MACD,DIF) AND (MACD >= (0 - 0.05))) AND (MACD <= 0.02)),0.23,'金叉'),LINETHICK4,colorFFFFFF;
DRAWICON(((CROSS(MACD,DIF) AND (MACD >= (0 - 0.05))) AND (MACD <= 0.02)),0.23,1);
DIFF2:=(EMA(CLOSE,2) - EMA(OPEN,5));
操盘手:=DIFF2;
(0.4 * ((CROSS(操盘手,MACD) AND (MACD <= (0 - 0.11))) AND (LOW <= 下))),LINETHICK2,colorFFFFFF;
DRAWTEXT(((CROSS(操盘手,MACD) AND (LOW <= 下)) AND (MACD <= (0 - 0.11))),0.6,'短线5%'),colorB7D16F;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
BB:(0.7 * ((((((CROSS(DIF,DEA) AND (CLOSE < 上)) AND ((下 - REF(下,1)) > 0)) AND CROSS(MACD,0)) AND (MACD >= 0)) AND (DIF > 0)) AND (((HH - REF(HH,1)) > 0) AND (VOL > REF(VOL,1)))));
DRAWTEXT((((BB >= 0.7) AND (CLOSE < 上)) AND ((下 - REF(下,1)) > 0)),0.7,'。量价配合完美'),color00FF00;
DRAWTEXT((((BB >= 0.7) AND (CLOSE < 上)) AND ((下 - REF(下,1)) > 0)),0.7,'。(追)'),color0000FF;

同花顺黑马出击指标公式

 

相关文章