在线检测未来函数

飞狐霸王庄2.1版主图指标公式

来源:Internet,编辑:股旁网,2010-07-26

{大箱体}
顶: COST(95)*1, linedot,ColorFF00FF;
Var11:=(2*CLOSE+HIGH+LOW)/4;
底: EMA(Var11,99)*0.91,linedot,ColorFFFF00;
{小箱体}
//箱顶:MA(REF(HHV(c,30),1),2),COLOR0000FF,LINETHICK2;
//箱底:MA(REF(LLV(c,30),1),2),COLOR00FF00,LINETHICK2;
{均线系统}
MA10:=MA(C,10),colorwhite;
MA60:MA(C,60),ColorFF8080;
DRAWTEXT(CROSS(MA10,MA60),(LOW * 0.95),'注意'),Coloryellow;
{趋势}
MA15:=EMA(CLOSE,21);
STICKLINE((MA15 > REF(MA15,1)),MA15,MA15,9,6),LINETHICK4,Color00FFFF;
STICKLINE((MA15 < REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,colorFF0000;
{k线}
FO:=OPEN;
FH:=HIGH;
FL:=LOW;
FC:=CLOSE;
KK:=IF(FC>=FO AND (FC>=REF(FC,1) OR REF(FC,1)>=REF(FO,1)),1,IF(FC<FO AND (FC<REF(FO,1) OR REF(FC,1)<REF(FO,1)),-1,0));
STICKLINE(FC>FO,FH,FL,0.4,0),colorFF;
STICKLINE(KK=1 AND FC>=FO,FO,FC,8,0),colorFF;
STICKLINE(KK=1 AND FC<FO,FO,FC,8,0),colorFF;
STICKLINE(KK=0 AND FC>=FO,FO,FC,8,0),colorFF;
STICKLINE(KK=0 AND FC<FO,FO,FC,8,0),colorFF;
{趋势向下k线染灰}
STICKLINE((MA15 < REF(MA15,1)),h,l,0.4,0),Colorgray;
STICKLINE((MA15 < REF(MA15,1)),c,o,8,0),Colorgray;
{霸王庄}
主力持仓:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
指数趋势:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
强弱分界:=80;
主力筹码集中度:=WINNER(C)*100;
散筹筹码集中度:=(WINNER(C*1.1)-WINNER(C*0.9))*100;
qiang:=(主力持仓-散筹筹码集中度)>20 and (主力筹码集中度-散筹筹码集中度)>0 and 主力持仓>50;
强庄坐镇:if(qiang,1,0),Coloryellow,linethick0;
DRAWTEXT(强庄坐镇,(底 * 0.99),'●'),Coloryellow;
霸王庄:if(qiang and 主力筹码集中度-散筹筹码集中度>20,1,0)Colorred,linethick0;;
DRAWTEXT(霸王庄,(底 * 0.98),'★'),Colorred;
{神秘均线}
LOCK:=IF(CURRENTDATE<1120923,1,0);
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,6)>REF(EMA((2*CLOSE+HIGH+LOW)/4,6),1),EMA((2*CLOSE+HIGH+LOW)/4,5)),Color0080FF;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,6)<REF(EMA((2*CLOSE+HIGH+LOW)/4,6),1),EMA((2*CLOSE+HIGH+LOW)/4,5)),ColorBFFE01;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,10)>REF(EMA((2*CLOSE+HIGH+LOW)/4,13),1),EMA((2*CLOSE+HIGH+LOW)/4,13)),Color8080FF,LINETHICK2;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,10)<REF(EMA((2*CLOSE+HIGH+LOW)/4,13),1),EMA((2*CLOSE+HIGH+LOW)/4,13)),LINETHICK2,ColorC08000;
PARTLINE(EMA((LOW+CLOSE+OPEN)/3,28)>REF(EMA((LOW+CLOSE+OPEN)/3,28),1),REF(EMA((LOW+CLOSE+OPEN)/3,25),1)),LINETHICK3,colorFF;
PARTLINE(EMA((LOW+CLOSE+OPEN)/3,28)<REF(EMA((LOW+CLOSE+OPEN)/3,28),1),REF(EMA((LOW+CLOSE+OPEN)/3,25),1)),LINETHICK3,colorff00;
PARTLINE((EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2>REF((EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2,1),(EMA(LOW,250)+EMA((CLOSE+LOW)/2,250))/2),linethick2,colorwhite;
PARTLINE((EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2<REF((EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2,1),(EMA(LOW,250)+EMA((CLOSE+LOW)/2,250))/2),linethick2,colorgray;
{股旁网-股票公式网站 www.gupang.com}
小趋势线:ma15,Color008080,linethick0;
小趋势成立:if(MA15 > REF(MA15,1),1,0),linethick0,ColorFF8000;
大趋势线:(EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2,colorwhite,linethick0;
{立庄量}
VOLUME:=VOL,linethick0;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
V2:=IF(BARSTATUS=2,VOL*240/MINUTE/REF(VOL,1)-1,VOL/REF(VOL,1)-1),COLORRED;
STICKLINE(V2>=1,(llv(l,10)/2+hhv(h,10)/2),c,3,0),COLORYELLOW;
DRAWTEXTex(c,1,10,20,'\n所属板块:'+BLKNAME),colorFFFFFF;

飞狐霸王庄2.1版主图指标公式

 

相关文章