在线检测未来函数

同花顺超级MACD指标公式

来源:Internet,编辑:股旁网,2010-07-29

SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLOR00FFFF;
DEA:EMA(DIFF,3),COLORFF33FF;
MACD:(DIFF-DEA),COLORSTICK;
低位金叉:=IF(CROSS(DIFF,DEA) AND DIFF<0,30,0),COLORYELLOW;
STICKLINE(低位金叉,0,15,8,0),COLORYELLOW;
高位死叉:=IF(CROSS(DEA,DIFF) AND DIFF>55,-30,0),COLORYELLOW;
STICKLINE(高位死叉,0,-15,8,0),COLOR00FF00;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,32,0),COLORFF00FF,LINETHICK2; A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),28,0),COLORFF00FF,LINETHICK2;
DRAWLINE(A1=0,DEA, 底背离,DEA,0),COLORRED,LINETHICK2;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),
-28,0),COLORGREEN,LINETHICK2;
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;
A3:=CROSS(DIFF,DEA) AND DEA<0;
零下二次金叉:=IF(FILTER(COUNT(A3,21)=2,10),28,0),COLOR0000FF,LINETHICK2;
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR110:=(2*CLOSE+HIGH+LOW)/4;
VAR120:=SMA(VARE/VARC*100,3,1);
VAR130:=LLV(LOW,34);
VAR140:=SMA(VAR120,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR140>100,VAR140-100,0);
VAR160:=HHV(HIGH,34);
VAR170:=EMA((VAR110-VAR130)/(VAR160-VAR130)*100,8);
VAR180:=EMA(VAR170,5);
STICKLINE(VAR170-VAR180>0,VAR170,VAR180,4,1),COLORRED ;
趋势:=IF(CROSS(VAR170,VAR180),15,0),COLORC0C0C0,LINETHICK1;
STICKLINE(VAR170-VAR180<0,VAR170,VAR180,4,1),COLOR00FF00 ;
金叉选股:IF(零下二次金叉=20 AND 低位金叉=30 AND (VAR170-VAR180)>0,28,0),COLOR0000FF,LINETHICK2;
底背离选股:IF(底背离=28 AND (VAR170-VAR180)>0,28,0),COLOR0000FF,LINETHICK2;

同花顺超级MACD指标公式

 

相关文章