在线检测未来函数

大智慧顶级优化RSI指标公式

来源:Internet,编辑:股旁网,2010-07-29

LC:=REF(C,1);
RSII:=SMA(MAX(C-LC,0),14,1)/SMA(ABS(C-LC),14,1)*100;
压力:HHV(MA(RSII,3),13),COLORGREEN;
支撑:LLV(MA(RSII,3),13),COLORYELLOW;
VAR2:MA(RSII,8),COLOR888888;
VAR3:REF(VAR2,3),COLOR888888;
STICKLINE(VAR2>=VAR3,VAR3,VAR2,3,1),COLOR00FFFF;
STICKLINE(VAR3>VAR2,VAR2,VAR3,3,1),COLORFFBB00;
RSI:RSII,COLORFFFFFF,LINETHICK2;
VAR4:IF(RSI<VAR2,RSI,VAR2),COLORRED,LINETHICK3;
AA:=REF(RSI,3)=HHV(RSI,2*3+1);
BB:=MA(AA,3+1);
CC:=FILTER(BB,3) AND RSI=HHV(RSI,3+1);
{股旁网-股票公式网站 www.gupang.com}
A1:=BARSLAST(REF(CC,1));
背离:=REF(CLOSE,A1+1)<CLOSE AND REF(RSI,A1+1)>RSI AND CC;
DRAWTEXT(顶背离,压力+1.5,'DBL'),COLORMAGENTA;
DRAWLINE(CC,RSI,FILTER(顶背离>0,5),RSI,0),COLORWHITE;
AA2:=REF(RSI,3)=LLV(RSI,2*3+1);
BB2:=MA(AA2,3+1);
CC2:=FILTER(BB2,3) AND RSI=LLV(RSI,3+1);
A2:=BARSLAST(REF(CC2,1));
底背离:=REF(C,A2+1)>CLOSE AND REF(RSI,A2+1)<RSI AND CC2;
DRAWTEXT(底背离,支撑-1.5,'DBL'),COLORMAGENTA;
DRAWLINE(CC2,RSI,FILTER(底背离>0,5),RSI,0),COLORWHITE;

大智慧顶级优化RSI指标公式

 

相关文章