在线检测未来函数

同花顺多空预警指标公式

来源:Internet,编辑:股旁网,2010-07-29

VAR1:=(HIGH+LOW+CLOSE)/3;
VAR2:=(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14));
VAR3:=(VAR1-MA(VAR1,70))/(0.015*AVEDEV(VAR1,70));
VAR4:=IF(VAR2>=150 AND VAR2<200 AND VAR3>=150 AND VAR3<200,10,0);
VAR5:=IF(VAR2<=-150 AND VAR2>-200 AND VAR3<=-150 AND VAR3>-200,-10,VAR4);
VAR6:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR7:=100-ABS(VAR6);
VAR8:=IF(VAR7<90,VAR7,100);
PJX:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
短期强弱:PJX,Colorff33ff;
VAR1A:=IF(PJX>0,PJX,0);
VAR1B:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,VAR5))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR8<100;
VAR1D:=VAR1A<48 AND VAR1B<60 AND VAR8<100;
DRAWTEXT(VAR1D AND COUNT(VAR1D,30)=1,80,'短线反弹'),colorFF7B00;
STICKLINE(VAR1D AND COUNT(VAR1D,30)=1,60,80,5,0),colorFFBE00;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,80,'短线高点'),colorFF62FF;
STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,60,80,5,0),color0000E9;
VAR2C:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,0))+30;
VAR2E:=VAR1A<48 AND VAR2C<30 AND VAR8<100;
VAR2F:=VAR1A<48 AND VAR2C>30 AND VAR8<100;
DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,50,'短线反弹2'),color333399;
STICKLINE(VAR2E AND COUNT(VAR2E,30)=1,30,50,5,0),colorFFFF66;
DRAWTEXT(VAR2F AND COUNT(VAR2F,30)=1,50,'短线高点2'),colorFFCC66;
STICKLINE(VAR2F AND COUNT(VAR2F,30)=1,30,50,5,0),colorFFCC66;
VAR3D:=IF(VAR3<=200 AND VAR2<=150,-15,IF(VAR3>=-200 AND VAR2>=-150,15,VAR5));
VAR3E:=VAR3D>0 AND VAR8<100;
VAR3F:=VAR1A<48 AND VAR3D<0 AND VAR8<100;
DRAWTEXT(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,'短线反弹3'),coloryellow;
STICKLINE(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,0,5,0),coloryellow;
DRAWTEXT(VAR3E AND COUNT(VAR3E,30)=1,20,'短线高点3'),colorFF2266;
STICKLINE(VAR3E AND COUNT(VAR3E,30)=1,20,0,5,0),colorFF2266;
强势线:60,coloryellow;
VAR9:=IF(VAR7<90,40,30);
分界线:30,colorFFFFFF;
STICKLINE(FILTER(VAR1B=45,5),-20,-10,5,0),color077BF6;
DRAWTEXT(FILTER(VAR1B=45,5),0,'强支撑'),color077BF6;
STICKLINE(FILTER(VAR1B=75,5),75,60,5,0),colorred;
DRAWTEXT(FILTER(VAR1B=75,5),75,'高压'),colorred;
STICKLINE(PJX<=-19,-25,-20,12,0),colorred;
STICKLINE(PJX>=70,85,80,12,0),coloryellow;
DRAWTEXT(FILTER(VAR5>0,5),30,'★'),coloryellow;
多空预警:0,color0726CA;
PARTLINE(VAR9=40 AND VAR2>=0 AND VAR3>=0,多空预警,color0000B5);
PARTLINE(VAR9=40 AND VAR2<=0 AND VAR3<=0,多空预警,color077BF6);

同花顺多空预警指标公式

 

相关文章