在线检测未来函数

大智慧数字K线+光标自动解K线主图指标公式

来源:Internet,编辑:股旁网,2010-07-29

{DRAWGBKLAST(DATE>900101,STRIP(RGB(15,125,125),RGB(0,50,0),0));}
DRAWTEXTABS(10,8,STKLABEL+' '+STKNAME+' '+BKNAME),COLOR00FFFF;
N:=20;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));
量能饱和度:=IF(SAT>1,1,SAT)*100;
DRAWTEXTABS(20,28,'量能饱和度:'+NUMTOSTRN(量能饱和度,2)+'%'),COLORred;
DRAWRECTREL(1,83,18,382,RGB(30,30,30)),COLORWHITE;
AAA:=量能饱和度<=10;
BBB:=量能饱和度>10 AND 量能饱和度<=20;
CCC:=量能饱和度>20 AND 量能饱和度<=30;
DDD:=量能饱和度>30 AND 量能饱和度<=50;
EEE:=量能饱和度>50 AND 量能饱和度<=70;
FFF:=量能饱和度>70 AND 量能饱和度<=80;
GGG:=量能饱和度>80 AND 量能饱和度<=90;
HHH:=量能饱和度>90;
IF BARSTATUS=2 AND AAA THEN BEGIN DRAWRECTREL(3,350,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND BBB THEN BEGIN DRAWRECTREL(3,320,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND CCC THEN BEGIN DRAWRECTREL(3,290,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND DDD THEN BEGIN DRAWRECTREL(3,230,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND EEE THEN BEGIN DRAWRECTREL(3,170,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND FFF THEN BEGIN DRAWRECTREL(3,140,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND GGG THEN BEGIN DRAWRECTREL(3,110,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND HHH THEN BEGIN DRAWRECTREL(3,85,16,380,RGB(255,0,0));
END;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,30,0),Color0000FF;
STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,30,0),Color00FF00;
STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,30,0),ColorFF00FF;
STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,30,0),ColorFF0000;
DRAWTEXTREL(23,117,'--------------------------------'),ColorFFFFFF;
IF BARSTATUS=2 and c>=今日支撑 THEN
DRAWTEXTREL(23,147,'今日支撑=:'+NUMTOSTRN(今日支撑 ,2 )),ColorFF00FF;
IF BARSTATUS=2 and c<今日支撑 THEN
DRAWTEXTREL(23,147,'今日支撑=:'+NUMTOSTRN(今日支撑 ,2 )),ColorFF0000;
IF BARSTATUS=2 and c>=今日阻力 THEN
DRAWTEXTREL(23,187,'今日阻力=:'+NUMTOSTRN(今日阻力 ,2 )),Color0000FF;
IF BARSTATUS=2 and c<今日阻力 THEN
DRAWTEXTREL(23,187,'今日阻力=:'+NUMTOSTRN(今日阻力 ,2 )),Color00FF00;
IF BARSTATUS=2 and c>=明日支撑 THEN
DRAWTEXTREL(143,147,'明日支撑=:'+NUMTOSTRN(明日支撑 ,2 )),Color00FFFF;
IF BARSTATUS=2 and c<明日阻力 THEN
DRAWTEXTREL(143,187,'明日阻力=:'+NUMTOSTRN(明日阻力 ,2 )),Color00FFFF;
DRAWTEXTREL(23,227,'--------------------------------'),ColorFFFFFF;
IF BARSTATUS=2 and v>ref(v,1) and ma(v,5)>ref(ma(v,5),1) THEN
DRAWTEXTREL(160,87,'今日成交量大于昨日,且有继续增大趋势'),Color8285FF;
IF BARSTATUS=2 and v<ref(v,1) and ma(v,5)>ref(ma(v,5),1) THEN
DRAWTEXTREL(160,87,'今日成交量小于昨日,但有放大迹象'),Color8285FF;
IF BARSTATUS=2 and v>ref(v,1)and ma(v,5)<ref(ma(v,5),1) THEN
DRAWTEXTREL(160,87,'今日成交量大于昨日, 但有缩小迹象'),Color8285FF;
IF BARSTATUS=2 and v<ref(v,1)and ma(v,5)<ref(ma(v,5),1) THEN
DRAWTEXTREL(160,87,'今日成交量小于昨日,且有缩小迹象'),Color8285FF;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
aRSV:=SMA(下档线,3,1);
aK:=SMA(aRSV,3,1);
aD:=((3 * aRSV) - (2 * aK));
aJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
aRSV24:=SMA(aJ12,3,1);
aK24:=SMA(aRSV24,3,1);
aD24:=((3 * aRSV24) - (2 * aK24));
撑压位:=IF(CROSS(aD24,aD),HIGH,REF(HIGH,BARSLAST(CROSS(aD24,aD))));
底:=LLV(HIGH,30){,COLOR00FF00,LINETHICK2};
STICKLINE(BARSTATUS=2 ,撑压位,撑压位,30,1),LINETHICK1,COLORFFFFFF;
DRAWTEXT(BARSTATUS=2 ,撑压位,' 撑压'),COLORFFFFFF,VALIGN1;
STICKLINE(BARSTATUS=2 ,底,底,30,1),COLOR00FF00,LINETHICK1;
DRAWTEXT(BARSTATUS=2 ,底,' 底线'),COLOR00FF00,VALIGN0;
AA05:MA(C,5),colorff00ff,linethick1;
五日乖离率:=(c-AA05)/AA05*100;
BB05:=atan((aa05/ref(aa05,1)-1)*100)*180/3.1416;
速度5:=sma(ema((AA05-ref(AA05,1))/ref(AA05,1),3)*100,3,1);
加速度5:ema((速度5-ref(速度5,1)),3),linethick0;
STICKLINE(BB05>30 and AA05>ref(AA05,1), AA05,REF(AA05,1),8,1),colorff00ff;
AA10:MA(C,10),coloryellow;
AA20:=MA(c,20);
BB10:=atan((aa10/ref(aa10,1)-1)*100)*180/3.1416;
STICKLINE(BB05<0 and AA05<ref(AA05,1), AA05,REF(AA05,1),3,1),colorcyan;
AA30:MA(C,30),colorwhite;
三拾日乖离率:(c-AA30)/AA30*100,linethick0;
Var1:=(AA20-AA30)>ref((AA20-AA30),1) and AA20>ref(aa20,1) and AA30>ref(AA30,1);
Var2:=(AA30-AA20)<ref((AA30-AA20),1) and AA20<ref(aa20,1) and AA30<ref(AA30,1);
BB30:=atan((aa30/ref(aa30,1)-1)*100)*180/3.1416;
STICKLINE(BB30>15 and AA30>ref(AA30,1), AA30,REF(AA30,1),8,1),colorff00ff;
强势狙击:=filter(BB30>30 and BB10>45 and cross(BB05,60),10);
加仓:=filter(count(cross(BB05,30),5)>=1 and AA05>ref(aa05,1) and 三拾日乖离率>ref(三拾日乖离率,1) and AA10>ref(AA10,1)
and 加速度5>ref(加速度5,1) and 速度5>ref(速度5,1) ,10) ;
{股旁网-股票公式网站 www.gupang.com}
清仓:=filter(count(cross(30,BB05),5)>=1 and (c>AA30 or O>AA30) and AA05<ref(aa05,1) and 三拾日乖离率<ref(三拾日乖离率,1) and AA10<ref(AA10,1),10);
drawtext(加仓 ,low*0.98,'←加仓'),colorred;
JC:=cross(0,五日乖离率) and 三拾日乖离率<ref(三拾日乖离率,1) and AA10>ref(AA10,1) ;
减仓:=filter(JC,10);
MR:=count(cross(五日乖离率,0),3)>=1 and 三拾日乖离率>ref(三拾日乖离率,1) and AA05>ref(AA05,1) and (c/ref(c,1)-1)*100>5 and ref(c,1)<AA30;
买入:=filter(MR,10);
drawtext(减仓,high*1.02,'←减仓'),colorcyan;
drawtext(买入,low*0.98,'←买入'),coloryellow;
drawtext(清仓 ,high*1.02,'←清仓'),COLORGREEN;
drawtext(强势狙击,LOW*0.98,'←强势狙击'),coloryellow;
Var21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
Var3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(Var21+Var3)/AMOUNT*VOL*100*50;
DRAWTEXT(MV>6 and l<=llv(l,10),l*0.96,'←异动'),colorcyan;
aa:=if(c>=ref(c,3),1,0);
bb:=if(c>=ref(c,5),1,0);
cc:=if(c>=ref(c,7),1,0);
dd:=if(c>=ref(c,8),1,0);
ee:=if(c>=ref(c,13),1,0);
ff:=if(c>=ref(c,21),1,0);
gz2:=aa+bb+cc+dd+ee+ff;
Var11:=EMA(CLOSE,3)-EMA(CLOSE,6)-(EMA(CLOSE,6)-EMA(CLOSE,12))*(-100);
Var12:=EMA(Var11,3);
Var5:=CROSS(Var11,Var12);
Var6:=CROSS(Var12,Var11);
STICKLINE(C>=O,l,H,0,0), COLOR0000FF,LAYER2;
STICKLINE(C<O,l,H,0,0), COLORFFFF00,LAYER2;
STICKLINE(C>=O,O,C,10,1), COLOR0000FF,LAYER2;
STICKLINE(C<O,O,C,8,0), COLORFFFF00,LAYER2;
STICKLINE(Var6,OPEN,CLOSE,8,0), COLORBLUE,LAYER0;{兰色熊K}
STICKLINE(Var5,OPEN,CLOSE,5,0), COLORYELLOW,LAYER0;{彩色牛K}
STICKLINE(Var5,OPEN,CLOSE-(CLOSE-OPEN)*0.33,5,0), COLORaaccdd,LAYER0;{彩色牛K}
STICKLINE(Var5,OPEN,CLOSE-(CLOSE-OPEN)*0.66,5,0), COLORRED,LAYER0;{彩色牛K}
DRAWTEXT(c>0,(O+C)/2,NUMTOSTRN(gz2 ,0 )),coloryellow,LAYER0,ALIGN1,VALIGN0,LINETHICK1;{彩色牛K};
早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
解盘:='【K线形态解盘】'+
IFs(倾盆大雨,'★倾盆大雨,见顶信号;','')+
IFs(大阴烛,'★大阴烛,后市向淡,发生逆转;','')+
IFs(好友反攻,'★好友反攻,底部反转;','')+
IFs(跳空缺口,'★跳空缺口,注意向上还是向下跳空;','')+
IFs(光脚阴线,'★光脚阴线,下跌信号;','')+
IFs(光头阳线,'★光头阳线,后市看涨;','')+
IFs(三只乌鸦,'★三只乌鸦,可能见顶回落;','')+
IFs(分离,'★分离,注意看涨分离和看跌分离;','')+
IFs(长下影,'★长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;','')+
IFs(长上影,'★长上影,表明行情上档压力沉重,升势受阻;','')+
IFs(下跌三部曲,'★下跌三部曲,下跌信号;','')+
IFs(上升三部曲,'★上升三部曲,上涨信号;','')+
IFs(早晨之星,'★早晨之星,见底回升;','')+
IFs(黄昏之星,'★黄昏之星,见顶回落;','')+
IFs(十字星,'★十字星,有转向意味,注意股价位置在顶部还是底部;','')+
IFs(长十字,'★长十字,注意在顶部还是底部;','')+
IFs(垂死十字,'★垂死十字,下跌信号;','')+
IFs(早晨十字星,'★早晨十字星,上涨信号,见底回升;','')+
IFs(黄昏十字星,'★黄昏十字星,下跌信号,见顶回落;','')+
IFs(射击之星,'★射击之星,可能见顶回落,可靠性低;','')+
IFs(倒转锤头,'★倒转锤头,可能见底回升;','')+
IFs(锤头,'★锤头,可能见底回升,如有量配合,信号强烈;','')+
IFs(吊颈,'★吊颈,上升行情中见顶回落,顶部出现,见顶信号;','')+
IFs(平顶,'★平顶,温和的反转;','')+
IFs(穿头破脚,'★穿头破脚,顶部出现,见顶回落信号;','')+
IFs(乌云盖顶,'★乌云盖顶,见顶回落信号;','')+
IFs(曙光初现,'★曙光初现,后市见底回升;','')+
IFs(身怀六甲,'★身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号;','')+
IFs(十字胎,'★十字胎;','')+
IFs(平底,'★平底,温和的反转;','')+
IFs(大阳烛,'★大阳烛,看涨;','')+
IFs(三个白武士,'★三个白武士,每日收盘价上移,表示可能见底回升;','')+
IFs(双飞乌鸦,'★双飞乌鸦,行情将见顶回落;','')+
IFs(孕育线,'★孕育线,注意股价位置;','')+
IFs(多方炮,'★多方炮,在底部出现有上涨意味,在中间出现有可能是上涨中继,顶部出现是复合见顶信号;','')+
IFs(出水芙蓉,'★出水芙蓉,见底回升;','');
DRAWFLAGTEXT(倾盆大雨,c,'★倾盆大雨,见顶信号'),COLORGREEN;
DRAWFLAGTEXT(大阴烛,c,'★大阴烛,后市向淡,发生逆转'),COLORGREEN;
DRAWFLAGTEXT(好友反攻,c,'★好友反攻,底部反转'),COLORred;
DRAWFLAGTEXT(跳空缺口,c,'★跳空缺口,注意向上还是向下跳空'),colorff00ff;
DRAWFLAGTEXT(光脚阴线,c,'★光脚阴线,下跌信号'),COLORGREEN;
DRAWFLAGTEXT(光头阳线,c,'★光头阳线,后市看涨'),COLORred;
DRAWFLAGTEXT(三只乌鸦,c,'★三只乌鸦,小心见顶回落'),COLORGREEN;
DRAWFLAGTEXT(分离,c,'★分离,注意看涨分离和看跌分离'),COLORGREEN;
DRAWFLAGTEXT(长下影,c,'★长下影,持续下跌后出现,止跌回升;在升势末出现,多加留意'),colorff00ff;
DRAWFLAGTEXT(长上影,c,'★长上影,行情上档压力沉重,升势受阻'),COLORGREEN;
DRAWFLAGTEXT(下跌三部曲,c,'★下跌三部曲,下跌信号'),COLORGREEN;
DRAWFLAGTEXT(上升三部曲,c,'★上升三部曲,上涨信号'),COLORred;
DRAWFLAGTEXT(早晨之星,c,'★早晨之星,见底回升'),COLORred;
DRAWFLAGTEXT(黄昏之星,c,'★黄昏之星,见顶回落'),COLORGREEN;
DRAWFLAGTEXT(十字星,c,'★十字星,有转向意味,注意股价位置在顶部还是底部'),colorff00ff;
DRAWFLAGTEXT(长十字,c,'★长十字,注意在顶部还是底部'),COLORGREEN;
DRAWFLAGTEXT(垂死十字,c,'★垂死十字,下跌信号'),COLORGREEN;
DRAWFLAGTEXT(早晨十字星,c,'★早晨十字星,上涨信号,见底回升'),COLORred;
DRAWFLAGTEXT(黄昏十字星,c,'★黄昏十字星,下跌信号,见顶回落'),COLORGREEN;
DRAWFLAGTEXT(射击之星,c,'★射击之星,可能见顶回落,可靠性低'),COLORGREEN;
DRAWFLAGTEXT(倒转锤头,c,'★倒转锤头,可能见底回升'),COLORred;
DRAWFLAGTEXT(锤头,c,'★锤头,可能见底回升,如有量配合,信号强烈'),COLORred;
DRAWFLAGTEXT(吊颈,c,'★吊颈,上升行情中见顶回落,顶部出现,见顶信号'),colorff00ff;
DRAWFLAGTEXT(平顶,c,'★平顶,温和的反转'),COLORred;
DRAWFLAGTEXT(穿头破脚,c,'★穿头破脚,顶部出现,见顶回落信号'),COLORGREEN;
DRAWFLAGTEXT(乌云盖顶,c,'★乌云盖顶,见顶回落信号'),COLORGREEN;
DRAWFLAGTEXT(曙光初现,c,'★曙光初现,后市见底回升'),COLORred;
DRAWFLAGTEXT(身怀六甲,c,'★身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号'),colorff00ff;
DRAWFLAGTEXT(十字胎,c,'★十字胎'),COLORred;
DRAWFLAGTEXT(平底,c,'★平底,温和的反转'),COLORred;
DRAWFLAGTEXT(大阳烛,c,'★大阳烛,看涨'),COLORred;
DRAWFLAGTEXT(三个白武士,c,'★三个白武士,每日收盘价上移,表示可能见底回升'),COLORred;
DRAWFLAGTEXT(双飞乌鸦,c,'★双飞乌鸦,小心见顶回落'),COLORGREEN;
DRAWFLAGTEXT(孕育线,c,'★孕育线,注意股价位置'),COLORred;
DRAWFLAGTEXT(多方炮,c,'★多方炮,配合量能确定顶底'),colorff00ff;

大智慧数字K线+光标自动解K线主图指标公式

 

相关文章