在线检测未来函数

大智慧铁龙DMI指标公式

来源:Internet,编辑:股旁网,2010-07-29

N:=7;
TR := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/TR,COLORFFFFFF;
MDI:DMM*100/TR,COLORYELLOW;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLOR0000FF,LAYER0;
{股旁网-股票公式网站 www.gupang.com}
春暖:= REF(PDI,1)<REF(PDI,2) AND REF(ADX,1)<REF(ADX,2) AND PDI>REF(PDI,1) AND ADX>REF(ADX,1) AND PDI>MDI AND PDI>ADX AND C/REF(C,1)>1.01 ;
STICKLINE(春暖,0,20,2,0 ),COLORFF00FF,LAYER0;
60,COLORFFFF00,POINTDOT;
20,COLOR00FF00,POINTDOT;

大智慧铁龙DMI指标公式

 

相关文章