在线检测未来函数

同花顺RSI复合通道指标公式

来源:Internet,编辑:股旁网,2010-07-28

 M=12,2,10;
N1=6,2,100;
N2=13,2,100;
LC:=REF(CLOSE,1);
RS1:=SMA(MAX(CLOSE-LC,0),M,1)/SMA(ABS(CLOSE-LC),M,1)*100;
ATR:=MA(MAX(MAX((RS1-RS1),ABS(REF(RS1,1)-RS1)),ABS(REF(RS1,1)-RS1)),15);
VM:=MA(RS1,N1);
SM:MA(RS1,20),PRECIS1,Coloraaee00,LINETHICK0;
SU:SM+2*STD(RS1,20),PRECIS1,Coloraaee00,LINETHICK0;
SD:SM-2*STD(RS1,20),PRECIS1,Coloraaee00,LINETHICK0;
VU:VM+2.3*ATR,PRECIS1,Colorffffff,LINETHICK0;
VD:VM-2.1*ATR,PRECIS1,Colorffffff,LINETHICK0;
//{DRAWGBKLAST(C>0),Color7a6500};
FILLRGN(SU,SD,C>0,RGB(0,170,140)),PRECIS1;
FILLRGN(VU,VD,C>0,RGB(210,210,210)),PRECIS1;
RSI:RS1,PRECIS1,Color0000ff,LINETHICK2,LAYER0;
MA1:VM,PRECIS1,Colorff0000;
MA2:MA(RS1,N2),PRECIS1,Color004a00,LINETHICK2;
强势:70,colorred,LAYER3;
中势:50,colorblue,LAYER3;
弱势:30,colorgreen,LAYER3;

同花顺RSI复合通道指标公式

 

相关文章