在线检测未来函数

通达信资金流向K线主图指标公式

来源:Internet,编辑:股旁网,2010-07-28

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30);
MA60:MA(C,60);MA120:MA(C,120);
量_价:=1;CTKG:=1;
W:=量_价;
EPSL:=0.0001;
ZZ:=(C+H+L)/3;
TJA:=ZZ>=MAX(C,O) AND CTKG=1;{倒锤头};
TJB:=ZZ<=MIN(C,O) AND CTKG=1;{正锤头};
ZF:=IF(TJA,1,IF(TJB,-1,0));{正负数};
TJ0:=TJA OR TJB;
TJ1:=H=L AND C>REF(C,1);{一字涨停};
TJ2:=H=L AND C<REF(C,1);{一字跌停};
TJ3:=H=L AND C=REF(C,1);{连续一字涨、跌停};
{股旁网-股票公式网站 www.gupang.com}
量_价:=IF(W=1,VOL,AMOUNT),STICK,COLOREEFFEE;{平盘量,白色}
EE:=IF(TJ1,EPSL,IF(TJ2,-EPSL,0));
ZL:=2*(H-L)+ABS(C-O)+3*IF(TJ3,EPSL,ABS(EE));
JGL_DX:=(IF(TJ0,2/3*(2*C-H-L)+ZF*ABS(C-O),(C-O))+EE)/ZL;
差:=(JGL_DX*量_价)/20000,COLOR13AADD,NODRAW;
DX:=JGL_DX*100,NODRAW;
买:=量_价*(1+JGL_DX)/20000,COLOR1133AA,NODRAW;
卖:=量_价*(1-JGL_DX)/20000,COLORFFFF00,NODRAW;
量差:=买-卖,NODRAW,COLORYELLOW;
STICKLINE(量差<=0,CLOSE,OPEN,3,0),COLOR009900;
STICKLINE(量差<=0,CLOSE,OPEN,2.2,0),COLOR00BB00;
STICKLINE(量差<=0,CLOSE,OPEN,1.5,0),COLOR00DD00;
STICKLINE(量差<=0,CLOSE,OPEN,0.5,0),COLOR00FF00;
STICKLINE(量差>=0,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(量差>=0,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(量差>=0,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(量差>=0,CLOSE,OPEN,0.5,0),COLORCC66FF;
V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);
STICKLINE(V2V,OPEN,CLOSE,0.5,0),COLORYELLOW;
ZT:=C/REF(C,1)>1.097;
STICKLINE(ZT,OPEN,CLOSE,0.5,0),COLORYELLOW;
V3V:=V/REF(V,1)>=1.9 AND C<REF(C,1);
STICKLINE(V3V,OPEN,CLOSE,0.5,0),COLORBLUE;

通达信资金流向K线主图指标公式

 

相关文章