在线检测未来函数

飞狐cci操盘铁律指标公式

来源:Internet,编辑:股旁网,2010-08-01

DRAWGBK((DATE > 0),COLORRGB(40,40,173),COLORRGB(1,1,14),1);
LC:=REF(CLOSE,1);
止损价位:(LC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0;
滤网:=close>ref(high,1) and close>open;
RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
D:=SMA(CCC,3,1);
回抽:IF(CROSS(D,RSI5),50,0),STICK,COLORRED;
【逃命】:IF(CROSS(80,RSI5),-50,0),STICK,COLORGREEN;
STICKLINE(CROSS(D,RSI5),50,0,8,0),COLORRED;
STICKLINE(CROSS(80,RSI5),-50,0,8,0),COLORGREEN;
rr9:=(CLOSE-MA(CLOSE,27))/MA(CLOSE,27)*100;
rrA:=MA(rr9,2);
rrB:=BARSLAST(CROSS(-10,rrA)=1);
rrD:=rrA<-10 AND rrB>3;
黄金坑:IF(rrD,-50,0),coloryellow,LINETHICK2;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,n))/(0.015*AVEDEV(TYP,n)),COLORMAGENTA,LINETHICK2;
上穿买入:if(cross(cci,-100) and 滤网,-50,-100),colorwhite;
drawicon(上穿买入=-50,cci,12);
VARB:=SMA(ABS(LOW-REF(LOW,1)),3,1)/SMA(MAX(LOW-REF(LOW,1),0),3,1)*100;
VARC:=EMA(IF(CLOSE*1.3,VARB*10,VARB/10),3);
VARE:=HHV(VARC,30);
VARG:=EMA(IF(LOW<=LLV(LOW,30),(VARC+VARE*2)/2,0),3)/618;
VARH:=IF(VARG>50,50,VARG);
吸筹:STICKLINE(VARH>-120,0,VARH,6,1),COLOR0FFFFF;
买入时机: IF(CROSS(Cci,-150) ,-150,-200),COLORred;
C2:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84));
牛启动: IF(CROSS(C2,-70),-100,-150),COLORGREEN;
选股:牛启动=-100 or 买入时机=-150 or 上穿买入=-50,linethick0;
{底部:-200,LINEDOT;}
{股旁网-股票公式网站 www.gupang.com}
卖出:if(cross(100,cci) and close<ref(low,1),80,100),LINEDOT;
drawtext(cross(cci,-100),-100,'-100'),COLORMAGENTA;
AA:=REF(cci,N)=HHV(cci,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND cci=HHV(cci,N+1);
A1:=BARSLAST(REF(CC,1));
背离:=REF(H,A1+1)<H AND REF(cci,A1+1)>cci AND CC;
DRAWTEXT(顶背离,cci*1.2,'顶背离'),COLORMAGENTA;
DRAWLINE(CC,cci,FILTER(顶背离>0,5),cci,0),COLORMAGENTA;
DRAWICON(顶背离,cci*1.1,2);
AA2:=REF(cci,N)=LLV(cci,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND cci=LLV(cci,N+1);
A2:=BARSLAST(REF(CC2,1));
底背离:=REF(L,A2+1)>L AND REF(cci,A2+1)<cci AND CC2;
DRAWTEXT(底背离,cci*1.2,'底背离'),COLORMAGENTA;
DRAWLINE(CC2,cci,FILTER(底背离>0,5),cci,0),COLORMAGENTA;
DRAWICON(底背离,cci*0.98,1);
EXPLAIN(1,'(一)长期下跌后第一次碰-100不能买,第二次碰-100在即将上穿之时买入(必须底背离,成功率才100%)。'),COLORYELLOW,ALIGN2;
EXPLAIN(1,'(二)股价到+100时"加码"买入,在+100以上开始回头时跌破+100应该卖出,然后按照支撑位置可以买入,第二次穿过+100之时股价一般会创新高,但是指标如果背离时,再次跌破+100,坚决抛光!'),COLORYELLOW,ALIGN2;
EXPLAIN(1,'(三)再次到-100以下时,就重复上面的方法。\n'),COLORYELLOW,ALIGN2;
explain(底背离,'CCI指标出现底背离'),colorred;
explain(顶背离,'CCI指标出现顶背离,提高警惕,保卫成果'),colorgreen;
explain(上穿买入=-50,'CCI上穿-100,并且通过滤网,如果K线品质良好,及时跟进'),colorred;
explain(rrD,'股价进入黄金坑,留意何时走出黄金坑,完成筑底阶段'),coloryellow;
explain(rrD=0 and ref(rrD,1)=1,'股价走出黄金坑,完成筑底,注意分析形态及K线形态,及时跟进'),colorred;
explain(VARH>0,'50上的黄柱表示吸筹'),coloryellow;

飞狐cci操盘铁律指标公式

 

相关文章