在线检测未来函数

大智慧筹码分析主图指标公式

来源:Internet,编辑:股旁网,2010-08-01

MA6:=MA(CLOSE,6);
MA18:=MA(CLOSE,18);
空:(3)*(MA18) - (2)*(MA6),LINETHICK3,COLORCYAN;
多:(3)*(MA6) - (2)*(MA18),LINETHICK3,COLOR0000C0;
超买:MA(C,10)*IF(CAPITAL=0,1.04,1.1),DOTLINE,COLORGREEN,LINETHICK1;
超卖:MA(C,10)*IF(CAPITAL=0,0.95,0.9),DOTLINE,COLORYELLOW,LINETHICK1;
【生命线】:sum(vol*(o+c)/2,88)/sum(vol,88),COLOR0000FF,linethick1;
持股线】:hhv(ma(C,18),2),COLORYELLOW;
【分离线】:if(ma(C,18)<【持股线】,(ma(C,18)-(【持股线】-ma(C,18))),【持股线】),COLORCYAN,linethick1;
MA18:ma(C,18),linethick1,COLORWHITE;
角度:ATAN((MA18/REF(MA18,1)-1)*100)*180/3.14159,linethick0;
一:=COST(10)/COST(1);
二:=COST(20)/COST(10);
三:=COST(30)/COST(20);
四:=COST(40)/COST(30);
五:=COST(50)/COST(40);
密:=一<二 AND 一<三 AND 一<四 AND 一<五 ;
密二:=二<三 AND 二<四 AND 二<五 ;
密三:=三<二 AND 三<四 AND 三<五 ;
密四:=四<二 AND 四<三 AND 四<五 ;
密五:=五<二 AND 五<三 AND 五<四 ;
STICKLINE(c>=o,c,o,9,1),colorred;
STICKLINE(c>=o,l,o,0.1,0),colorred;
STICKLINE(c>=o,c,h,0.1,0),colorred;
STICKLINE(c<o,c,o,9,0),colorffff00;
STICKLINE(c<o,h,l,0.1,0),colorffff00;
x11:POLYLINE(密二>0,COST(11)),COLOR008800;
x21:POLYLINE(密二>0,COST(12)),COLOR008800;
x31:POLYLINE(密二>0,COST(13)),COLOR008800;
x41:POLYLINE(密二>0,COST(14)),COLOR008800;
x51:POLYLINE(密二>0,COST(15)),COLOR008800;
x61:POLYLINE(密二>0,COST(16)),COLOR008800;
x71:POLYLINE(密二>0,COST(17)),COLOR008800;
x81:POLYLINE(密二>0,COST(18)),COLOR008800;
x91:POLYLINE(密二>0,COST(19)),COLOR008800;
x12:POLYLINE(密三>0,COST(21)),COLORff9933;
x22:POLYLINE(密三>0,COST(22)),COLORff9933;
x32:POLYLINE(密三>0,COST(23)),COLORff9933;
x42:POLYLINE(密三>0,COST(24)),COLORff9933;
x52:POLYLINE(密三>0,COST(25)),COLORff9933;
x62:POLYLINE(密三>0,COST(26)),COLORff9933;
x72:POLYLINE(密三>0,COST(27)),COLORff9933;
x82:POLYLINE(密三>0,COST(28)),COLORff9933;
x92:POLYLINE(密三>0,COST(29)),COLORff9933;
x13:POLYLINE(密四>0,COST(31)),COLOR008800;
x23:POLYLINE(密四>0,COST(32)),COLOR008800;
x33:POLYLINE(密四>0,COST(33)),COLOR008800;
x43:POLYLINE(密四>0,COST(34)),COLOR008800;
x53:POLYLINE(密四>0,COST(35)),COLOR008800;
x63:POLYLINE(密四>0,COST(36)),COLOR008800;
x73:POLYLINE(密四>0,COST(37)),COLOR008800;
x83:POLYLINE(密四>0,COST(38)),COLOR008800;
x93:POLYLINE(密四>0,COST(39)),COLOR008800;
x14:POLYLINE(密五>0,COST(41)),COLOR33cc00;
x24:POLYLINE(密五>0,COST(42)),COLOR33cc00;
x34:POLYLINE(密五>0,COST(43)),COLOR33cc00;
x44:POLYLINE(密五>0,COST(44)),COLOR33cc00;
x54:POLYLINE(密五>0,COST(45)),COLOR33cc00;
x64:POLYLINE(密五>0,COST(46)),COLOR33cc00;
x74:POLYLINE(密五>0,COST(47)),COLOR33cc00;
x84:POLYLINE(密五>0,COST(48)),COLOR33cc00;
x94:POLYLINE(密五>0,COST(49)),COLOR33cc00;
stickline(密>0 AND c<COST(50),COST(10),COST(2),2,1),COLORGREEN;
stickline(密二>0 AND c<COST(50),COST(10),COST(20),0.8,1),COLORYELLOW;
stickline(密二>0 AND c<COST(50),COST(20)/1.0017,COST(20),4,1),COLORYELLOW;
stickline(密三>0 AND c<COST(50),COST(20),COST(30),1,1),COLORYELLOW;
stickline(密三>0 AND c<COST(50),COST(30)/1.0017,COST(30),4,1),COLORYELLOW;
stickline(密四>0 AND c<COST(50),COST(30),COST(40),0.8,1),COLORYELLOW;
stickline(密四>0 AND c<COST(50),COST(40)/1.0017,COST(40),4,1),COLORYELLOW;
stickline(密五>0 AND c<COST(50),COST(40),COST(50),1,1),COLORYELLOW;
stickline(密五>0 AND c<COST(50),COST(50)/1.0017,COST(50),4,1),COLORYELLOW;
aa:=if(c>=ref(c,3),1,0);
bb:=if(c>=ref(c,5),1,0);
cc:=if(c>=ref(c,7),1,0);
dd:=if(c>=ref(c,8),1,0);
ee:=if(c>=ref(c,13),1,0);
ff:=if(c>=ref(c,21),1,0);
gz2:=aa+bb+cc+dd+ee+ff;
kk:=0;
for i=1 TO 4 DO
kk:=kk+REF(gz2,i);
kkk:=kk/4;
DRAWTEXT(kkk=0 and gz2>0 and c>REF(c,1),L*0.994,'买'),COLORYELLOW,linethick3;
DRAWTEXT(kkk=6 and gz2<6 ,H*1.025,'卖'),COLORWHITE,ALIGN2,linethick3;
A:=SUMBARS(V,CAPITAL*1);
A1:=SUM(COST(10),A)/A;
A2:=SUM(COST(20),A)/A;
A3:=SUM(COST(30),A)/A;
A4:=SUM(COST(40),A)/A;
A5:=SUM(COST(50),A)/A;
庄家成本线:(5*A1+4*A2+3*A3+2*A4+A5)/15,Color98FF00,linethick1;
Var21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
Var3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(Var21+Var3)/AMOUNT*VOL*100*50;
DRAWTEXT(MV>6 and l<=llv(l,10),l*0.98,'←异动'),colorcyan;
varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);
var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3)) or ref(c,1)=hhv(c,4) and close>=ref(c,2) or ref(c,2)=hhv(c,4) and ref(c,3)=llv(c,4) and c>=ref(c,1) or ref(c,3)=hhv(c,4) and c>=ref(c,1) and c>=ref(c,2);
vardQ:=ref(c,1)=hhv(c,4) and c<ref(c,2) or (ref(c,2)=hhv(c,4) and ref(c,1)>ref(c,3) or ref(c,3)=hhv(c,4) and ref(c,1)>ref(c,2)) and ref(c,2)>=ref(c,4) and c<ref(c,1);
注:drawtext(varcQ and var9Q and varcq=1 and c>o,low*0.998,'▲关注'),coloryellow,linethick1;
警:drawtext(vardQ,high*1.01,'▼警示'),COLORGREEN,linethick1;
ED1:=(-2*REF(C,2)+REF(C,1)+2*C);
ED2:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
ED3:=(-0.8*REF(C,4)-0.8*REF(C,3)-0.2*REF(C,2)+0.8*REF(C,1)+2*C);
JF1:=SMA(SMA(ED1,3,1),3,1);
JF2:=SMA(SMA(ED2,4,1),3,1);
JF3:=SMA(SMA(ED3,4,1),4,1);
{股旁网-股票公式网站 www.gupang.com}
DRAWICON(sum(CROSS(ED1,JF1) + CROSS(ED2,JF2) + CROSS(ED3,JF3),1)>1,L/1.001,1);
DRAWICON(sum(CROSS(JF1,ED1) + CROSS(JF2,ED2) + CROSS(JF3,ED3),1)>1,H*1.051,2);
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
DRAWTEXT(IF(B1>0,1,0),L-0.1,'MACD底背'),COLORGREEN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);
DRAWTEXT(IF(B2>0,1,0),L-0.25,'KDJ底背'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);
DRAWTEXT(IF(B3>0,1,0),L-0.1,'RSI底背'),COLORCYAN;
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(IF(D1>0,1,0),H+0.05,'MACD顶背'),COLORWHITE;
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);
DRAWTEXT(IF(D2>0,1,0),H+0.20,'KDJ顶背'),COLORWHITE;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
DRAWTEXT(IF(D3>0,1,0),H+0.2,'RSI顶背'),COLORWHITE;
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*1.06,'【绝佳】') ,LINETHICK3,COLORYELLOW;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.03,'卖'),COLORCYAN,LINETHICK2;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,30,0),Color0000FF;
STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,30,0),Color00FF00;
STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,30,0),ColorFF00FF;
STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,30,0),ColorFF0000;
DRAWTEXTREL(10,10,'------------------------------------'),ColorFFFFFF;
IF BARSTATUS=2 and c>=今日支撑 THEN
DRAWTEXTREL(10,50,'今日支撑:'+NUMTOSTRN(今日支撑 ,2 )),ColorFF00FF;
IF BARSTATUS=2 and c<今日支撑 THEN
DRAWTEXTREL(10,50,'今日支撑:'+NUMTOSTRN(今日支撑 ,2 )),ColorFFFFFF;
IF BARSTATUS=2 and c>=今日阻力 THEN
DRAWTEXTREL(10,120,'今日阻力:'+NUMTOSTRN(今日阻力 ,2 )),Color0000FF;
IF BARSTATUS=2 and c<今日阻力 THEN
DRAWTEXTREL(10,120,'今日阻力:'+NUMTOSTRN(今日阻力 ,2 )),Color00FF00;
IF BARSTATUS=2 and c>=明日支撑 THEN
DRAWTEXTREL(100,50,'明日支撑:'+NUMTOSTRN(明日支撑 ,2 )),Color00FFFF;
IF BARSTATUS=2 and c<明日阻力 THEN
DRAWTEXTREL(100,120,'明日阻力:'+NUMTOSTRN(明日阻力 ,2 )),Color00FFFF;
DRAWTEXTREL(10,160,'------------------------------------'),ColorFFFFFF;

大智慧筹码分析主图指标公式

 

相关文章