在线检测未来函数

大智慧主图叠加MACD和KD指标公式

来源:Internet,编辑:股旁网,2010-08-03

D:=20;
STICKLINE(C>=O,C,O,8,0),COLOR0000AA;
STICKLINE(C>=O,C,O,6,0),COLOR0000bb ;
STICKLINE(C>=O,C,O,4,0),COLOR0000cc ;
STICKLINE(C>=O,C,O,2,0),COLOR0000ee;
STICKLINE(C>=O,H,L,0,0),COLOR0000ff;
STICKLINE(C<=O,C,O,8,0),Color7B7b00;
STICKLINE(C<=O,C,O,6,0),Color909000;
STICKLINE(C<=O,C,O,4,0),ColorA8a800;
STICKLINE(C<=O,C,O,2,0),COLORcece00;
STICKLINE(C<=O,H,L,0,0),COLORffff00;
{股旁网-股票公式网站 www.gupang.com}
A:=EMA(CLOSE,26);
T:=EMA(CLOSE,12);
B:=EMA(A,9);
T1:=EMA(T,9);
DEA:EMA(T-(T1-T),2),linethick0;
DIFF:DEA-EMA(((A-B)-(T-T1)),1)*6,linethick0;
FILLRGN(diff,dea,diff>dea,RGB(100,0,100));
FILLRGN(diff,dea,diff<=dea),Color6C7480;
vAR1:=HHV(DEA,d);
VAR2:=LLV(DEA,d);
VAR3:=DEA-(DIFF-DEA);
UP:IF(DIFF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),COLORbb9a00,LINETHICK1,LAYER0;
DN:IF(DIFF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2),COLORaa00bb,LINETHICK1,LAYER0;
AH:HHV(DIFF,55),COLOR6600ff,linethick2,layer0;
PARTLINE(ah,ah),COLORWHITE,POINTDOT,linethick2,layer0;
DRAWICON( ref(aH=diff,1) and DIFF<REF(DIFF,1),AH,8),ALIGN1,LAYER0;
AL:LLV(DIFF,55),COLOR248a24,linethick2,layer0;
PARTLINE(al,Al),COLORWHITE,POINTDOT,linethick2,layer0;
DRAWICON( ref(al=diff,1) and DIFF>REF(DIFF,1),al,7),ALIGN1,LAYER0;
FILLRGN(UP,DEA,DEA>=UP),coloryellow;
hhZ:=HHV(HIGH,9);
llZ:=LLV(LOW,9);
jc:=ema((hhZ+llZ)/2,9);
bl:=(CLOSE-LLZ)/(HHZ-LLZ);
kz:sma(jc*(1+(BL-0.5)/2),3,1),COLORFFFFFF,dotline;
dz:sma(jc*(SMA(BL,3,1)-0.5)/2+jc,3,1),COLOR00FFFF,dotline;
{jz:=3*kz-2*dz,dotline;}

大智慧主图叠加MACD和KD指标公式

 

相关文章