在线检测未来函数

通达信持仓k线主图指标公式

来源:Internet,编辑:股旁网,2010-08-04

使用说明:红色持股,绿色空仓,白色为预警

{RSI指标}
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
{智慧主图}
X9:=FORCAST(C,9);
LLX:=LLV(FORCAST(C,9),2);
XX9:=X9*100-LLX*100;
DRAWBAND(X9,RGB(255,255,0),LLX,RGB(0,255,0));
D:IF(XX9=0,LLX,DRAWNULL),COLORGREEN;
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
端庄窝:=IF(VAR6A>21,VAR6A-21,0);
{画图}
T1:=(XX9=0 AND 端庄窝<=REF(端庄窝,1));
T2:=(XX9=0 AND 端庄窝>REF(端庄窝,1));
T3:=(XX9>0 AND 端庄窝>REF(端庄窝,1));
T4:=(XX9>0 AND 端庄窝<=REF(端庄窝,1));
T5:=RSI1>=RSI2;
T6:=RSI1<RSI2;
STICKLINE(T1,H,L,0,1),COLORGREEN;
STICKLINE(T1 AND C>O,O,C,3,1),COLORGREEN;
STICKLINE(T1 AND C<O,C,O,3,0),COLORGREEN;
STICKLINE(T2 AND T5,H,L,0,1),COLORWHITE;
STICKLINE(T2 AND T5 AND C>O,O,C,3,1),COLORWHITE;
STICKLINE(T2 AND T5 AND C<O,C,O,3,0),COLORWHITE;
STICKLINE(T2 AND T6,H,L,0,1),COLORGREEN;
STICKLINE(T2 AND T6 AND C>O,O,C,3,1),COLORGREEN;
STICKLINE(T2 AND T6 AND C<O,C,O,3,0),COLORGREEN;
{股旁网-股票公式网站 www.gupang.com}
STICKLINE(T3,H,L,0,1),COLORRED;
STICKLINE(T3 AND C>O,O,C,3,1),COLORRED;
STICKLINE(T3 AND C<O,C,O,3,0),COLORRED;
STICKLINE(T4 AND T5,H,L,0,1),COLORWHITE;
STICKLINE(T4 AND T5 AND C>O,O,C,3,1),COLORWHITE;
STICKLINE(T4 AND T5 AND C<O,C,O,3,0),COLORWHITE;
STICKLINE(T4 AND T6,H,L,0,1),COLORGREEN;
STICKLINE(T4 AND T6 AND C>O,O,C,3,1),COLORGREEN;
STICKLINE(T4 AND T6 AND C<O,C,O,3,0),COLORGREEN;
STICKLINE(T3 AND C<LLX,H,L,0,1),COLORWHITE;
STICKLINE(T3 AND C>O AND C<LLX,O,C,3,1),COLORWHITE;
STICKLINE(T3 AND C<O AND C<LLX,C,O,3,0),COLORWHITE;
{均线}
短线:=MA(CLOSE,6),COLOR0000FF,LINETHICK2;
中线:MA(CLOSE,33),COLORCYAN,LINETHICK2;
多:IF(短线>=中线,中线,DRAWNULL),COLORMAGENTA,LINETHICK2;
空:IF(中线>=短线,中线,DRAWNULL),COLORBLUE,LINETHICK2;
MA250:MA(C,250),LINETHICK2;

通达信持仓k线主图指标公式

 

相关文章