在线检测未来函数

通达信含不同周期的rsi划线指标公式

来源:Internet,编辑:股旁网,2010-08-04

{参数: n3 2.00 500.00 24.00}

N:=8;
80,POINTDOT,COLORGRAY;
20,POINTDOT,COLOR00BCBE;
R:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100,COLORWHITE,LINETHICK3;
A1:=REF(R,N)=HHV(R,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
DRAWLINE(D1,R,S11,R,1),COLORBLUE;
A2:=REF(R,N)=LLV(R,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);{低点}
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
DRAWLINE(D2,R,U11,R,1),COLORBLUE;
M:=INTPART(3*N/5);
A12:=REF(R,M)=HHV(R,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
DRAWLINE(D12,R,S112,R,1),COLORYELLOW;
{股旁网-股票公式网站 www.gupang.com}
A22:=REF(R,M)=LLV(R,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
DRAWLINE(D22,R,U112,R,1),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI3:SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100;
DRAWICON(CROSS(R,RSI3),R,1);
DRAWICON(CROSS(RSI3,R),RSI3,2);

通达信含不同周期的rsi划线指标公式

 

相关文章