在线检测未来函数

通达信BOLL+MA+包络线主图指标公式

来源:Internet,编辑:股旁网,2010-08-05

{BOLL带}
MA26:=MA(C,26);
上轨26:=MA26+2*STD(C,26);
下轨26:=MA26-2*STD(C,26);
{然后画色带}
DRAWBAND(MA26,RGB(100,100,150),上轨26,RGB(100,100,150));
DRAWBAND(MA26,RGB(100,135,190),下轨26,RGB(100,135,190));
{黄金轨道}
CC:=ABS(C-MA(CLOSE,26))/MA(CLOSE,26);
DD:=DMA(CLOSE,CC);
内上:(1+618/10000)*DD,COLORRED,CROSSDOT;
内下:(1-618/10000)*DD,COLORRED,CROSSDOT;
中轴:(内上+内下)/2,COLORBLACK,CROSSDOT;
外上:(1+1236/10000)*DD,COLORCYAN,CROSSDOT;
外下:(1-1236/10000)*DD,COLORCYAN,CROSSDOT;
{股旁网-股票公式网站 www.gupang.com}
{因为画色带遮挡了原来的K线,所以要重做一次K线}
STICKLINE(C>O,H,L,0,0),COLORRED;
STICKLINE(C<=O,H,L,0,0),COLORCYAN;
STICKLINE(C>O,C,O,3.1,1),COLORRED;
STICKLINE(C<=O,C,O,3.1,0),COLORCYAN;
{量能平台}
N:=26;
T1:=CONST(HHVBARS(V,N));
T0:IF(CURRBARSCOUNT<=N+7,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),COLORGREEN;
IF(CURRBARSCOUNT=T1+1,T0,DRAWNULL),CIRCLEDOT,COLORBLUE;
DRAWTEXT(ISLASTBAR,T0,'量能平台'),COLORYELLOW;
{均线}
均线5:MA(C,5),COLORWHITE;
均线24:MA(C,24),COLORYELLOW;
均线72:MA(C,72),COLORMAGENTA;

通达信BOLL+MA+包络线主图指标公式

 

相关文章