在线检测未来函数

通达信用于回调,除权后的支撑和压力画线主图指标公式

来源:Internet,编辑:股旁网,2010-08-06

N:=30;M:=60;{可调}
XSA:=CONST(HHV(H,M));XSC:=CONST(LLV(L,M));
XSB:=((XSA+XSC)/2+XSC)/2;YJ:=ZIG(C,20);
XSD:=((XSA+XSC)/2+XSA)/2;XSE:=(XSA+XSC)/2;
AA:=REF(H,N)=HHV(H,2*N+1); BB:=FILTER(AA,N);
CC:=BACKSET(BB,N+1); DD:=FILTER(CC,N);
EE:=BACKSET(ISLASTBAR,BARSLAST(DD)+1);
FF:=ABS(OPEN+HIGH+LOW+CLOSE)/4;
高:=REF(YJ,2) < REF(YJ,1) AND YJ < REF(YJ,1);
低:=REF(YJ,2) > REF(YJ,1) AND YJ > REF(YJ,1);
DRAWICON(低,L*0.96,1);DRAWICON(高,H*1.02,2);
{股旁网-股票公式网站 www.gupang.com}
生命线:MA(C,30),LINETHICK2,COLORYELLOW;
观望:IF(C<生命线,生命线,DRAWNULL),LINETHICK2,COLOR00DD00;
{3DK线}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(C>O,C,O,3,0),COLOR000099;
STICKLINE(C>O,C,O,2,0),COLOR0000CC;
STICKLINE(C>O,C,O,1,0),COLOR0000FF;
STICKLINE(C>O,C,O,0,0),COLORCC66FF;
STICKLINE(O>=C,C,O,3,0),COLOR777700;
STICKLINE(O>=C,C,O,2,0),COLOR999900;
STICKLINE(O>=C,C,O,1,0),COLORBBBB00;
STICKLINE(O>=C,C,O,0,0),COLOREEEE00;
{线显示}
STICKLINE(EE,XSA,XSA,9,1),COLOR999999;
STICKLINE(EE,XSB,XSB,9,1),COLOR999999;
STICKLINE(EE,XSC,XSC,9,1),COLOR999999;
STICKLINE(EE,XSD,XSD,9,1),COLOR999999;
STICKLINE(EE,XSE,XSE,1,1),COLOR999999;
{大盘现况}
涨家数:INDEXADV,COLOR0000DD,NODRAW;
跌家数:INDEXDEC,COLOR00DD00,NODRAW;
大盘成交量:INDEXV,COLOR00DDDD,NODRAW;

通达信用于回调,除权后的支撑和压力画线主图指标公式

 

相关文章