在线检测未来函数

通达信RSI金叉主图和选股指标公式

来源:Internet,编辑:股旁网,2010-08-09

M1:MA(C,5);
M2:MA(C,21);
M3:MA(C,34);
XG:=CROSS(C,M1) AND REF(EXIST(M1<REF(M1,5),1),1) AND COUNT(M2>M3,10)>=10 AND M2>M3;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
RSI金叉:=CROSS(RSI1,RSI2);
{股旁网-股票公式网站 www.gupang.com}
{SWL:=(EXPMA(CLOSE,5)*7+EXPMA(CLOSE,10)*3)/10;
SWS:=DMA(EMA(CLOSE,12),MAX(1,100*(SUM(VOL,5)/(3*CAPITAL))));}
XGG:={CROSS(SWL,SWS) AND} RSI金叉 AND XG;
DRAWICON(XGG,L-0.25,1);
STICKLINE(XGG,C,O,3,0)COLORYELLOW;
STICKLINE(XGG,L,H,0,0)COLORYELLOW;

选股公式:
M1:=MA(C,5);
M2:=MA(C,21);
M3:=MA(C,34);
XG:=CROSS(C,M1) AND REF(EXIST(M1<REF(M1,5),1),1) AND COUNT(M2>M3,10)>=10 AND M2>M3;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
RSI金叉:=CROSS(RSI1,RSI2);
{SWL:=(EXPMA(CLOSE,5)*7+EXPMA(CLOSE,10)*3)/10;
SWS:=DMA(EMA(CLOSE,12),MAX(1,100*(SUM(VOL,5)/(3*CAPITAL))));}
XGG:{CROSS(SWL,SWS) AND} RSI金叉 AND XG;

通达信RSI金叉主图和选股指标公式

 

相关文章