在线检测未来函数

通达信68000元智慧王私募版之七操盘点位指标公式

来源:Internet,编辑:股旁网,2010-08-07

{参数:
N: 1,10,3
N1:1,100,9
N2: 1,10,6
N3:-50,0,-23
N4:50,100,75
P1:1,100,19
P2:1,250,118
}

VAR2:=(C-REF(C,1))/REF(C,1)*100;
VAR3:=(C-LLV(L,18))/(HHV(H,18)-LLV(L,18))*100;
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
J:3*VAR4-2*VAR5,COLOR00FFFF;
VAR6:=J>1*REF(J,1);
VAR7:=LLVBARS(L,50);
VAR8:=SUM(V,VAR7);
VAR9:=HHVBARS(H,50);
VAR10:=SUM(V,VAR9);
VAR11:=(C-REF(O,VAR9))/REF(O,VAR9)*100;
VAR12:=VAR10/CAPITAL*100;
VAR13:=(C-REF(O,VAR7))/REF(O,VAR7)*100;
VAR14:=VAR8/CAPITAL*100;
VAR15:=MA(WINNER(C),N)*100;
VAR16:=EMA(VAR4,N);
A2:EMA(VAR4,N),COLORFFDDCC;
A3:=EMA(A2,N);
A4:=EMA(A3,N);
A5:=EMA(A4,N);
A6:=EMA(A5,N);
A7:=EMA(A6,N);
VAR17:=EMA(A7,N);
VAR18:=EMA(VAR17,N);
VAR19:=EMA(VAR18,N);
AA:=EMA(A5,N2);
中期大底:LLV(J,AA),LINETHICK2,COLOR0000FF;
上:=IF(MA(H,3)*1.05,30,0)*10-AA;
下:=IF(MA(L,3)*0.96,30,0)*2/中期大底;
中:=IF(MA(H,3)*1.05,30,0);
电:=J;
DRAWTEXT(CROSS(A4,AA) AND VAR11<N3,AA,'●底'),COLORFFFF00;
DRAWTEXT(CROSS(A2,J) AND A2>N4,A2+4.22,'●峰'),COLOR00FFFF;
DRAWTEXT(CROSS(J,A2) AND VAR6 AND A2<20 AND VAR2>9 OR A2>1*REF(A2,1) AND VAR2>4 AND
A2<60,A2,'●拉升'),COLORFFFFCC;
STICKLINE(J>=A2,A2,J,6,0),COLOR0000FF;
STICKLINE(J<=A2,J,A2,6,0),COLOR00FF00;
压力:HHV(J,60),COLOR00FFFF;
支撑:=LLV(AA,13);
STICKLINE(J<=中期大底 AND 中-REF(中,1)>0 AND C>=O*0.99,1,88,3,0),COLOR0000FF;
DRAWICON(J<=中期大底 AND 中-REF(中,1)>0 AND C>=O*0.99,88,1),COLOR00FF00;
STICKLINE(FILTER(CROSS(上,中期大底) AND 中-REF(中,1)>=0,3),中期大底,70,3,0),COLOR00FF00;
DRAWICON(FILTER(CROSS(上,中期大底) AND 中-REF(中,1)>=0,3),70,1);
STICKLINE(CROSS(上,下) AND C>=O,中期大底,60,2,0),COLORFF0000;
B0:=MA(C,3);
B01:=MA(C,4);
B1:=(H+L+C)/3;
B2:=HHV(B1,15);
B3:=LLV(B1,15);
B4:=B2-B3;
B5:MA((B1-B3)/B4,2)*100,COLOR000080;
B6:=HHV(B1,4*15);
B7:=LLV(B1,4*15);
B8:=B6-B7;
B9:=MA((B1-B7)/B8,2)*100;
BA:=HHV(B1,16*15);
BB:=LLV(B1,16*15);
BC:=BA-BB;
BD:=MA((B1-BB)/BC,2)*100;
顶线:=98;
底线:=1;
DRAWTEXT(CROSS(98,B5) AND C<H/1.03,98,'↑出局');

通达信68000元智慧王私募版之七操盘点位指标公式

 

相关文章