在线检测未来函数

大智慧股盲操作K线主图指标公式

来源:Internet,编辑:股旁网,2010-08-07

N1:=5;
N2:=10;
N3:=21;
N4:=60;
牛熊:EMA(CLOSE,N4),COLORGREEN,LINETHICK3;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
DRAWTEXT(IF(B1>0,1,0),L-0.1,'MACD底背'),COLORGREEN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);
DRAWTEXT(IF(B2>0,1,0),L-0.25,'KDJ底背'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);
DRAWTEXT(IF(B3>0,1,0),L-0.4,'RSI底背'),COLORblue;
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(IF(D1>0,1,0),H+0.1,'MACD顶背'),COLORWHITE;
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);
DRAWTEXT(IF(D2>0,1,0),H+0.25,'KDJ顶背'),COLORWHITE;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
DRAWTEXT(IF(D3>0,1,0),H+0.4,'RSI顶背'),COLORyellow;
SG:EMA(HHV(H,1),8),COLORGRAY;
X1:EMA(CLOSE,N1),COLORYELLOW;
JJ:=(H+L+3*C)/5;
VAR21:=EMA(JJ,5);VAR22:=EMA(JJ,13);VAR23:=EMA(JJ,21);VAR24:=EMA(JJ,34);H1A:=(VAR21+VAR22+VAR23+VAR24)/4;
成本和谐:MA(H1A,5),COLORRED,LINETHICK2;
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
LL:=LLV(C,100);
X11:STICKLINE(成本和谐>REF(成本和谐,1) , 成本和谐*0.998,成本和谐*1.002,8,0),COLORRED,LINETHICK2;
X30:=X1<REF(X1,1) AND C<X1;
X31:STICKLINE(SG<REF(SG,1) OR X30, SG*0.998,SG*1.004,8,0),COLORBLUE,LINETHICK3;
X21:STICKLINE(成本和谐<REF(成本和谐,1) , 成本和谐*0.998,成本和谐*1.002,8,0),COLORGRAY,LINETHICK4;
{股旁网-股票公式网站 www.gupang.com}
TJ:=IF((C-REF(C,1))/REF(C,1)>0.025,1,0);
STICKLINE(C>REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),10,0),COLORGREEN;
VAR4:=(LOW+HIGH+CLOSE)/3;
操作: MA(VAR4,5),LINETHICK2,COLORWHITE;
拉升:HHV(操作,13),COLORRED,LINETHICK1;
压力:HHV(操作,60),COLORRED;
买卖:LLV(操作,13),LINETHICK1,COLOR00FF00;
底部支撑: LLV(LOW,60)*1.02,COLOR00CCFF;
顶部: HHV(HIGH,60)*0.98,COLORFFFFCC;
STICKLINE(操作>REF(操作,1),操作,操作+0.018,5,0),COLORYELLOW,LINETHICK4;
STICKLINE(拉升>REF(拉升,1),拉升,拉升+0.018,5,0),COLORYELLOW,LINETHICK2;
STICKLINE(拉升=REF(拉升,1),拉升,拉升,1,1),COLORRED;
STICKLINE(买卖=REF(买卖,1),买卖,买卖,1,1),COLORRED;
STICKLINE(买卖>REF(买卖,1),买卖,买卖+0.028,4,1),COLORF00FF0,LINETHICK2;
STICKLINE(顶部=REF(顶部,1),顶部,顶部,7,1),COLORRED;
STICKLINE(压力=REF(压力,1),压力,压力,7,1),COLORRED;
STICKLINE(底部支撑=REF(底部支撑,1),底部支撑,底部支撑,1,1),COLORRED;

大智慧股盲操作K线主图指标公式

 

相关文章