在线检测未来函数

通达信买卖资金指标公式

来源:Internet,编辑:股旁网,2010-08-12

K1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
K2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
DT:=VOL*K1/(K1+K2);
KT:=VOL-DT;
D5:=100*SUM(DT,5)/CAPITAL;
K5:=100*SUM(KT,5)/CAPITAL;
J5:=D5-K5;
D10:=100*SUM(DT,10)/CAPITAL;
K10:=100*SUM(KT,10)/CAPITAL;
J10:=D10-K10;
D20:=100*SUM(DT,20)/CAPITAL;
K20:=100*SUM(KT,20)/CAPITAL;
J20:=D20-K20;
BL5:=400/MAX(D5,K5);
BL10:=400/MAX(D10,K10);
BL20:=400/MAX(D20,K20);
D5B:=999-D5*BL5;
K5B:=999-K5*BL5;
J5B:=999-ABS(J5)*BL5;
D10B:=999-D10*BL10;
K10B:=999-K10*BL10;
J10B:=999-ABS(J10)*BL10;
D20B:=999-D20*BL20;
K20B:=999-K20*BL20;
J20B:=999-ABS(J20)*BL20;
换手:VOL/CAPITAL*100,NODRAW,COLORYELLOW;
买量:100*DT/CAPITAL,NODRAW,COLORRED;
卖量:100*KT/CAPITAL,NODRAW,COLORGREEN;
进出:100*DT/CAPITAL-100*KT/CAPITAL,NODRAW,COLORMAGENTA;
{股旁网-股票公式网站 www.gupang.com}
五日买:D5,NODRAW,COLORRED;
五日卖:K5,NODRAW,COLORGREEN;
五日进出:J5,NODRAW,COLORMAGENTA;
十日买:D10,NODRAW,COLORRED;
十日卖:K10,NODRAW,COLORGREEN;
十日进出:J10,NODRAW,COLORMAGENTA;
STICKLINE(买量>卖量,0,(买量+卖量+卖量),3,1),COLORRED;
STICKLINE(买量>卖量,0,卖量,2,0),COLORMAGENTA;
STICKLINE(买量>卖量,卖量,(买量+卖量),2,0),COLORYELLOW;
STICKLINE(买量=卖量,0,(买量+卖量+卖量),3,1),COLORRED;
STICKLINE(买量=卖量,0,卖量,2,0),COLORMAGENTA;
STICKLINE(买量=卖量,卖量,(买量+卖量),2,0),COLORYELLOW;
STICKLINE(买量<卖量,0,(买量+卖量),3,0),COLORCYAN;
STICKLINE(买量<卖量,0,卖量,2,0),,COLORMAGENTA;

通达信买卖资金指标公式

 

相关文章